É possível atualizar o MediaInfo no Ubuntu 16.04 LTS?

1. É possível atualizar o MediaInfo no Ubuntu 16.04 LTS?

Kleber Dantas Duarte
kdantas

(usa Outra)

Enviado em 24/05/2021 - 23:19h

Olá pessoal. Espero que vocês consigam me ajudar nessa jornada. De antemão, já vou avisando que meu conhecimento no Linux é limitado a algumas consultas no google. E pra início de conversa, tenho acesso root via SSH no meu servidor. Então vamos lá...

Tenho um servidor com o sistema operacional Ubuntu 16.04 LTS - Xenial Xerus (GNU / Linux 4.9.160-armada375 armv7l). Ou seja, rodando numa máquina com arquitetura Armhf-32. Neste servidor tem instalada uma seedbox (rTorrent/ruTorrent) onde o plugin do MediaInfo está com uma versão antiga da biblioteca (0.7.82-1). Já tentei atualizar o repositório, mas pelo jeito, essa é a última versão disponível.

Infelizmente, nesta versão do MediaInfo, não consigo extrair todos os dados de arquivos de vídeo 4K. Sendo assim, gostaria de saber dos caros colegas com mais experiência no sistema Linux, se há alguma forma para atualizar a versão do MediaInfo sem ser pelo comando update, e que funcione no Ubuntu 16.04 LTS?

Sei que muitos de vocês irão dizer... Então por que não atualiza a versão do Ubuntu? E responderei: Se eu tivesse a certeza que não perderia os dados armazenados na seedbox e todas as suas funcionalidades, até cogitaria essa hipótese. Mas, pelo sim, pelo não, acho melhor deixar como está e tentar instalar uma versão mais atual do MediaInfo, do que arriscar perder todos os dados da seedbox.

E se ainda assim, não for possível fazer essa atualização do MediaInfo no Ubuntu 16.04 LTs, prefiro deixar como está, a arriscar bagunçar o sistema e perder tudo.

Na tentativa de encontrar uma solução para este problema, já mandei uma mensagem para o criador do Plugin MediaInfo e para o criador do MediaInfo. Irei colocar abaixo as respostas de cada um.

[img]https://imgur.com/5fwWEfH.jpg[/img]
O Novik comentou que se poderia fazer uma compilação da fonte. Confesso que não sei pra onde vai tal coisa.

[img]https://imgur.com/WlYZXf2.jpg[/img]
Já o JeromeMartinez sugeriu que tem um versão pra arquitetura armv7l, só que pro Ubuntu 20.04. Será que funcionaria no 16.04 LTS? :-\

Dito isto, caros colegas, se vocês souberem alguma forma para atualizar a versão do MediaInfo (0.7.82-1) instalada no Ubuntu 16.04 LTS, ficarei muito agradecido pela orientação de como proceder para tal. E se vocês responderem que não tem solução, também agradecerei pela atenção ao meu problema. Desde já, um grande abraço a todos.



  


2. Re: É possível atualizar o MediaInfo no Ubuntu 16.04 LTS?

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 25/05/2021 - 00:05h

Muda todos os seus repositórios para o focal fossa e atualiza usando o APT.
Quando terminar desmarca os repositórios para que não de o update no sistema.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


3. Re: É possível atualizar o MediaInfo no Ubuntu 16.04 LTS?

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 25/05/2021 - 01:32h

Ubuntu 16.04 está sem suporte desde Abril 2021
Instale o 18.04 que terá suporte até abril 2023 ou o 20.04 que terá suporte até abril 2025




4. Re: É possível atualizar o MediaInfo no Ubuntu 16.04 LTS?

Ruan
ru4n

(usa Debian)

Enviado em 25/05/2021 - 09:37h

Bom, como já dito, o Ubuntu 16.04 perdeu o suporte. Com isso, os pacotes de terceiros não vão mais ser atualizados para essa versão.

O que você pode fazer também, é usar a versão snap do medianfo:
snap install mediainfo 


O snap fornece sempre as versões mais recentes dos pacotes, e é útil nesses casos onde o ambiente não pode ser atualizado.

Porém, no mundo ideal, é recomendado fazer um upgrade para a versão LTS mais recente, quando for possível.

Se não tiver o snap instalado:
apt install snapd 




5. Re: É possível atualizar o MediaInfo no Ubuntu 16.04 LTS?

Kleber Dantas Duarte
kdantas

(usa Outra)

Enviado em 25/05/2021 - 21:55h


ru4n escreveu:

Bom, como já dito, o Ubuntu 16.04 perdeu o suporte. Com isso, os pacotes de terceiros não vão mais ser atualizados para essa versão.

O que você pode fazer também, é usar a versão snap do medianfo:
snap install mediainfo 


O snap fornece sempre as versões mais recentes dos pacotes, e é útil nesses casos onde o ambiente não pode ser atualizado.

Porém, no mundo ideal, é recomendado fazer um upgrade para a versão LTS mais recente, quando for possível.

Se não tiver o snap instalado:
apt install snapd 



Confesso que fiquei bem animado com a ideia de instalar uma nova versão do mediainfo por esse método. Só tenho minhas dúvidas se será instalado uma versão mais nova do aplicativo MediaInfo, e se o Plugin MediaInfo vai conseguir fazer a ponte entre o aplicativo e a exibição do resultado. De todo modo, apresentou um erro na execução da instalação, conforme linhas de comando abaixo. Conforme os erros eram apresentados, fiz alguns testes de comando também:

[email protected]:~$ sudo apt install snapd
Reading package lists... Done
Building dependency tree
Reading state information... Done
snapd is already the newest version (2.0.2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

[email protected]:~$ sudo snap install mediainfo
[/] Download snap "ubuntu-core" from channel "stable"
error: cannot perform the following tasks:
- Download snap "ubuntu-core" from channel "stable" (snap not found)

[email protected]:~$ sudo snap install ubuntu-core
[/] Download snap "ubuntu-core" from channel "stable"
error: cannot perform the following tasks:
- Download snap "ubuntu-core" from channel "stable" (snap not found)

[email protected]:~$ systemctl status snapd
● snapd.service - Snappy daemon
Loaded: loaded (/lib/systemd/system/snapd.service; static; vendor preset: enabled)
Active: active (running) since Wed 2021-05-26 00:21:14 CEST; 1h 27min ago
Main PID: 5646 (snapd)
Tasks: 8 (limit: 512)
CGroup: /system.slice/snapd.service
└─5646 /usr/lib/snapd/snapd

[email protected]:~$ sudo snap version
error: Unknown command `version'. Please specify one command of: abort, ack, changes, connect, disconnect, find, install, interfaces, known, list, login, logout, refresh or remove

[email protected]:~$ sudo snap find
error: no snaps found

[email protected]:~$


Infelizmente, por esse método, ainda não foi possível instalar uma nova versão do MediaInfo. Se tiver(em) alguma dica como solucionar esse erro, estarei de prontidão.


6. Re: É possível atualizar o MediaInfo no Ubuntu 16.04 LTS?

Kleber Dantas Duarte
kdantas

(usa Outra)

Enviado em 25/05/2021 - 22:05h


aguamole escreveu:

Muda todos os seus repositórios para o focal fossa e atualiza usando o APT.
Quando terminar desmarca os repositórios para que não de o update no sistema.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


Olá @aquamole, poderia da uma passo a passo como faço isso via linha de comando?

Só tenho uma dúvida se o repositório da versão 20.04 LTS não vai causar conflito ou erro ao tentar instalar na versão 16.04 LTS?


7. Re: É possível atualizar o MediaInfo no Ubuntu 16.04 LTS?

Kleber Dantas Duarte
kdantas

(usa Outra)

Enviado em 25/05/2021 - 22:08h


clodoaldops escreveu:

Ubuntu 16.04 está sem suporte desde Abril 2021
Instale o 18.04 que terá suporte até abril 2023 ou o 20.04 que terá suporte até abril 2025



Se eu instalar alguma dessas versões, corro o risco de desconfigurar a seedbox ou perder os arquivos que estão sendo semeados pela seedbox?




8. Re: É possível atualizar o MediaInfo no Ubuntu 16.04 LTS?

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 26/05/2021 - 08:41h

Se você instalar uma nova versão terá que configurar tudo novamente... Ubuntu-LTS tem suporte por 5 anos



9. Re: É possível atualizar o MediaInfo no Ubuntu 16.04 LTS?

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 26/05/2021 - 09:48h

Depende das dependências do mediainfo se tiver que atualizar a base do 16.04 o APT ira atualizar a base o que faria atualizar para o 20.04.
Mas eu nunca testei atualizar do 16.04 direto para o 20.04.
Agora se a base do 16.04 estiver em conforme com o midiainfo então o APT só vai atualizar o necessário das dependência e o mediaindo.
O correto mesmo é que você faça um clone da partição do sistema com o Clonezzila antes de fazer atualização desse mediainfo.
https://pt.wikipedia.org/wiki/Clonezilla
https://clonezilla.org/
https://www.youtube.com/watch?v=1HlfPawHKuE

Tem como escrever um comando para modificar os repositórios do 16.04 para os do 20.04 mas é que se eu errar o comando depois você teria que consertar manualmente o que não seria difícil.

O comando é este:
$ sudo cp /etc/apt/sources.list /etc/apt/sources.list.old && sudo sed -i 's/xenial/focal/' /etc/apt/sources.list; sudo apt-get update 


CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


10. Re: É possível atualizar o MediaInfo no Ubuntu 16.04 LTS?

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 26/05/2021 - 10:57h

Se for atualizar versão faça bkp seus arquivos... Lembre-se que 16.04 usa Unity e 18.04/20.04 usa Gnome... Isso poderá dar problemas principalmente pq 16.04 está morto, obsoleto e sem suporte



11. Re: É possível atualizar o MediaInfo no Ubuntu 16.04 LTS?

Ruan
ru4n

(usa Debian)

Enviado em 26/05/2021 - 13:18h


kdantas escreveu:

Confesso que fiquei bem animado com a ideia de instalar uma nova versão do mediainfo por esse método. Só tenho minhas dúvidas se será instalado uma versão mais nova do aplicativo MediaInfo, e se o Plugin MediaInfo vai conseguir fazer a ponte entre o aplicativo e a exibição do resultado. De todo modo, apresentou um erro na execução da instalação, conforme linhas de comando abaixo. Conforme os erros eram apresentados, fiz alguns testes de comando também:

[email protected]:~$ sudo apt install snapd
Reading package lists... Done
Building dependency tree
Reading state information... Done
snapd is already the newest version (2.0.2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

[email protected]:~$ sudo snap install mediainfo
[/] Download snap "ubuntu-core" from channel "stable"
error: cannot perform the following tasks:
- Download snap "ubuntu-core" from channel "stable" (snap not found)

[email protected]:~$ sudo snap install ubuntu-core
[/] Download snap "ubuntu-core" from channel "stable"
error: cannot perform the following tasks:
- Download snap "ubuntu-core" from channel "stable" (snap not found)

[email protected]:~$ systemctl status snapd
● snapd.service - Snappy daemon
Loaded: loaded (/lib/systemd/system/snapd.service; static; vendor preset: enabled)
Active: active (running) since Wed 2021-05-26 00:21:14 CEST; 1h 27min ago
Main PID: 5646 (snapd)
Tasks: 8 (limit: 512)
CGroup: /system.slice/snapd.service
└─5646 /usr/lib/snapd/snapd

[email protected]:~$ sudo snap version
error: Unknown command `version'. Please specify one command of: abort, ack, changes, connect, disconnect, find, install, interfaces, known, list, login, logout, refresh or remove

[email protected]:~$ sudo snap find
error: no snaps found

[email protected]:~$


Infelizmente, por esse método, ainda não foi possível instalar uma nova versão do MediaInfo. Se tiver(em) alguma dica como solucionar esse erro, estarei de prontidão.


strange

Ative a variável de debug do snap:
echo SNAPD_DEBUG_HTTP=7 >> /etc/environment
source /etc/environment


Depois tenta restartar o processo do snapd:
systemctl restart snapd # (ou matar o processo com pkill snapd) 


Dps tenta novamente os passos de instalação...



12. Re: É possível atualizar o MediaInfo no Ubuntu 16.04 LTS?

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 26/05/2021 - 13:29h

Como 16.04 está sem suporte creio que não será possível instalar e nem atualizar nada... Nem snaps... Nem flatpacks... Nem .deb... Use uma distribuição que tenha suporte




01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts