Desafio [RESOLVIDO]

1. Desafio [RESOLVIDO]

aguinaldo araujo
araujoguina

(usa Ubuntu)

Enviado em 16/08/2008 - 11:14h

Meu provedor é via rádio. Utilizo o ubuntu 8.04. Consigo conectar ao sinal da internet, mas não consigo navegar. Já executei o pppoeconf, informando login e senha. No comando PLOG as seguintes informações surgem:
> using interface PPP0
> connect: PPP0 <--> wlan1
> CHAP authentication succeded: welcome
> CHAP authentication succeded
> peer from calling number 00:06:4F:33:53:D3 authorized
> cannot determine ethernet adress for proxy ARP
> local IP adress 200.223.93.129
> remote IP adress 200.223.189.71
> primary DNS adress 200.223.189.70
> secondary DNS adress 200.223.178.65

Obs.: funciona no Vista sem necessitar informar IP, GATEWAY ou DNS ou qualquer outra configuração. Eu já utilizei uma versão anterior do ubuntu e com os mesmos comandos eu consegui navegar sem problemas.
Outra coisa: a instalação não é particionada. Instalei dentro do Windows e escolho o boot ao ligar o PC.

Quem puder ajudar, desde já agradeço.

Aguinaldo.


  


2. Re: Desafio [RESOLVIDO]

Jefferson Diego
Diede

(usa Debian)

Enviado em 16/08/2008 - 17:31h

Quanto a essas linhas:
primary DNS adress 200.223.189.70
secondary DNS adress 200.223.178.65

Você consegue acessar os DNS's? eles respondem a requisições?
Tente digitar:
nslookup www.google.com
e veja no que dá.


3. Re: Desafio [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 16/08/2008 - 18:42h

Instalou dentro do Windows, que dizer, é máquina virtual?
Costuma dar problemas com wireless!


4. Re: Desafio [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 16/08/2008 - 21:09h

Tente reconfigurar o pppoeconf, para determinar ip dinamico, e um servidor DNS, automaticamente.
Deve resolver.


5. Re: Desafio [RESOLVIDO]

Fábio Berbert de Paula
fabio

(usa Debian)

Enviado em 17/08/2008 - 01:11h

Tente:

$ sudo route add default ppp0

Pode ser problema de rota (geralmente a rota padrão fica pra placa de rede e não pra interface sem fio - que neste caso gerou uma conexão ppp com seu provedor).



6. Re: Desafio [RESOLVIDO]

Luciano Gomes
lucianopqd

(usa Ubuntu)

Enviado em 17/08/2008 - 09:56h

Amigo, acho que internet a Rádio usa apenas DHCP, só isso...


7. Re: Desafio [RESOLVIDO]

aguinaldo araujo
araujoguina

(usa Ubuntu)

Enviado em 17/08/2008 - 10:36h

Obrigado a todos pela ajuda,mas ainda não consegui.

a) ao tentar o "ns lookup www.google.com"; retornou como comando inexistente;
b) o "sudo route add defaut ppp0" gerou "host desconhecido";
c) alterei a instalação p/ disco particionado;

O IWCONFIG retorna:
- lo no wireless extensions
- eth0 no wireless extensions
- wmaster0 no wireless extensions
- wlan1 IEEE 802.11g ESSID:""

O PLOG agora gera:
- timeout waiting for PADO Packets
- unable to complete PPPoE discovery

O PING retorna:
- network is unreachable

Lí alguma coisa sobre alteração no arquivo /etc/network/ interfaces. Vou tentar e informo depois.

obrigado.


8. Re: Desafio [RESOLVIDO]

Andre Antonio da Silva Neto
andre_asn

(usa Slackware)

Enviado em 17/08/2008 - 11:13h

tenha em mãos:

* IP da máquina;
* Gateway;
* Máscara de rede;
* DNS do provedor.


Entre como root:

$ su

Siga os procedimento abaixo:

1. Editando o rc.inet1.conf:

# vi /etc/rc.d/rc.inet1.conf:

Edite e salve com as modificações. O X refere-se à placa de rede (0, 1, 2 ou 3). Esses números dependem de qual está sendo usada para esta conexão/configuração (padrão eth0 - 1 placa de rede).

# /etc/rc.d/rc.inet1.conf:

# Config information for ethX:

IPADDR[X]="coloque_aqui_o_ip_da_máquina"
NETMASK[X]="coloque_aqui_a_máscara_da_rede"
USE_DHCP[X]=""
DHCP_HOSTNAME[X]=""

# Default gateway IP address:

GATEWAY="coloque_aqui_o_gateway"

2. Editando o resolv.conf:

# vi /etc/resolv.conf:

Edite e salve com as modificações:

nameserver: coloque_aqui_o_DNS1
nameserver: coloque_aqui_o_DNS2

3. Editando o rc.modules - habilitando a placa de rede:

# vi /etc/rc.d/rc.modules

Em rc.modules, localize Ethernet cards e Other network hardware drivers. Procure sua placa de rede nessas listas e descomente a linha com o módulo da placa. Se não souber qual sua placa de rede, liste as PCI's:

# lspci

Ou, mais especificamente:

# lspci | grep Ethernet

Em rc.modules, teremos:

#nome_e_modelo_da_placa:
/sbin/modprobe módulo_da_placa

Salve o arquivo com a modificação, e pronto, a sua internet está configurada.



9. Re: Desafio [RESOLVIDO]

aguinaldo araujo
araujoguina

(usa Ubuntu)

Enviado em 17/08/2008 - 11:45h

Companheiros, já estou usando a conexão, obrigado a todos pela força.
O problema estava na ESSID que não segurava o nome da conexão.
Editei o /etc/network/interfaces, que ficou da seguinte forma:

auto lo
iface lo inet loopback

auto dsl-provider
iface dsl-provider inet ppp
pre-up /sbin/ifconfig wlan1 up # line maintained by pppoeconf
provider dsl-provider


auto wlan0 (acrescentei)
iface wlan1 inet dhcp (gerou automaticamente depois que executei novamente o pppoeconf)
wireless-essid ibititaholi (acrescentei)
auto wlan1

O sinal da conexão (dois monitorzinhos) que era substituido por um símbolo igual ao sinal de conexão de celular quando eu clicava na rede sem fio, agora não aparece mais, fica apenas dois monitorzinhos estáticos. Não sei de que forma deveria aparecer. O bom é que estou navegando.

Valeu.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts