Correção de Pacotes

1. Correção de Pacotes

Pedro Henrique dos Santos
pedrodesantis

(usa Ubuntu)

Enviado em 27/06/2019 - 07:57h

Bom dia, estou com esse problema, e não coonsigo atualizar nem instalar nada.

"Verifique se você está utilizando repositórios de terceiros. Se estiver, desabilite-os, já que normalmente são fonte de problemas.
Além disso, execute o seguinte comando em um Terminal: apt-get install -f
Transaction failed: O sistema de pacotes está quebrado
Os seguintes pacotes têm dependências não satisfeitas:

libpng12-dev: Depends: libpng12-0 (= 1.2.54-1ubuntu1) mas não está instalado"


Obrigado


  


2. Re: Correção de Pacotes

Pedro Henrique dos Santos
pedrodesantis

(usa Ubuntu)

Enviado em 27/06/2019 - 11:43h

Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/libpng12-0_1.2.54-1ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



3. Re: Correção de Pacotes

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 27/06/2019 - 12:38h

Comando:
$ sudo dpkg -r libpng12-dev
$ sudo dpkg --configure -a
$ sudo apt-get install -f
$ sudo apt-get update
$ sudo apt-get dist-upgrade
Se resolveu marque o tópico como resolvido!

CPU Q6600 GTX 750 SofRaid 4xSSD 4Gb DDR2 mesmo assim uso Lubuntu.