o sistema detectou um problema no aplicativo. Você gostaria de relatar o problema agora

1. o sistema detectou um problema no aplicativo. Você gostaria de relatar o problema agora

CASSIO FERRAZ
cassio88

(usa Ubuntu)

Enviado em 15/03/2019 - 10:12h

Tenho Ubuntu 2018.04

Desde quinta-feira, o update-notifier apresenta problema, o boot está lento e aparece a mensagem acima. Não aparece na mensagem de erro qual o pacote está causando o problema.

Dei uma olhada em /var/log, mas não sei exatamente qual dos logs poderia me ajudar.

abri o terminal e dei o comando abaixo

sudo apt-get update && sudo apt-get upgrade

A mensagem que apareceu foi:
Lendo listas de pacotes... Pronto
E: Repository 'http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease' changed its 'Label' value from 'Oracle Java (JDK) 8 / 9 Installer PPA' to 'Oracle Java (JDK) 8 Installer PPA'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.

Entrei na configuração do atualizador de programas, desabilitei a opção do java e reiniciei o micro, mas voltou a apresentar o problema.

Alguém me ajuda? Obrigado



  


2. Re: o sistema detectou um problema no aplicativo. Você gostaria de relatar o problema agora

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 15/03/2019 - 10:26h

Vá em programas e atualizações, outros programas, desative todos PPA, feche aplicativo, atualize novamente




3. Re: o sistema detectou um problema no aplicativo. Você gostaria de relatar o problema agora

Ryuk Shinigami
Ryuk

(usa Nenhuma)

Enviado em 15/03/2019 - 14:36h

Mostre a saída desse comando:
grep -Ev '^($|#)' /etc/apt/sources.list{,.d/*.list} 




4. Re: o sistema detectou um problema no aplicativo. Você gostaria de relatar o problema agora

CASSIO FERRAZ
cassio88

(usa Ubuntu)

Enviado em 15/03/2019 - 15:44h

/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ bionic main restricted
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ bionic universe
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ bionic-updates universe
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ bionic multiverse
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
/etc/apt/sources.list:deb http://archive.canonical.com/ubuntu bionic partner
/etc/apt/sources.list:deb-src http://archive.canonical.com/ubuntu bionic partner
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu bionic-security main restricted
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu bionic-security universe
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu bionic-security multiverse

No update-notifier, aba outros programas, parceiros da Canonical ainda estão selecionados (ou seja, ainda não testei a sugestão 2 - do Clodoaldo)



5. Re: o sistema detectou um problema no aplicativo. Você gostaria de relatar o problema agora

Ryuk Shinigami
Ryuk

(usa Nenhuma)

Enviado em 15/03/2019 - 19:01h


cassio88 escreveu:

/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ bionic main restricted
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ bionic universe
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ bionic-updates universe
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ bionic multiverse
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
/etc/apt/sources.list:deb http://archive.canonical.com/ubuntu bionic partner
/etc/apt/sources.list:deb-src http://archive.canonical.com/ubuntu bionic partner
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu bionic-security main restricted
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu bionic-security universe
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu bionic-security multiverse

No update-notifier, aba outros programas, parceiros da Canonical ainda estão selecionados (ou seja, ainda não testei a sugestão 2 - do Clodoaldo)


OK! Apenas os repositórios oficiais do Ubuntu estão ativos. Já fez o update?
sudo apt update 



6. Re: o sistema detectou um problema no aplicativo. Você gostaria de relatar o problema agora

CASSIO FERRAZ
cassio88

(usa Ubuntu)

Enviado em 15/03/2019 - 19:36h

Dei o update, depois o upgrade, daí o reboot. O problema continua. Pode ser apport-autoreport.service (em negrito, quase ao final da listagem abaixo)?

cassio@cassio:~$ sudo apt update
[sudo] senha para cassio:
Atingido:1 http://br.archive.ubuntu.com/ubuntu bionic InRelease
Obter:2 http://br.archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
Atingido:4 http://archive.canonical.com/ubuntu bionic InRelease
Obter:5 http://br.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [552 kB]
Obter:6 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Obter:7 http://br.archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages [472 kB]
Obter:8 http://br.archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages [732 kB]
Obter:9 http://br.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [742 kB]
Baixados 2.751 kB em 2s (1.370 kB/s)
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
8 packages can be upgraded. Run 'apt list --upgradable' to see them.

cassio@cassio:~$ sudo apt upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Calculando atualização... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
libcryptui0a seahorse-daemon
Utilize 'sudo apt autoremove' para os remover.
Os pacotes a seguir serão atualizados:
apport apport-gtk gnome-software gnome-software-common gnome-software-plugin-snap python3-apport python3-problem-report ubuntu-software
8 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 3.251 kB de arquivos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Obter:1 http://br.archive.ubuntu.com/ubuntu bionic-updates/main amd64 python3-problem-report all 2.20.9-0ubuntu7.6 [9.884 B]
Obter:2 http://br.archive.ubuntu.com/ubuntu bionic-updates/main amd64 python3-apport all 2.20.9-0ubuntu7.6 [81,7 kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apport all 2.20.9-0ubuntu7.6 [124 kB]
Obter:4 http://br.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apport-gtk all 2.20.9-0ubuntu7.6 [9.704 B]
Obter:5 http://br.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-software-plugin-snap amd64 3.28.1-0ubuntu4.18.04.8 [28,3 kB]
Obter:6 http://br.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-software amd64 3.28.1-0ubuntu4.18.04.8 [490 kB]
Obter:7 http://br.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gnome-software-common all 3.28.1-0ubuntu4.18.04.8 [2.482 kB]
Obter:8 http://br.archive.ubuntu.com/ubuntu bionic-updates/main amd64 ubuntu-software all 3.28.1-0ubuntu4.18.04.8 [25,3 kB]
Baixados 3.251 kB em 2s (1.878 kB/s)
(Lendo banco de dados ... 197533 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../0-python3-problem-report_2.20.9-0ubuntu7.6_all.deb ...
A descompactar python3-problem-report (2.20.9-0ubuntu7.6) sobre (2.20.9-0ubuntu7.5) ...
A preparar para desempacotar .../1-python3-apport_2.20.9-0ubuntu7.6_all.deb ...
A descompactar python3-apport (2.20.9-0ubuntu7.6) sobre (2.20.9-0ubuntu7.5) ...
A preparar para desempacotar .../2-apport_2.20.9-0ubuntu7.6_all.deb ...
A descompactar apport (2.20.9-0ubuntu7.6) sobre (2.20.9-0ubuntu7.5) ...
A preparar para desempacotar .../3-apport-gtk_2.20.9-0ubuntu7.6_all.deb ...
A descompactar apport-gtk (2.20.9-0ubuntu7.6) sobre (2.20.9-0ubuntu7.5) ...
A preparar para desempacotar .../4-gnome-software-plugin-snap_3.28.1-0ubuntu4.18.04.8_amd64.deb ...
A descompactar gnome-software-plugin-snap (3.28.1-0ubuntu4.18.04.8) sobre (3.28.1-0ubuntu4.18.04.4) ...
A preparar para desempacotar .../5-gnome-software_3.28.1-0ubuntu4.18.04.8_amd64.deb ...
A descompactar gnome-software (3.28.1-0ubuntu4.18.04.8) sobre (3.28.1-0ubuntu4.18.04.4) ...
A preparar para desempacotar .../6-gnome-software-common_3.28.1-0ubuntu4.18.04.8_all.deb ...
A descompactar gnome-software-common (3.28.1-0ubuntu4.18.04.8) sobre (3.28.1-0ubuntu4.18.04.4) ...
A preparar para desempacotar .../7-ubuntu-software_3.28.1-0ubuntu4.18.04.8_all.deb ...
A descompactar ubuntu-software (3.28.1-0ubuntu4.18.04.8) sobre (3.28.1-0ubuntu4.18.04.4) ...
Configurando gnome-software-common (3.28.1-0ubuntu4.18.04.8) ...
A processar 'triggers' para mime-support (3.60ubuntu1) ...
A processar 'triggers' para ureadahead (0.100.0-20) ...
ureadahead will be reprofiled on next reboot
A processar 'triggers' para desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
A processar 'triggers' para libglib2.0-0:amd64 (2.56.3-0ubuntu0.18.04.1) ...
Configurando python3-problem-report (2.20.9-0ubuntu7.6) ...
Configurando gnome-software (3.28.1-0ubuntu4.18.04.8) ...
A processar 'triggers' para systemd (237-3ubuntu10.15) ...
A processar 'triggers' para man-db (2.8.3-2ubuntu0.1) ...
A processar 'triggers' para gnome-menus (3.13.3-11ubuntu1.1) ...
A processar 'triggers' para hicolor-icon-theme (0.17-2) ...
Configurando ubuntu-software (3.28.1-0ubuntu4.18.04.8) ...
Configurando gnome-software-plugin-snap (3.28.1-0ubuntu4.18.04.8) ...
Configurando python3-apport (2.20.9-0ubuntu7.6) ...
Configurando apport (2.20.9-0ubuntu7.6) ...
apport-autoreport.service is a disabled or a static unit, not starting it.
Configurando apport-gtk (2.20.9-0ubuntu7.6) ...


7. Re: o sistema detectou um problema no aplicativo. Você gostaria de relatar o problema agora

Ryuk Shinigami
Ryuk

(usa Nenhuma)

Enviado em 15/03/2019 - 20:26h

apport-autoreport.service is a disabled or a static unit, not starting it.

Não é um ERRO, é apenas um aviso de que o serviço não está ativo.
Apport não é um serviço essencial, ele serve apenas para relatar "falhas" para os desenvolvedores.
Se quer que ele rode normalmente, ative-o:
sudo systemctl enable apport.service