erro na instalação do fglrx, "pacotes mantidos"

1. erro na instalação do fglrx, "pacotes mantidos"

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 20/02/2017 - 19:06h

Pessoal, fiz um downgrade pro Ubuntu 14.04, depois de muito tempo de Manjaro XFCE (sem conseguir configurar minha placa de video), somente para gozar da minha placa de video AMD Radeon bem configurada. E eis que consigo tudo menos instalar o maldito fglrx, tentei pelo "drivers adicionais" e ele sempre volta pra xorg, tentei por synaptic e dá o mesmo erro que no terminal, no terminal dá isso:

[email protected]:~$ sudo apt-get install fglrx gksu
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
gksu já é a versão mais nova.
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
unity-control-center : Depende: libcheese-gtk23 (>= 3.4.0) mas não será instalado
Depende: libcheese7 (>= 3.0.1) mas não será instalado
E: Erro, pkgProblemResolver::Resolve gerou falhas, isto pode ser causado por pacotes mantidos (hold).


entendendo que poderia ser por pacotes quebrados tentei diversos procedimentos diferentes que encontrei aqui no fórum, mas o synaptic não encontra mais pacotes quebrados e realmente não sei mais o que fazer. também não consigo adicionar o repositório que sempre adicionava para baixar o fglrx. o "ppa:ubuntu-x-swat/x-updates".
alguém saberia me ajudar com isso?



  


2. erro na instalação do fglrx, "pacotes mantidos"

Edwal F. Paiva Filho
nicolo

(usa Ubuntu)

Enviado em 20/02/2017 - 19:35h

O problema não é com o driver da placa de vídeo.
Há problemas com o unity-control-center que instalou alguma coisa que não é compatível com as libcheese.

Solução : O objetivo é remover as dependências desencontradas
Sugestão : Instale uma outra interface sugiro XFCE

Inicie uma sessão com XFCE

Desinstale completamente o Unity

Instale as libcheese
Tente instalar o driver novamente.

IMPORTANTE
Verifique se todos os repositórios dão compatíveis e da mesma versão 14.04
Repositórios de PPA e outros alienígenas podem ser a fonte do problema de dependências
desencontradas.



3. Re: erro na instalação do fglrx, "pacotes mantidos"

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 20/02/2017 - 19:43h

nicolo escreveu:

O problema não é com o driver da placa de vídeo.
Há problemas com o unity-control-center que instalou alguma coisa que não é compatível com as libcheese.

Solução : O objetivo é remover as dependências desencontradas
Sugestão : Instale uma outra interface sugiro XFCE

Inicie uma sessão com XFCE

Desinstale completamente o Unity

Instale as libcheese
Tente instalar o driver novamente.

IMPORTANTE
Verifique se todos os repositórios dão compatíveis e da mesma versão 14.04
Repositórios de PPA e outros alienígenas podem ser a fonte do problema de dependências
desencontradas.

quando tu diz pra iniciar uma sessão com xfce seria bootar por um pendrive com uma imagem do xubuntu? dá pra fazer isso de outra forma? eu não saberia desinstalar o Unity (no meu amadorismo fico me perguntando oq ia restar por trás hehe). eu tinha pensado mesmo em tentar limpar a pilha de repositórios que acumulei aqui



4. Re: erro na instalação do fglrx, "pacotes mantidos"

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 23/02/2017 - 09:51h

tentei remover o unity e instalar, mas não deu ainda. acusa um conflito com o gnome-control-center agora.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts