GRUB não inicia

1. GRUB não inicia

Guilherme Parcerão
Lickizard

(usa Ubuntu)

Enviado em 09/07/2019 - 16:12h

Oi pessoal. Eu sou iniciante no Linux e instalei o Ubuntu em dual boot com o Windows, mas toda vez que eu ligo o PC o GRUB simplesmente não aparece, o PC liga e já inicia o Windows direto. Eu já segui as instruções desse artigo, mas não adiantou nada: https://www.edivaldobrito.com.br/recuperando-o-boot-grub-ubuntu-depois-de-instalar-o-windows/
Alguma sugestão do que eu possa fazer?


  


2. Re: GRUB não inicia

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 09/07/2019 - 16:18h

-siga dica que aqui deu certo
https://www.vivaolinux.com.br/artigo/Instalacao-dual-boot-UEFI-Linux-MintUbuntu-com-Windows-8110



3. Menu do GRUB não aparece após instalação do Ubuntu 19.04

Bruno Vasconcelos
brunovasc9

(usa Outra)

Enviado em 11/07/2019 - 12:25h

Tive Ubuntu 18.04 em dual boot com windows 10 por um bom tempo, e porque queria tornar minhas configurações do Ubuntu mais robustas, apaguei a antiga partição e reinstalei com o Ubuntu 19.04. Contudo, quando ligo o computador, o menu do GRUB que costumava aparecer não aparece mais: tenho apenas uma tela preta que fica assim por alguns segundos (cerca de 15), pisca e inicia no Ubuntu. Isto é, se eu quiser entrar no Windows, eu preciso acessar o boot apertando F12.

Já estou há um dia inteiro tentando encontrar uma solução para esse problema, mas não consegui nada ainda. Alguns dos links mais relevantes na minha busca estão colocados abaixo. Como o AskUbuntu não permite a novos usuários fazer perguntas ou comentar em posts, vim aqui no VivaOLinux em busca de ajuda. O que percebi foi que, na tela preta, se eu apertar a seta para baixo duas vezes e apertar enter (o que eu fazia antes para logar no windows), eu, de fato, entro no windows. Isso, junto com o tempo de espera de cerca de 15 segundos, que é aproximadamente o que eu teria de esperar antes para o GRUB logar automaticamente no Ubuntu, depois da contagem de 10 segundos, me levam a crer que o menu ESTÁ LÁ, apenas não aparece.

Baseado nas soluções propostas nesses links, minha última tentativa foi adicionar as linhas que agora marquei com # (para que não sejam executadas, pois a modificação não fizera efeito quando tentei aplicá-las assim) no arquivo de texto grub (/etc/default/grub), aplicando sudo update-grub após as modificações.

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=10
#GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Só estou postando isto esperando que possa ser útil para alguém mais experiente em Linux na resolução desta questão, ou que alguém possa apontar algum procedimento errado que eu tenha feito.

--------------------------------------------------
Links:

https://askubuntu.com/questions/1136036/grub-menu-doesnt-show-up-after-upgrading-to-ubuntu-19-04
https://askubuntu.com/questions/681422/grub-menu-not-showing-with-dual-boot-uefi-mode-installation
https://askubuntu.com/questions/182248/why-is-grub-menu-not-shown-when-starting-my-computer

E também:
https://unix.stackexchange.com/questions/233453/dual-boot-windows-linux-mint-grub-menu-not-appearing...
https://askubuntu.com/questions/111085/how-do-i-hide-the-grub-menu-showing-up-at-the-beginning-of-bo...
https://askubuntu.com/questions/1036091/how-to-set-grub-timeout-to-0-on-ubuntu-18-04








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts