Erro no apt-get install [RESOLVIDO]

1. Erro no apt-get install [RESOLVIDO]

Natanael Roberto Rodrigues
natanaelrodrigue

(usa Outra)

Enviado em 23/03/2021 - 12:00h

Boa tarde Pessoal,

Toda vez que tento dar um apt-get no ubuntu 20.04 ocorre o erro abaixo. Eu instalei o ubuntu na maquina e direcionei os diretórios /home e /var para as unidades que já tinham e estavam sendo utilizadas em uma distribuição da mesma versão.



Configurando php7.4-fpm (7.4.3-4ubuntu2.4) ...
Error: The new file /usr/lib/php/7.4/php.ini-production does not exist!
dpkg: erro ao processar o pacote php7.4-fpm (--configure):
o subprocesso instalado, do pacote php7.4-fpm, o script post-installation retor
nou erro do status de saída 1
Configurando python2.7-minimal (2.7.18-1~20.04.1) ...
# Empty sitecustomize.py to avoid a dangling symlink
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
/usr/bin/python2.7: can't open file '/usr/lib/python2.7/py_compile.py': [Errno 2
] No such file or directory
dpkg: erro ao processar o pacote python2.7-minimal (--configure):
o subprocesso instalado, do pacote python2.7-minimal, o script post-installatio
n retornou erro do status de saída 2
dpkg: problemas com dependências impedem a configuração de python2-minimal:
python2-minimal depende de python2.7-minimal (>= 2.7.17~rc1-1~); porém:
Pacote python2.7-minimal não está configurado ainda.

dpkg: erro ao processar o pacote python2-minimal (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-fpm:
php-fpm depende de php7.4-fpm; porém:
Pacote php7.4-fpm não está configurado ainda.

dpkg: erro ao processar o pacote php-fpm (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de python2.7:
python2.7 depende de python2.7-minimal (= 2.7.18-1~20.04.1); porém:
Pacote python2.7-minimal não está configurado ainda.

dpkg: erro ao processar o pacote python2.7 (--configure):
problemas de dependência - deixando desconfigurado
Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de
seguimento de um erro anterior.
Nenhum relatório apport escrito pois MaxReports j
á foi atingido
Nenhum relatório apport escrito pois MaxReports já foi atingido
Err
os foram encontrados durante o processamento de:
php7.4-fpm
python2.7-minimal
python2-minimal
php-fpm
python2.7
E: Sub-process /usr/bin/dpkg returned an error code (1)



  


2. Re: Erro no apt-get install [RESOLVIDO]

Carlos A. P. Cunha
Carlos_Cunha

(usa Deepin)

Enviado em 23/03/2021 - 16:11h

Esta cheio de pacotes quebrado, tente executar isso:


sudo apt-get install -f


Se o processo for feito com sucesso ai tenta i "install" novamente, se não, poste a saída de erro do comando que passei.


#-------------------------------------------------------------------------------------#
"Falar é fácil, me mostre o código." - Linus Torvalds
#-------------------------------------------------------------------------------------#



3. Re: Erro no apt-get install [RESOLVIDO]

Natanael Roberto Rodrigues
natanaelrodrigue

(usa Outra)

Enviado em 23/03/2021 - 16:21h


Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 1 não atualizados.
5 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Configurando php7.4-fpm (7.4.3-4ubuntu2.4) ...
Error: The new file /usr/lib/php/7.4/php.ini-production does not exist!
dpkg: erro ao processar o pacote php7.4-fpm (--configure):
o subprocesso instalado, do pacote php7.4-fpm, o script post-installation retornou erro do status de saída 1
Configurando python2.7-minimal (2.7.18-1~20.04.1) ...
# Empty sitecustomize.py to avoid a dangling symlink
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
/usr/bin/python2.7: can't open file '/usr/lib/python2.7/py_compile.py': [Errno 2] No such file or directory
dpkg: erro ao processar o pacote python2.7-minimal (--configure):
o subprocesso instalado, do pacote python2.7-minimal, o script post-installation retornou erro do status de saída 2
dpkg: problemas com dependências impedem a configuração de python2-minimal:
python2-minimal depende de python2.7-minimal (>= 2.7.17~rc1-1~); porém:
Pacote python2.7-minimal não está configurado ainda.

dpkg: erro ao processar o pacote python2-minimal (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de php-fpm:
php-fpm depende de php7.4-fpm; porém:
Pacote php7.4-fpm não está configurado ainda.

dpkg: erro ao processar o pacote php-fpm (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de python2.7:
python2.7 depende de python2.7-minimal (= 2.7.18-1~20.04.1); porém:
Pacote python2.7-minimal não está configurado ainda.

dpkg: erro ao processar o pacote python2.7 (--configure):
problemas de dependência - deixando desconfigurado
Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
Nenhum relatório apport escrito pois MaxReports já foi atingido
Nenhum relatório apport escrito pois MaxReports já foi atingido
Erros foram encontrados durante o processamento de:
php7.4-fpm
python2.7-minimal
python2-minimal
php-fpm
python2.7
E: Sub-process /usr/bin/dpkg returned an error code (1)



4. Re: Erro no apt-get install [RESOLVIDO]

5. Re: Erro no apt-get install [RESOLVIDO]

Paulo Jr
Pebis

(usa Debian)

Enviado em 23/03/2021 - 19:55h


Adicionou algum repositório aí???


6. Re: Erro no apt-get install [RESOLVIDO]

Natanael Roberto Rodrigues
natanaelrodrigue

(usa Outra)

Enviado em 23/03/2021 - 22:09h


acabei reinstalando do zero. Já tinha feito várias tentativas de ajustes e não deu certo.


7. Re: Erro no apt-get install [RESOLVIDO]

Carlos A. P. Cunha
Carlos_Cunha

(usa Deepin)

Enviado em 24/03/2021 - 09:05h


natanaelrodrigue escreveu:


acabei reinstalando do zero. Já tinha feito várias tentativas de ajustes e não deu certo.


Melhor que vc fez, seu sistema já estava "muito quebrado", não que não pudesse ser "concertado", mas não sei o esforço(e pelo jeito não) valeria a pena.
Muito cuidado em usar repositórios ou instalar coisas de outras versões ou de outros distros,

#-------------------------------------------------------------------------------------#
"Falar é fácil, me mostre o código." - Linus Torvalds
#-------------------------------------------------------------------------------------#







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts