Enlightenment no Ubuntu

1. Enlightenment no Ubuntu

White Hawk
WhiteHawk

(usa Ubuntu)

Enviado em 12/11/2010 - 22:02h

Olá. Atualmente estou usando o Ubuntu 10.10 com o Gnome. Quero instalar o Enlightenment E17 nele, mas não sei como. Alguém pode me ajudar?


  


2. Re: Enlightenment no Ubuntu

Perfil removido
removido

(usa Nenhuma)

Enviado em 12/11/2010 - 22:21h

Nunca testei o e17 no Ubuntu, somente no Debian e no Arch Linux, o passo que segui é parecido com esse abaixo:

http://maketecheasier.com/run-enlightenment-e17-on-ubuntu-karmic/2010/01/14


Abra seu sources.list com o Gedit:

$ sudo gedit /etc/apt/sources.list

cole isso:

# E17 (Enlightenment).
#deb http://packages.enlightenment.org/ubuntu karmic main extras
deb http://packages.enlightenment.org/ubuntu lucid main extras


Salve, feche o arquivo, instale a chave GPG, atualize as listas de pacotes e instale o ambiente e todos os seus módulos:

$ wget http://packages.enlightenment.org/repo.key -O - | sudo apt-key add -
$ sudo apt-get update
$ sudo apt-get install e17 emodules-all


* caso dê problemas de dependências, é porque o projeto deu uma parada após sair da fase Experimental e ter entrado na fase Alpha, então os pacotes não vem sendo atualizados conforme já falado pelo @terramel, nesse caso o unico meio de tê-lo é instalando pelo SVN ou testando uma distro tipo o Elive.


3. Re: Enlightenment no Ubuntu

Perfil removido
removido

(usa Nenhuma)

Enviado em 13/11/2010 - 00:13h

http://terramel.org/

Este blog que eu linkei tem quatro tutoriais sobre o e17. Desde a instalação até customização e tudo.

Divirta-se.


4. Re: Enlightenment no Ubuntu

White Hawk
WhiteHawk

(usa Ubuntu)

Enviado em 13/11/2010 - 08:05h

Olá. Gedimar, eu já decidi usar Enlightenment justamente pelas fotos que vi neste blog. Mesmo assim, obrigado.

Edps, adicionei as linhas que você me passou ao arquivo sources.list, adicionei a chave GPG e atualizei a lista de pacotes, porém na hora de instalar o e17 e os emodules-all dá um erro.


$ sudo apt-get install e17 emodules-all
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
e17 : Depende: libecore-evas-svn-05 (>= 0.9.9.063) mas não será instalado
Depende: libecore-imf-svn-05 (>= 0.9.9.063) mas não será instalado
Depende: libecore-input-svn-05 (>= 0.9.9.063) mas não será instalado
Depende: libecore-x-svn-05 (>= 0.9.9.063) mas não será instalado
Depende: libedbus-svn-05 (>= 0.5.0.063) mas não será instalado
Depende: libedje-svn-05 (>= 0.9.92.063) mas não será instalado
Depende: libeet1 (>= 1.2.3) mas não será instalado
Depende: libevas-svn-05 (>= 0.9.9.063) mas não será instalado
Depende: libevas-svn-05-engine-software-x11
Depende: libedje-bin mas não será instalado
emodules-all : Depende: emodule-alarm mas não será instalado
Depende: emodule-bling mas não será instalado
Depende: emodule-calendar mas não será instalado
Depende: emodule-configmenu mas não será instalado
Depende: emodule-cpu mas não será instalado
Depende: emodule-deskshow mas não será instalado
Depende: emodule-diskio mas não será instalado
Depende: emodule-drawer mas não será instalado
Depende: emodule-ecomorph mas não será instalado
Depende: emodule-edgar mas não será instalado
Depende: emodule-efm-nav mas não será instalado
Depende: emodule-efm-path mas não será instalado
Depende: emodule-efm-pathbar mas não será instalado
Depende: emodule-eweather mas não será instalado
Depende: emodule-exalt mas não será instalado
Depende: emodule-execwatch mas não será instalado
Depende: emodule-extramenu mas não será instalado
Depende: emodule-flame mas não será instalado
Depende: emodule-iiirk mas não será instalado
Depende: emodule-itask mas não será instalado
Depende: emodule-itask-ng mas não será instalado
Depende: emodule-language mas não será instalado
Depende: emodule-mail mas não será instalado
Depende: emodule-mem mas não será instalado
Depende: emodule-moon mas não será instalado
Depende: emodule-mpdule mas não será instalado
Depende: emodule-net mas não será instalado
Depende: emodule-news mas não será instalado
Depende: emodule-notification mas não será instalado
Depende: emodule-penguins mas não será instalado
Depende: emodule-photo mas não será instalado
Depende: emodule-places mas não será instalado
Depende: emodule-rain mas não será instalado
Depende: emodule-screenshot mas não será instalado
Depende: emodule-slideshow mas não será instalado
Depende: emodule-snow mas não será instalado
Depende: emodule-taskbar mas não será instalado
Depende: emodule-tclock mas não será instalado
Depende: emodule-tiling mas não será instalado
Depende: emodule-trash mas não será instalado
Depende: emodule-uptime mas não será instalado
Depende: emodule-winlist-ng mas não será instalado
Depende: emodule-winselector mas não será instalado
Depende: emodule-wlan mas não será instalado
E: Pacotes quebrados


5. Re: Enlightenment no Ubuntu

Perfil removido
removido

(usa Nenhuma)

Enviado em 13/11/2010 - 09:16h

Eu disse que poderia ocorrer esses erros de dependência, também ocorreu comigo usando o Debian Testing, então... adicionei o repositório do Debian SID e consegui instalar (mas não tem os módulos). Estou com o e17 completinho instalado no Arch Linux.

Para compilar, leia isso, para ver quais são as dependências para a compilação:

http://ubuntuforums.org/showthread.php?t=97199&highlight=E17+cvs

é basicamente isso:

$ sudo apt-get install build-essential cvs libtool libltdl3-dev automake1.9 autotools-dev libpopt-dev libcurl3-dev libx11-dev x11proto-xext-dev libbz2-dev libid3tag0-dev libpng12-dev libtiff4-dev libungif4-dev libjpeg62-dev libssl-dev libfreetype6-dev bison flex xlibs-dev gettext libimlib2-dev libxml2-dev libxcursor-dev libgtk1.2-dev autoconf pkg-config libpng3-dev libxine-dev libxkbfile-dev libsqlite3-dev giblib-dev libxmu-dev libxdamage-dev libxcomposite-dev libtag1-dev libtagc0-dev giblib-dev libasound2-dev libxml2-dev

* mas pode ser que essa lista esteja furada pois o how-to é de 2005. Veja o how-to do terramel:

http://terramel.org/guia-enlightenment-17-parte-2-instalacao/


Outro meio é instalar o e17 através de um único pacote:

http://download.enlightenment.org/snapshots/2010-10-03/enlightenment-0.16.999.52995.tar.gz">http://download.enlightenment.org/snapshots/2010-10-03/enlightenment-0.16.999.52995.tar.gz


Ou você também pode baixar os pacotes individuais e compilar a partir desses endereços:

http://download.enlightenment.org/releases/
http://download.enlightenment.org/snapshots

os pacotes:

http://download.enlightenment.org/releases/e_dbus-1.0.0.beta2.tar.bz2
http://download.enlightenment.org/releases/ecore-1.0.0.beta2.tar.bz2
http://download.enlightenment.org/releases/edje-1.0.0.beta2.tar.bz2
http://download.enlightenment.org/releases/eet-1.4.0.beta2.tar.bz2
http://download.enlightenment.org/releases/eeze-1.0.0.beta2.tar.bz2
http://download.enlightenment.org/releases/efreet-1.0.0.beta2.tar.bz2
http://download.enlightenment.org/releases/eina-1.0.0.beta2.tar.bz2
http://download.enlightenment.org/releases/embryo-1.0.0.beta2.tar.bz2
http://download.enlightenment.org/releases/evas-1.0.0.beta2.tar.bz2






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts