Downgrade GCC

1. Downgrade GCC

Rafael Felippe dos Santos Cortez Pereira
RafaeFelippe

(usa OpenSuSE)

Enviado em 20/01/2009 - 08:17h

Olá pessoal,

Utilizo o OpenSuse 10.3 e preciso da ajuda de vc que sao mais experientes que eu. Baixei um .tar.gz de uma aplicacoa que preciso instalar, mas ao rodar o comando MAKE é inciado a compilacao mas em determinado momento é exibida mensagem de erro informadno que a versao do compilador nao é conhecida.

Apesar de meu GCC ser mais novo (versao 4.2) li em outros lugares que o ideal seria compilar este source com o gcc 3.3, por isto gostaria de saber como fazer para instalar o gcc 3.3 em minha maquina. E tambem queria saber se realmente versoes diferentes do mesmo compilador podem influenciar na compilacao de sources, como no meu caso, onde imagino ter q fazer um downgrade do gcc

Muito obrigado pela ajuda.


  


2. Re: Downgrade GCC

carlo valente
cvalente

(usa openSUSE)

Enviado em 20/01/2009 - 16:52h

gcc 3.3 :http://packages.opensuse-community.org/index.jsp?searchTerm=gcc&distro=openSUSE_103

Não sei se vai dar algum conflito entre as duas versões; talvez seja melhor desinstalar a 4.2 antes.


3. 4.2

Gabriel Duarte Guimarães Costa
gabrield

(usa Debian)

Enviado em 20/01/2009 - 17:17h

O que você quer compilar!? Derrepende há outras opcões ao invés do downgrade!


4. Re: Downgrade GCC

Gabriel Duarte Guimarães Costa
gabrield

(usa Debian)

Enviado em 20/01/2009 - 17:19h

Um projeto no qual isso acontece é o QEMU, que só compila com o GCC série 3.
[]'s






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts