QGIS

1. QGIS

WGuedes
wguedes

(usa Ubuntu)

Enviado em 19/05/2019 - 16:10h

Caros Linuxeres

Seguindo orientações internet, instalei, recentemente, a versão 6,3 do QGIS, que vinha funcionando bem – exceto por algumas quebras, as quais, segundo me consta, são "normais" do QGIS.

Ontem, porém, o atualizador do UBUNTU trouxe-me a informação de que eu deveria fazer uma atualização parcial do sistema, o que justificava com falhas apresentadas devidas, provavelmente, a instalações de aplicativos não oriundos dos repositórios UBUNTU e que, por isto, não seria possível uma atualização completa. A instalação foi feita a partir do site do QGIS.

Eu não fazia ideia de que, aplicativos oriundos de outras fontes, poderiam dar tilti e aceitei a atualização parcial.

Depois, aceitei a solicitação de remoção de pacotes obsoletos que, segundo o sistema, eram inúmeros.

Hoje, buscando dar sequência ao meu aprendizado de QGIS, fui procurar o ícone que me dá acesso a ele e... surpresa: ele havia sumido. Procurei-o, desesperadamente, sem sucesso.

Dos aplicativos instalados juntamente com o QGIS, conforme a tal orientação, somente o SAGA continua lá; o resto se foi.

Sem problema: os arquivos que produzi com o QGIS estão salvos, sendo bastante instalá-lo novamente.

Recorri, novamente, à preciosa orientação e, chegando o devido momento, comandei: sudo apt-get install qgis python-qgis qgis-plugin-grass saga, como da primeira vez

Ao comando dado seguiram-se as linhas abaixo, das quais a última explica este contato.

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
saga is already the newest version (2.3.1+dfsg-4~bionic1).
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
python-qgis : Depende: python3-qgis mas não será instalado
qgis : Depende: gdal-abi-2-2-3
Depende: libqgis-analysis3.6.3 mas não será instalado
Depende: libqgis-app3.6.3 mas não será instalado
Depende: python3-qgis (= 1:3.6.3+28bionic) mas não será instalado
qgis-plugin-grass : Depende: grass740
Depende: libqgis-app3.6.3 mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Já busquei elucidar essa questão, mas não senti muita firmeza nas respostas que encontrei. Assim, gostaria de saber se há alguma ajuda que essa galera genial me possa fornecer e, mesmo que não possa, fico-lhes muito grato, desde já, pela atenção.

Saudações LIVRES,
WGuedes


  


2. Re: QGIS

Carlos
caffilhobr

(usa openSUSE)

Enviado em 20/05/2019 - 15:48h

Boa Tarde

Você ao instalar o QGIS seguiu a recomendação oficial abaixo?

https://www.qgis.org/pt_BR/site/forusers/alldownloads.html#debian-ubuntu

Como você removeu o QGIS? Utilizou os comandos abaixo?

sudo apt-get remove qgis
sudo apt-get remove --auto-remove qgis









Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts