Instalação de pacotes para VLC

1. Instalação de pacotes para VLC

Max Victor Henriques Corrêa
imortalpro

(usa Ubuntu)

Enviado em 02/04/2017 - 10:07h

Bom dia galera, estou com muitos problemas para instalar os pacotes de dependência para o VLC.
Seguem os códigos digitados e os resultados:

[email protected]:~/Downloads$ sudo apt-get install vlc
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
libgl1-mesa-glx : Depende: libglapi-mesa (= 17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial) mas 11.2.0-1ubuntu2 está para ser instalado
libglapi-mesa : Quebra: libglapi-mesa:i386 (!= 11.2.0-1ubuntu2) mas 17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial está para ser instalado
libglapi-mesa:i386 : Quebra: libglapi-mesa (!= 17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial) mas 11.2.0-1ubuntu2 está para ser instalado
libgles2-mesa : Depende: libglapi-mesa (= 17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial) mas 11.2.0-1ubuntu2 está para ser instalado
vlc : Depende: vlc-nox (= 2.2.2-5ubuntu0.16.04.1) mas não será instalado
Depende: libgles1-mesa (>= 7.8.1) mas não será instalado ou
libgles1
Depende: libsdl-image1.2 (>= 1.2.10) mas não será instalado
Depende: libva-drm1 (>= 1.1.0) mas não será instalado
Depende: libva-x11-1 (>= 1.0.3) mas não será instalado
Depende: libvlccore8 (>= 2.2.0) mas não será instalado
Recomenda: vlc-plugin-notify (= 2.2.2-5ubuntu0.16.04.1) mas não será instalado
Recomenda: vlc-plugin-samba (= 2.2.2-5ubuntu0.16.04.1) mas não será instalado
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).
[email protected]:~/Downloads$


ao digitar "apt-get -f install" :

[email protected]:~/Downloads$ sudo apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
The following additional packages will be installed:
libglapi-mesa
Os pacotes a seguir serão atualizados:
libglapi-mesa
1 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
2 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/66,4 kB de arquivos.
Depois desta operação, 7.168 B adicionais de espaço em disco serão usados.
Você quer continuar? [S/n]


(Lendo banco de dados ... 375446 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../libglapi-mesa_17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial_amd64.deb ...
A descompactar libglapi-mesa:amd64 (17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial) sobre (11.2.0-1ubuntu2) ...
dpkg: erro ao processar o arquivo /var/cache/apt/archives/libglapi-mesa_17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial_amd64.deb (--unpack):
a tentar sobreescrever '/usr/share/doc/libglapi-mesa/changelog.Debian.gz' partilhado, que é diferente de outras instâncias do pacote libglapi-mesa:amd64
A processar 'triggers' para libc-bin (2.23-0ubuntu7) ...
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link

Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/libglapi-mesa_17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Eu já usei o purge e tentei instalar os pacotes todos de novo, já removi algumas ppas e coloquei outras, baixei manualmente vários pacotes mas não consegui resolver, fui na ppa do libglapi-mesa e do libgles1-mesa para baixar manualmente porém não consigo resolver isso, por favor me ajudem e me expliquem o que está acontecendo.


  


2. Re: Instalação de pacotes para VLC

Jalison Vieira Lima
Jalison2000

(usa Debian)

Enviado em 02/04/2017 - 10:29h

1º Você usa que sistema operacional?
2° Você não precisa de PPA para instalar o VLC.


3. Re: Instalação de pacotes para VLC

Antonio Thomacelli
tonnytg

(usa Outra)

Enviado em 02/04/2017 - 10:32h

Bom dia,
primeiro vamos deixar claro que os erros estão relacionado aos pacotes da placa de vídeo.
Isso provavelmente está acontecendo porque há uma mistura de pacotes i386 com x64_86,
ele está tentando instalar o pacote ( amd64 ) e da erro dizendo que já existe esses arquivos na máquina.

O erro está nessa linha :

libglapi-mesa : Quebra: libglapi-mesa:i386

Em algum momento, você teve a necessidade de instalar a versão 32bits, e agora o vlc está tendo que instalar o 64bits que conflita com o outro.





dpkg: erro ao processar o arquivo /var/cache/apt/archives/libglapi-mesa_17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial_amd64.deb (--unpack):
a tentar sobreescrever '/usr/share/doc/libglapi-mesa/changelog.Debian.gz'

Parece que apesar dele te avisar que vai dar erro, ele tenta descompactar o pacote e instalar,
mas na hora que ele acha um arquivo já existente, ele para o processo. Talvez, com cuidado, você mover esse arquivo para outro lugar e tentar de novo, se der o mesmo erro, volte com ele para o lugar.

Att,
Antonio Thomacelli Gomes
http://www.tonnytg.com.br
LPIC-2 Certified Linux Engineers


4. Re: Instalação de pacotes para VLC

Max Victor Henriques Corrêa
imortalpro

(usa Ubuntu)

Enviado em 03/04/2017 - 01:30h

Jalison2000 escreveu:

1º Você usa que sistema operacional?
2° Você não precisa de PPA para instalar o VLC.


Desculpe a demora, uso Ubuntu 16.04 Xenial
Eu instalei uma ppa do videolan que é a distribuidora do vlc, achei q era necessário.


5. Re: Instalação de pacotes para VLC

Max Victor Henriques Corrêa
imortalpro

(usa Ubuntu)

Enviado em 03/04/2017 - 01:32h

tonnytg escreveu:

Bom dia,
primeiro vamos deixar claro que os erros estão relacionado aos pacotes da placa de vídeo.
Isso provavelmente está acontecendo porque há uma mistura de pacotes i386 com x64_86,
ele está tentando instalar o pacote ( amd64 ) e da erro dizendo que já existe esses arquivos na máquina.

O erro está nessa linha :

libglapi-mesa : Quebra: libglapi-mesa:i386

Em algum momento, você teve a necessidade de instalar a versão 32bits, e agora o vlc está tendo que instalar o 64bits que conflita com o outro.





dpkg: erro ao processar o arquivo /var/cache/apt/archives/libglapi-mesa_17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial_amd64.deb (--unpack):
a tentar sobreescrever '/usr/share/doc/libglapi-mesa/changelog.Debian.gz'

Parece que apesar dele te avisar que vai dar erro, ele tenta descompactar o pacote e instalar,
mas na hora que ele acha um arquivo já existente, ele para o processo. Talvez, com cuidado, você mover esse arquivo para outro lugar e tentar de novo, se der o mesmo erro, volte com ele para o lugar.

Att,
Antonio Thomacelli Gomes
http://www.tonnytg.com.br
LPIC-2 Certified Linux Engineers


Cara, muito obrigado, as coisas começaram a fazer sentido agora, eu vou ler novamente com calma depois que tiver tempo e fazer os procedimentos.


6. Instalação de pacotes para VLC

Edwal F. Paiva Filho
nicolo

(usa Ubuntu)

Enviado em 03/04/2017 - 10:36h

Desinstale o tal videolan de ppa que não é necessário.

Eu uso o vlc não precisa de nenhum pacote alien.

Reinicie a máquina.
Instale o VLC

Dica para visualizar o tamanho a encrenca.

sudo apt-get install synaptic
sudo synaptic.

Esse gerenciador de pacotes (synaptic) é gráfico e permite selecionar o que está instalado
e você visualiza na tela.
O pacote encrencado 'tá em vermelho.




7. Re: Instalação de pacotes para VLC

Max Victor Henriques Corrêa
imortalpro

(usa Ubuntu)

Enviado em 04/04/2017 - 17:44h

Ok, mesmo movendo o arquivo que o amigo disse acima não consegui resolver o problema.
Removi todas as PPAs e modifiquei minha sources.list para uma versão bem básica.
Mesmo assim ainda não consegui resolver o problema, alguma sugestão?


8. Re: Instalação de pacotes para VLC

Perfil removido
removido

(usa Nenhuma)

Enviado em 04/04/2017 - 18:27h

sudo nano /etc/apt/sources.list
# Main
deb http://ftp.br.debian.org/debian jessie main contrib non-free
# Security
deb http://security.debian.org/ jessie/updates main contrib non-free
# Updates
deb http://ftp.br.debian.org/debian/ jessie-updates main contrib non-free

sudo rm -rf /etc/apt/sources.list.d/*
sudo rm -rf /var/lib/apt/lists/*
sudo apt-get clean
sudo apt-get update
sudo apt-get -f install



9. Re: Instalação de pacotes para VLC

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 04/04/2017 - 18:51h

Para que complicar, veja a dica do que fazer após instalar Ubuntu 16.04
https://www.vivaolinux.com.br/dica/O-que-fazer-apos-instalar-Ubuntu-1604-LTS

**********************************************
Meu Blog
http://dicaslinuxmint.blogspot.com.br/


10. Re: Instalação de pacotes para VLC

Max Victor Henriques Corrêa
imortalpro

(usa Ubuntu)

Enviado em 04/04/2017 - 19:31h

PauloHAC escreveu:

sudo nano /etc/apt/sources.list
# Main
deb http://ftp.br.debian.org/debian jessie main contrib non-free
# Security
deb http://security.debian.org/ jessie/updates main contrib non-free
# Updates
deb http://ftp.br.debian.org/debian/ jessie-updates main contrib non-free

sudo rm -rf /etc/apt/sources.list.d/*
sudo rm -rf /var/lib/apt/lists/*
sudo apt-get clean
sudo apt-get update
sudo apt-get -f install


Eu uso Ubuntu, não Debian, porém fiz os passos que disse aplicando esses repositórios no meu sources.list:
#------------------------------------------------------------------------------#
# OFFICIAL UBUNTU REPOS #
#------------------------------------------------------------------------------#


###### Ubuntu Main Repos
deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse

###### Ubuntu Update Repos
deb http://archive.ubuntu.com/ubuntu xenial-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu xenial-proposed main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu xenial-security main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu xenial-proposed main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse


Seguem as saídas do terminal:

[email protected]:/etc/apt$ sudo pluma sources.list
[email protected]:/etc/apt$ sudo rm -rf /etc/apt/sources.list.d/*
[email protected]:/etc/apt$ sudo rm -rf /var/lib/apt/lists/*
[email protected]:/etc/apt$ sudo apt-get clean
[email protected]:/etc/apt$ sudo apt-get update
Obter:2 http://archive.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Obter:3 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Obter:4 http://archive.ubuntu.com/ubuntu xenial-proposed InRelease [253 kB]
Obter:5 http://archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Obter:1 http://archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
Obter:6 http://archive.ubuntu.com/ubuntu xenial-security/main Sources [67,2 kB]
Obter:7 http://archive.ubuntu.com/ubuntu xenial-security/restricted Sources [2.600 B]
Obter:8 http://archive.ubuntu.com/ubuntu xenial-security/universe Sources [26,5 kB]
Obter:9 http://archive.ubuntu.com/ubuntu xenial-security/multiverse Sources [1.144 B]
Obter:10 http://archive.ubuntu.com/ubuntu xenial-security/main amd64 Packages [243 kB]
Obter:11 http://archive.ubuntu.com/ubuntu xenial-security/main i386 Packages [234 kB]
Obter:12 http://archive.ubuntu.com/ubuntu xenial-security/main Translation-en [103 kB]
Obter:13 http://archive.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [54,2 kB]
Obter:14 http://archive.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [42,4 kB]
Obter:15 http://archive.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages [7.428 B]
Obter:16 http://archive.ubuntu.com/ubuntu xenial-security/restricted i386 Packages [7.432 B]
Obter:17 http://archive.ubuntu.com/ubuntu xenial-security/restricted Translation-en [2.428 B]
Obter:18 http://archive.ubuntu.com/ubuntu xenial-security/restricted amd64 DEP-11 Metadata [200 B]
Obter:19 http://archive.ubuntu.com/ubuntu xenial-security/universe amd64 Packages [108 kB]
Obter:20 http://archive.ubuntu.com/ubuntu xenial-security/universe i386 Packages [95,0 kB]
Obter:21 http://archive.ubuntu.com/ubuntu xenial-security/universe Translation-en [55,2 kB]
Obter:22 http://archive.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [32,2 kB]
Obter:23 http://archive.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [37,0 kB]
Obter:24 http://archive.ubuntu.com/ubuntu xenial-security/multiverse amd64 Packages [2.748 B]
Obter:25 http://archive.ubuntu.com/ubuntu xenial-security/multiverse i386 Packages [2.912 B]
Obter:26 http://archive.ubuntu.com/ubuntu xenial-security/multiverse Translation-en [1.232 B]
Obter:27 http://archive.ubuntu.com/ubuntu xenial-security/multiverse amd64 DEP-11 Metadata [212 B]
Obter:28 http://archive.ubuntu.com/ubuntu xenial-security/multiverse DEP-11 64x64 Icons [29 B]
Obter:29 http://archive.ubuntu.com/ubuntu xenial-updates/main Sources [239 kB]
Obter:30 http://archive.ubuntu.com/ubuntu xenial-updates/restricted Sources [2.996 B]
Obter:31 http://archive.ubuntu.com/ubuntu xenial-updates/universe Sources [149 kB]
Obter:32 http://archive.ubuntu.com/ubuntu xenial-updates/multiverse Sources [5.268 B]
Obter:33 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [508 kB]
Obter:33 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [508 kB]
Obter:34 http://archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [497 kB]
Obter:35 http://archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [205 kB]
Obter:36 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [288 kB]
Obter:37 http://archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [185 kB]
Obter:38 http://archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages [7.776 B]
Obter:39 http://archive.ubuntu.com/ubuntu xenial-updates/restricted i386 Packages [7.792 B]
Obter:40 http://archive.ubuntu.com/ubuntu xenial-updates/restricted Translation-en [2.548 B]
Obter:41 http://archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 DEP-11 Metadata [157 B]
Obter:42 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [453 kB]
Obter:43 http://archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [438 kB]
Obter:44 http://archive.ubuntu.com/ubuntu xenial-updates/universe Translation-en [173 kB]
Obter:45 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [160 kB]
Obter:46 http://archive.ubuntu.com/ubuntu xenial-updates/universe DEP-11 64x64 Icons [188 kB]
Obter:47 http://archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 Packages [8.920 B]
Obter:48 http://archive.ubuntu.com/ubuntu xenial-updates/multiverse i386 Packages [7.720 B]
Obter:49 http://archive.ubuntu.com/ubuntu xenial-updates/multiverse Translation-en [4.136 B]
Obter:50 http://archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [2.520 B]
Obter:51 http://archive.ubuntu.com/ubuntu xenial-updates/multiverse DEP-11 64x64 Icons [7.765 B]
Obter:52 http://archive.ubuntu.com/ubuntu xenial-proposed/main Sources [85,2 kB]
Obter:53 http://archive.ubuntu.com/ubuntu xenial-proposed/universe Sources [32,1 kB]
Obter:54 http://archive.ubuntu.com/ubuntu xenial-proposed/multiverse Sources [2.536 B]
Obter:55 http://archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages [106 kB]
Obter:56 http://archive.ubuntu.com/ubuntu xenial-proposed/main i386 Packages [103 kB]
Obter:57 http://archive.ubuntu.com/ubuntu xenial-proposed/main Translation-pt_BR [278 kB]
Obter:58 http://archive.ubuntu.com/ubuntu xenial-proposed/main Translation-pt [212 kB]
Obter:59 http://archive.ubuntu.com/ubuntu xenial-proposed/main Translation-en [39,3 kB]
Obter:60 http://archive.ubuntu.com/ubuntu xenial-proposed/main amd64 DEP-11 Metadata [126 kB]
Obter:61 http://archive.ubuntu.com/ubuntu xenial-proposed/main DEP-11 64x64 Icons [90,1 kB]
Obter:62 http://archive.ubuntu.com/ubuntu xenial-proposed/restricted Translation-pt_BR [1.812 B]
Obter:63 http://archive.ubuntu.com/ubuntu xenial-proposed/restricted Translation-pt [1.788 B]
Obter:64 http://archive.ubuntu.com/ubuntu xenial-proposed/restricted amd64 DEP-11 Metadata [201 B]
Obter:65 http://archive.ubuntu.com/ubuntu xenial-proposed/universe amd64 Packages [47,5 kB]
Obter:66 http://archive.ubuntu.com/ubuntu xenial-proposed/universe i386 Packages [45,5 kB]
Obter:67 http://archive.ubuntu.com/ubuntu xenial-proposed/universe Translation-pt_BR [1.107 kB]
Obter:68 http://archive.ubuntu.com/ubuntu xenial-proposed/universe Translation-pt [778 kB]
Obter:69 http://archive.ubuntu.com/ubuntu xenial-proposed/universe Translation-en [20,8 kB]
Obter:70 http://archive.ubuntu.com/ubuntu xenial-proposed/universe amd64 DEP-11 Metadata [1.256 B]
Obter:71 http://archive.ubuntu.com/ubuntu xenial-proposed/universe DEP-11 64x64 Icons [5.127 B]
Obter:72 http://archive.ubuntu.com/ubuntu xenial-proposed/multiverse amd64 Packages [2.728 B]
Obter:73 http://archive.ubuntu.com/ubuntu xenial-proposed/multiverse i386 Packages [3.056 B]
Obter:74 http://archive.ubuntu.com/ubuntu xenial-proposed/multiverse Translation-pt_BR [25,6 kB]
Obter:75 http://archive.ubuntu.com/ubuntu xenial-proposed/multiverse Translation-pt [11,7 kB]
Obter:76 http://archive.ubuntu.com/ubuntu xenial-proposed/multiverse Translation-en [1.760 B]
Obter:77 http://archive.ubuntu.com/ubuntu xenial-proposed/multiverse amd64 DEP-11 Metadata [2.368 B]
Obter:78 http://archive.ubuntu.com/ubuntu xenial-proposed/multiverse DEP-11 64x64 Icons [2.639 B]
Obter:79 http://archive.ubuntu.com/ubuntu xenial-backports/main Sources [3.304 B]
Obter:80 http://archive.ubuntu.com/ubuntu xenial-backports/universe Sources [1.868 B]
Obter:81 http://archive.ubuntu.com/ubuntu xenial-backports/main amd64 Packages [4.684 B]
Obter:82 http://archive.ubuntu.com/ubuntu xenial-backports/main i386 Packages [4.684 B]
Obter:83 http://archive.ubuntu.com/ubuntu xenial-backports/main Translation-en [3.216 B]
Obter:84 http://archive.ubuntu.com/ubuntu xenial-backports/main amd64 DEP-11 Metadata [3.328 B]
Obter:85 http://archive.ubuntu.com/ubuntu xenial-backports/main DEP-11 64x64 Icons [29 B]
Obter:86 http://archive.ubuntu.com/ubuntu xenial-backports/restricted amd64 DEP-11 Metadata [194 B]
Obter:87 http://archive.ubuntu.com/ubuntu xenial-backports/universe amd64 Packages [2.512 B]
Obter:88 http://archive.ubuntu.com/ubuntu xenial-backports/universe i386 Packages [2.508 B]
Obter:89 http://archive.ubuntu.com/ubuntu xenial-backports/universe Translation-en [1.216 B]
Obter:90 http://archive.ubuntu.com/ubuntu xenial-backports/universe amd64 DEP-11 Metadata [212 B]
Obter:91 http://archive.ubuntu.com/ubuntu xenial-backports/universe DEP-11 64x64 Icons [29 B]
Obter:92 http://archive.ubuntu.com/ubuntu xenial-backports/multiverse amd64 DEP-11 Metadata [216 B]
Obter:93 http://archive.ubuntu.com/ubuntu xenial-backports/multiverse DEP-11 64x64 Icons [29 B]
Obter:94 http://archive.ubuntu.com/ubuntu xenial/main Sources [868 kB]
Obter:95 http://archive.ubuntu.com/ubuntu xenial/restricted Sources [4.808 B]
Obter:96 http://archive.ubuntu.com/ubuntu xenial/universe Sources [7.728 kB]
Obter:97 http://archive.ubuntu.com/ubuntu xenial/multiverse Sources [179 kB]
Obter:98 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages [1.201 kB]
Obter:99 http://archive.ubuntu.com/ubuntu xenial/main i386 Packages [1.196 kB]
Obter:100 http://archive.ubuntu.com/ubuntu xenial/main Translation-pt_BR [278 kB]
Obter:101 http://archive.ubuntu.com/ubuntu xenial/main Translation-pt [212 kB]
Obter:102 http://archive.ubuntu.com/ubuntu xenial/main Translation-en [568 kB]
Obter:103 http://archive.ubuntu.com/ubuntu xenial/main amd64 DEP-11 Metadata [733 kB]
Obter:104 http://archive.ubuntu.com/ubuntu xenial/main DEP-11 64x64 Icons [409 kB]
Obter:105 http://archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages [8.344 B]
Obter:106 http://archive.ubuntu.com/ubuntu xenial/restricted i386 Packages [8.684 B]
Obter:107 http://archive.ubuntu.com/ubuntu xenial/restricted Translation-pt_BR [1.812 B]
Obter:108 http://archive.ubuntu.com/ubuntu xenial/restricted Translation-pt [1.788 B]
Obter:109 http://archive.ubuntu.com/ubuntu xenial/restricted Translation-en [2.908 B]
Obter:110 http://archive.ubuntu.com/ubuntu xenial/restricted amd64 DEP-11 Metadata [186 B]
Obter:111 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages [7.532 kB]
Obter:112 http://archive.ubuntu.com/ubuntu xenial/universe i386 Packages [7.512 kB]
Obter:113 http://archive.ubuntu.com/ubuntu xenial/universe Translation-pt_BR [1.107 kB]
Obter:114 http://archive.ubuntu.com/ubuntu xenial/universe Translation-pt [778 kB]
Obter:115 http://archive.ubuntu.com/ubuntu xenial/universe Translation-en [4.354 kB]
Obter:116 http://archive.ubuntu.com/ubuntu xenial/universe amd64 DEP-11 Metadata [3.410 kB]
Obter:117 http://archive.ubuntu.com/ubuntu xenial/universe DEP-11 64x64 Icons [7.448 kB]
Obter:118 http://archive.ubuntu.com/ubuntu xenial/multiverse amd64 Packages [144 kB]
Obter:119 http://archive.ubuntu.com/ubuntu xenial/multiverse i386 Packages [140 kB]
Obter:120 http://archive.ubuntu.com/ubuntu xenial/multiverse Translation-pt_BR [25,6 kB]
Obter:121 http://archive.ubuntu.com/ubuntu xenial/multiverse Translation-pt [11,7 kB]
Obter:122 http://archive.ubuntu.com/ubuntu xenial/multiverse Translation-en [106 kB]
Obter:123 http://archive.ubuntu.com/ubuntu xenial/multiverse amd64 DEP-11 Metadata [63,8 kB]
Obter:124 http://archive.ubuntu.com/ubuntu xenial/multiverse DEP-11 64x64 Icons [230 kB]
Baixados 45,9 MB em 15min 52s (48,2 kB/s)
Lendo listas de pacotes... Pronto
[email protected]:/etc/apt$ sudo apt-get -f install
[sudo] senha para max:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... falhou.
Os pacotes a seguir têm dependências desencontradas:
libgl1-mesa-glx : Depende: libglapi-mesa (= 17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial) mas 11.2.0-1ubuntu2 está instalado
libglapi-mesa : Quebra: libglapi-mesa:i386 (!= 11.2.0-1ubuntu2) mas 17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial está instalado
libglapi-mesa:i386 : Quebra: libglapi-mesa (!= 17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial) mas 11.2.0-1ubuntu2 está instalado
libgles2-mesa : Depende: libglapi-mesa (= 17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial) mas 11.2.0-1ubuntu2 está instalado
E: Erro, pkgProblemResolver::Resolve gerou falhas, isto pode ser causado por pacotes mantidos (hold).
E: Impossível corrigir dependências
[email protected]:/etc/apt$


Creio que somente esta parte é importante:

Os pacotes a seguir têm dependências desencontradas:
libgl1-mesa-glx : Depende: libglapi-mesa (= 17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial) mas 11.2.0-1ubuntu2 está instalado
libglapi-mesa : Quebra: libglapi-mesa:i386 (!= 11.2.0-1ubuntu2) mas 17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial está instalado
libglapi-mesa:i386 : Quebra: libglapi-mesa (!= 17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial) mas 11.2.0-1ubuntu2 está instalado
libgles2-mesa : Depende: libglapi-mesa (= 17.0.1+git20170319+17.0.07adc57f-0ubuntu0ricotz~xenial) mas 11.2.0-1ubuntu2 está instalado
E: Erro, pkgProblemResolver::Resolve gerou falhas, isto pode ser causado por pacotes mantidos (hold).
E: Impossível corrigir dependências


Não sei como resolver essas dependências.


11. Re: Instalação de pacotes para VLC

Max Victor Henriques Corrêa
imortalpro

(usa Ubuntu)

Enviado em 04/04/2017 - 19:33h

nicolo escreveu:

Desinstale o tal videolan de ppa que não é necessário.

Eu uso o vlc não precisa de nenhum pacote alien.

Reinicie a máquina.
Instale o VLC

Dica para visualizar o tamanho a encrenca.

sudo apt-get install synaptic
sudo synaptic.

Esse gerenciador de pacotes (synaptic) é gráfico e permite selecionar o que está instalado
e você visualiza na tela.
O pacote encrencado 'tá em vermelho.



Tenho o Synaptic instalado, porém ele não resolve os problemas.

Abri o Synaptic e fui na lista de "Dependências Quebradas", estavam lá os seguintes pacotes:
[img]https://image.ibb.co/kXuiAa/1.png[/img]

Ao clicar em aplicar a seguinte mensagem foi exibida:
[img]https://image.ibb.co/eS0C3v/2.png[/img]


12. Re: Instalação de pacotes para VLC

Patrick
Freud_Tux

(usa Outra)

Enviado em 04/04/2017 - 20:08h

Seu sistema é de 32 ou 64 bits?

A confusão como apontado pelo brother anteriormente está nessa nomenclatura meu caro.
Se usa máquina com pacotes de 32 bits e quer usar de 64, tem que prestar atenção aos procedimentos, principalmente as dependências que podem acabar nessa encrenca no qual você está agora. E vice-versa.

Deixe somente os pacotes da versão que o seu sistema usa, fazendo uma limpeza, depois atualize tudo e veja se as mensagens continuam. É como fazer uma cirurgia de remoção de um corpo estranho, onde só vai dar certo, quando todo o corpo estranho for removido, entendeu.

E só então, tente usar os repositórios para instalar o que se queira.

T+



01 02