quando ativo o roteamento não consigo acessar a internet

1. quando ativo o roteamento não consigo acessar a internet

Douglas Gaigher
douglas.ti.br

(usa Debian)

Enviado em 30/04/2009 - 15:55h

Olá galera,

Estou com o seguinte problema:

Tenho um debian 4 com 2 placas de rede, uma conectada ao roteador e outra a minha LAN.
Configurei um firewall basico, quando vou distribuir a internet para a LAN acontece de meu debian para de acessar a internet!

Ocorre quando executo o seguinte comando: echo 1 > /proc/sys/net/ipv4/ip_forward

Quando eu altero o 1 por 0, volta a acessar a internet.

Ou seja, nao consigo fazer o Roteamento funcionar.

Alguem sabe o q pode ser ou como diagnosticar meu problema?

Obrigado!


  


2. Re: quando ativo o roteamento não consigo acessar a internet

daniel silva
danielbsilva2

(usa Debian)

Enviado em 30/04/2009 - 16:10h

tenta esse comando desse jeito e ve se resolve seu problema
lembrando que onde ta aí eth0, seria a interface que está conectada direto no seu modem/roteador



# modprobe iptable_nat
# echo 1 > /proc/sys/net/ipv4/ip_forward
# iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE


3. Re: quando ativo o roteamento não consigo acessar a internet

Douglas Gaigher
douglas.ti.br

(usa Debian)

Enviado em 30/04/2009 - 16:21h

Obrigado, amigo, mas o problema esta justamente neste comando: echo 1 > /proc/sys/net/ipv4/ip_forward. Quando coloco 1 a internet para. Quando coloco 0, a maq volta a acessar a internet...

Não consigo entender...






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts