eterno problema MSN/SQUID só funciona com gambiarra

1. eterno problema MSN/SQUID só funciona com gambiarra

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/07/2012 - 09:03h

Bom Dia, tenho um problema já faz algum tempo.

Bom quando eu seto o proxy no Internet Explorer, vou em configuração avançada do msn, coloco o login do proxy e senha do proxy, clico em testar... aparece a mensagem de "exito" ou seja está funcionando a autenticacao.

Mas quando eu mando conectar não conecta, antigamente funcionava a configuração do proxy de msn..

O engraçado é que o msn conecta quando eu tiro o proxy do internet explorer, mesmo utilizando o msn-proxy, ou até mesmo sem utilizar msn-proxy o problema ocorre... (Quando coloco o proxy do internet explorer automaticamente vai para o proxy do msn) será que tem como habilitar o proxy do internet explorer, mas não habilitar o proxy do msn ?

Para resolver eu instalo o firefox nas maquinas, e deixo o internet explorer sem proxy.. assim funciona tudo, mas tem usuarios que não gostam do firefox e preferem o internet explorer, até mesmo alguns sites de bancos só funciona com o mesmo.

Gostaria de resolver sem gambiarra, ou até mesmo colocando o proxy no MSN. Porém o msn não conecta quando coloco o usuario proxy e senha do mesmo, sendo que o usuário está totalmente liberado.


  


2. Re: eterno problema MSN/SQUID só funciona com gambiarra

Phillip Vieira
phrich

(usa Slackware)

Enviado em 09/07/2012 - 10:41h

Cara, vc tem um outro tópico igual a este, eu não lembro se eu coloquei no outro tópico, mas vc já adicionou a porta do msn no squid.conf?


3. Re: eterno problema MSN/SQUID só funciona com gambiarra

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/07/2012 - 12:00h

Não seria a porta 1863 no iptables ?

No squid eu coloquei isso tb e não adianta, tem algumas maquinas que não conectam, outras conectam;


#### ACL LIBERACAO MSN
acl MSN req_mime_type -i ^application/x-msn-messenger$
acl dll_MSN url_regex -i gateway.dll
acl dll2_MSN url_regex -i sqmserver.dll
acl msncontact url_regex -i contacts.msn.com contacts.msn.com:443
acl msn_domains url_regex -i gateway.dll login.live.com login.live.com:443 loginnet.passport.com loginnet.passport.com:443 msn.com messenger.hotmail.com microsoft.com passport.net sqmserver.dll contacts.msn.com msn.com:443 sqm.microsoft$
acl msncontatos dstdomain contacts.msn.com
acl msncontatos2 urlpath_regex contacts.msn.com
acl msnd dstdomain messenger.msn.com gateway.messenger.hotmail.com byrdr.omega.contacts.msn.com contacts.msn.com local-bay.contacts.msn.com by2.storage.msn.com
#### FIM ACL
#### LIBERACAO MSN
http_access allow msncontatos
http_access allow msncontatos2
http_access allow msnd
http_access allow MSN
http_access allow dll_MSN
http_access allow dll2_MSN
http_access allow msncontact
http_access allow msn_domains
#### FIM LIBERACAO



gostaria que o msn conecta-se sem SQUID, o problema é que conecta sem o proxy somente tirando o proxy do internet explorer.

Meu usuario do proxy tb está totalmente liberado (queria conectar sem ele, porém coloquei tb para tentar funcionar de outro modo). mas nada funciona.


acl admins_proxy proxy_auth "/etc/squid/users/admins_proxy"
http_access allow admins_proxy password



4. Re: eterno problema MSN/SQUID só funciona com gambiarra

Phillip Vieira
phrich

(usa Slackware)

Enviado em 09/07/2012 - 12:04h

Na parte do squid.conf que fala sobre as portas, ou seja, acl ports... adicione uma regra com o mesmo nome colocando a porta 1863.


Por exemplo, se vc tem uma regra acl Safe_ports porta crie uma acl abaixo dela com o mesmo nome:

acl Safe_ports 1863

E depois realize o teste ok?


5. Re: eterno problema MSN/SQUID só funciona com gambiarra

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/07/2012 - 16:19h

Fiz o teste e não deu certo.

Colocando o usuario e senha no proxy do msn aparece isso no squid:



1341858778.065 2137 192.168.0.119 TCP_MISS/200 497 POST http://messenger.hotmail.com/gateway/gateway.dll?Action=open&Server=NS&IP=messenger.hotmail.... - DIRECT/65.54.52.62 application/x-msn-messenger
1341858810.834 4721 192.168.0.119 TCP_MISS/200 4991 CONNECT login.live.com:443 - DIRECT/65.54.165.169 -
1341858852.507 0 192.168.0.119 TCP_DENIED/407 1848 POST http://ssw.live.com/uploaddata.aspx - NONE/- text/html



agora eu liberei na regra acima o endereço ssw*... porém não conecta.



1341859026.782 3998 192.168.0.119 TCP_MISS/200 7005 CONNECT loginnet.passport.com:443 - DIRECT/64.4.12.97 -
1341859049.856 1359 192.168.0.119 TCP_MISS/200 5023 CONNECT login.live.com:443 - DIRECT/65.54.186.77 -
1341859057.255 4461 192.168.0.119 TCP_MISS/200 5023 CONNECT login.live.com:443 - DIRECT/65.54.186.107 -
1341859061.256 1307 192.168.0.119 TCP_MISS/200 5023 CONNECT login.live.com:443 - DIRECT/65.54.186.109 -
1341859065.312 1418 192.168.0.119 TCP_MISS/200 5023 CONNECT login.live.com:443 - DIRECT/65.54.165.136 -
1341859067.092 1664 192.168.0.119 TCP_MISS/200 340 POST http://ssw.live.com/uploaddata.aspx - DIRECT/65.55.93.46 -


todos os dias aparecem endereços novos, ou seja libera 1 dia no segundo não funciona. alguém tem uma solução ?


6. Re: eterno problema MSN/SQUID só funciona com gambiarra

Phillip Vieira
phrich

(usa Slackware)

Enviado em 09/07/2012 - 16:43h

pq vc não libera o endereço live.com da seguinte maneira:

acl msn url_regex -i .live.com*
http_access allow msn


Assim, mesmo que tenha ms1.live.com/qqrcoisa ou qqrcoisa.live.com ou até mesmo qqrcoisa.live.com/outracoisa ele irá liberar todos estes endereços pois ele vai liberar tudo o que vier antes e depois do domínio live.com então mesmo q o endereço mude, o domínio será o mesmo...

Testa desta forma e veja se não funciona e nos conte é claro ;-)


7. Re: eterno problema MSN/SQUID só funciona com gambiarra

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/07/2012 - 16:48h

Bom, como falei ta complicado o msn.

Vou fazer isso, mas como mostrei no último log, não aparece nenhum DENIED, e não estava conectando.

Agora no windows eu desabilitei a opção "revogar certificado do servidor" e conectou. Mas não vou ficar feliz pq conectou, eu sei que está semana alguma máquina vai encomodar novamente.


8. Re: eterno problema MSN/SQUID só funciona com gambiarra

Phillip Vieira
phrich

(usa Slackware)

Enviado em 09/07/2012 - 17:16h

Apareceu um DENIED sim:

1341858852.507 0 192.168.0.119 TCP_DENIED/407 1848 POST http://ssw.live.com/uploaddata.aspx - NONE/- text/html

Bom, tenha mais esperança de q tudo vai dar certo ;-)

e quando der tudo certo, nos conte ok?


9. Re: eterno problema MSN/SQUID só funciona com gambiarra

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/07/2012 - 17:54h

sim apareceu o DENIED, porém eu liberei o endereço sw. e não apareceu mais... mesmo assim o msn não estava conectando. Porém quando tirei a opção de revogação de certificado conectou. O Problema é que conecta hj, porém na próxima semana já não posso da certeza que tudo vai estar funcionando. Somente comigo acontece estes problemas de msn ? Obrigado


10. Re: eterno problema MSN/SQUID só funciona com gambiarra

Phillip Vieira
phrich

(usa Slackware)

Enviado em 10/07/2012 - 14:05h

vc liberou o endereço ou vc liberou o live.com? assim como seus-subdomínios?


11. Re: eterno problema MSN/SQUID só funciona com gambiarra

Phillip Vieira
phrich

(usa Slackware)

Enviado em 10/07/2012 - 14:13h

Vou alterar algumas coisas na sua conf:

### ACL LIBERACAO MSN
acl dll_MSN url_regex -i gateway.dll
acl dll_MSN url_regex -i sqmserver.dll
acl MSN url_regex -i "/etc/squid3/msn_domains"


#### FIM ACL
#### LIBERACAO MSN
http_access allow MSN
http_access allow dll_MSN
#### FIM LIBERACAO

Como vc pode ver, eu reduzi algumas confs, e se a acl for do mesmo tipo, vc pode usar o mesmo nome para elas, dentro do arquivo "/etc/squid3/msn_domains", coloque o seguinte conteúdo:

.msn.com*
.msn.com:443*
.live.com*
.live.com:443*
.passport.com*
.passport.com:443*
.msn.com*
.hotmail.com*
.microsoft.com*
.passport.net*
.sqmserver.dll*
.sqm.microsoft$

Da mesma forma acima e um por linha, assim vc vai deixar a sua conf mais limpa e organizada, além de liberar todos os subdomínios dos domínios listados.

Teste ai e depois nos fale, caso dê errado, post seu squid.conf ok?


12. Re: eterno problema MSN/SQUID só funciona com gambiarra

johnny borges
johnnyb

(usa Fedora)

Enviado em 11/07/2012 - 10:34h

como ta seu firewall ?
tente liberar a porta diretamente no firewall
poste seu firewall
e a saida de iptables -L





01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts