SquidGuard

1. SquidGuard

Fernando
fndiaz

(usa CentOS)

Enviado em 23/02/2010 - 12:24h

Tenho instalado o squid e o squidGurad...no meu servidor CentOS

porém o squidGuard não está rodando!!!
Com o comando #tail /var/log/squidguard/squidGuard.log

ele me retorna:
2010-02-23 11:17:36 [4629] init domainlist /var/lib/squidguard/db/blacklists/aggressive/domains
2010-02-23 11:17:36 [4629] loading dbfile /var/lib/squidguard/db/blacklists/aggressive/domains.db
2010-02-23 11:17:36 [4629] init urllist /var/lib/squidguard/db/blacklists/aggressive/urls
2010-02-23 11:17:36 [4629] loading dbfile /var/lib/squidguard/db/blacklists/aggressive/urls.db
2010-02-23 11:17:36 [4629] init domainlist /var/lib/squidguard/db/blacklists/[*****]/domains
2010-02-23 11:17:36 [4629] loading dbfile /var/lib/squidguard/db/blacklists/[*****]/domains.db
2010-02-23 11:17:36 [4629] init urllist /var/lib/squidguard/db/blacklists/[*****]/urls
2010-02-23 11:17:36 [4629] loading dbfile /var/lib/squidguard/db/blacklists/[*****]/urls.db
2010-02-23 11:17:36 [4629] squidguard: ACL source default{ is not defined in configfile /etc/squid/squidguard.conf
2010-02-23 11:17:36 [4629] going into emergency mode

Alguem tem ideia o que pode ser??




  


2. Re: SquidGuard

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 23/02/2010 - 12:32h

De acordo com a linha abaixo:

2010-02-23 11:17:36 [4629] squidguard: ACL source default{ is not defined in configfile /etc/squid/squidguard.conf

há algum erro d digitação no seu squidguard.conf. Poste ele aki pra gente v.


3. Re: SquidGuard

Fernando
fndiaz

(usa CentOS)

Enviado em 23/02/2010 - 12:43h

Certo amigo...fiz uma configuração pequena pra teste, aí vai ela:

dbhome /var/lib/squidguard/db
logdir /var/log/squidguard

dest aggressive{
domainlist blacklists/aggressive/domains
urllist blacklists/aggressive/urls
}

dest [*****]{
domainlist blacklists/[*****]/domains
urllist blacklists/[*****]/urls
}


acl{
default{
pass !aggressive ![*****] all
redirect http://www.ligvoipbrasil.com.br
}
}



4. Re: SquidGuard

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 23/02/2010 - 14:10h

Kra, não vejo nada d estranho na sua config, mas, pra desencargo d consciência, modifique essa parte, deixando assim:

acl {
default {
pass all !aggressive ![*****]
redirect http://www.ligvoipbrasil.com.br
}
}

E quando vc declarar os "dest", d um espaço entre a chave e o nome. Ex.:

dest [*****] {
...


5. Re: SquidGuard

Fernando
fndiaz

(usa CentOS)

Enviado em 24/02/2010 - 08:18h

O erro continua...


6. Re: SquidGuard

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 24/02/2010 - 09:38h

Uma pergunta: aonde q se encontra o seu arquivo d configuração do squidGuard.conf? O caminho é /etc/squid/squidGuard.conf msm?

Vc deixou seu arquivo de configuração dessa forma?

#######################################################################
dbhome /var/lib/squidguard/db
logdir /var/log/squidguard

dest aggressive {
domainlist blacklists/aggressive/domains
urllist blacklists/aggressive/urls
}

dest [*****] {
domainlist blacklists/[*****]/domains
urllist blacklists/[*****]/urls
}


acl {
default {
pass all !aggressive ![*****]
redirect http://www.ligvoipbrasil.com.br
}
}
#####################################################################


7. Re: SquidGuard

Fernando
fndiaz

(usa CentOS)

Enviado em 24/02/2010 - 09:47h

O arquivoi se encontra neste local msmo, note que é squidguard.conf e não squidGuard.conf >> /etc/squid/squidguard.conf

e o conteudo do arquivo é esse mesmo que vc postou!!


8. Re: SquidGuard

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 24/02/2010 - 09:57h

Vamos debugar essa parada então. Digite:

echo "http://www.pornhub.com localhost/- - GET" | /usr/local/bin/squidGuard -c /etc/squid/squidguard.conf -d

Considerando q esteja fazendo o teste na máquina q o squidguard está instalado. Poste o resultado aki.


9. Re: SquidGuard

Fernando
fndiaz

(usa CentOS)

Enviado em 24/02/2010 - 10:49h

Blza.....só vou alterar parte do caminho do arquivo, pois no meu caso o endereço certo é >> /usr/bin/squidGuard

o comando retornou:

2010-02-24 10:45:38 [9580] init domainlist /var/lib/squidguard/db/blacklists/aggressive/domains
2010-02-24 10:45:38 [9580] loading dbfile /var/lib/squidguard/db/blacklists/aggressive/domains.db
2010-02-24 10:45:38 [9580] init urllist /var/lib/squidguard/db/blacklists/aggressive/urls
2010-02-24 10:45:38 [9580] loading dbfile /var/lib/squidguard/db/blacklists/aggressive/urls.db
2010-02-24 10:45:38 [9580] init domainlist /var/lib/squidguard/db/blacklists/[*****]/domains
2010-02-24 10:45:38 [9580] loading dbfile /var/lib/squidguard/db/blacklists/[*****]/domains.db
2010-02-24 10:45:38 [9580] init urllist /var/lib/squidguard/db/blacklists/[*****]/urls
2010-02-24 10:45:38 [9580] loading dbfile /var/lib/squidguard/db/blacklists/[*****]/urls.db
2010-02-24 10:45:38 [9580] squidGuard 1.2.0 started (1267019138.273)
2010-02-24 10:45:38 [9580] squidGuard ready for requests (1267019138.274)

2010-02-24 10:45:38 [9580] squidGuard stopped (1267019138.275)



10. Re: SquidGuard

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 24/02/2010 - 12:15h

Ele não tá redirecionando a página. Coloque na linha do redirect isso:

redirect 302:http://www.ligvoipbrasil.com.br

E tente debugar d novo.


11. Re: SquidGuard

Fernando
fndiaz

(usa CentOS)

Enviado em 24/02/2010 - 12:27h

Poderia me explicar como vc sabe que ele não está redirecionando???

Tentei com a linha do redirect que vc me falou...e retornou a msma coisa

2010-02-24 12:24:21 [9983] init domainlist /var/lib/squidguard/db/blacklists/aggressive/domains
2010-02-24 12:24:21 [9983] loading dbfile /var/lib/squidguard/db/blacklists/aggressive/domains.db
2010-02-24 12:24:21 [9983] init urllist /var/lib/squidguard/db/blacklists/aggressive/urls
2010-02-24 12:24:21 [9983] loading dbfile /var/lib/squidguard/db/blacklists/aggressive/urls.db
2010-02-24 12:24:21 [9983] init domainlist /var/lib/squidguard/db/blacklists/[*****]/domains
2010-02-24 12:24:21 [9983] loading dbfile /var/lib/squidguard/db/blacklists/[*****]/domains.db
2010-02-24 12:24:21 [9983] init urllist /var/lib/squidguard/db/blacklists/[*****]/urls
2010-02-24 12:24:21 [9983] loading dbfile /var/lib/squidguard/db/blacklists/[*****]/urls.db
2010-02-24 12:24:21 [9983] squidGuard 1.2.0 started (1267025061.040)
2010-02-24 12:24:21 [9983] squidGuard ready for requests (1267025061.041)

2010-02-24 12:24:21 [9983] squidGuard stopped (1267025061.044)



12. Re: SquidGuard

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 24/02/2010 - 12:34h

Vou t dar um exemplo do meu aki:

# echo "http://www.pornhub.com localhost/- - GET" | squidGuard -c /etc/squid/squidGuard.conf -d
2010-02-24 12:35:00 [7891] New setting: dbhome: /var/squidGuard/db
2010-02-24 12:35:00 [7891] New setting: logdir: /var/log/squid
2010-02-24 12:35:00 [7891] init expressionlist /var/squidGuard/db/blacklists/extensions/expressions
2010-02-24 12:35:00 [7891] init domainlist /var/squidGuard/db/blacklists/[*****]/domains
2010-02-24 12:35:00 [7891] loading dbfile /var/squidGuard/db/blacklists/[*****]/domains.db
2010-02-24 12:35:00 [7891] init urllist /var/squidGuard/db/blacklists/[*****]/urls
2010-02-24 12:35:00 [7891] loading dbfile /var/squidGuard/db/blacklists/[*****]/urls.db
2010-02-24 12:35:00 [7891] squidGuard 1.4 started (1267025700.104)
2010-02-24 12:35:00 [7891] squidGuard ready for requests (1267025700.233)
2010-02-24 12:35:00 [7891] source not found
2010-02-24 12:35:00 [7891] no ACL matching source, using default
2010-02-24 12:35:00 [7891] Request(default/adult/-) http://www.pornhub.com localhost/- - GET REDIRECT
302:http://10.62.0.100/cgi-bin/squidGuard.cgi?clientaddr=localhost&clientname=&clientuser=&clientgroup=default&targetgroup=adult&url=http://www.pornhub.com localhost/- - GET
2010-02-24 12:35:00 [7891] squidGuard stopped (1267025700.306)

Note nas últimas linhas o redirecionamento. Eu tou suspeitando q o banco d dados do seu squidGuard não foi criado. Vc o criou com o comando:

# squidGuard -C all

E vc deu permissão d leitura pro squid sobre os db's?

# chown -R squid:squid /var/lib/squidGuard/db/*

Faça isso e tente d novo.



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts