Squid nao inicia [RESOLVIDO]

1. Squid nao inicia [RESOLVIDO]

davidson clayton de carvalho
dclayton2509

(usa Red Hat)

Enviado em 27/04/2009 - 13:27h

Bom galera do com o seguinte problema no meu squid ele nao inicia corretamente

Apr 27 12:41:28 srvnet squid[4264]: Squid Parent: child process 4307 started
Apr 27 12:41:28 srvnet (squid): Cannot open '/var/log/squid/access.log' for writing. The parent directory must be writeable by the user 'squid', which is the cache_effective_user set in squid.conf.
Apr 27 12:41:28 srvnet squid[4264]: Squid Parent: child process 4307 exited due to signal 6
Apr 27 12:41:28 srvnet squid[4264]: Exiting due to repeated, frequent failures



  


2. MELHOR RESPOSTA

Elgio Schlemer
elgio

(usa OpenSuSE)

Enviado em 27/04/2009 - 15:36h

Apesar do meu post anterior, acredito que a seguinte sequencia de comandos resolva o teu problema:

chown -R squid /var/log/squid
chmod 750 /var/log/squid
chmod 640 /var/log/squid/*
/etc/init.d/squid restart



3. Re: Squid nao inicia [RESOLVIDO]

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 27/04/2009 - 13:32h

D permissão d escrita no diretório d logs do squid:

# chmod 777 /var/log/squid


4. Squid não inicia

Jakson Galeti
jgaleti

(usa Ubuntu)

Enviado em 27/04/2009 - 13:36h

Caro colega, verifica as permissões do arquivo que ele esta reclamando:
/var/log/squid/access.log

Primeiro verifique as permissões do arquivo:
ls -l /var/log/squid/access.log

Aqui no meu esta assim
-rwxr-xr-x 1 squid squid 512011600 Apr 27 13:30 /var/log/squid/access.log

Ajuste as permissões:
Permisssão: 755 e dono tem que ser o squid.
chmod 755 /var/log/squid/access.log
chown squid:squid /var/log/squid/access.log

Verifica se esta configuração basta para você


5. Re: Squid nao inicia [RESOLVIDO]

davidson clayton de carvalho
dclayton2509

(usa Red Hat)

Enviado em 27/04/2009 - 13:59h

Caros amigos,

Dei permissao 777 para as pastas mas mesmo assim ocorreu o mesmo erro.


Exiting due to repeated, frequent failures.




6. squid

jose claudio
LinuxTec

(usa Debian)

Enviado em 27/04/2009 - 15:15h

Boa tarde amigo estava com esse mesmo problema e resolvi dando um stop no squid reiniciei o pc e dei um start novamente esse problema realmente é de permissão mais não vai adiantar vc sair dando permissão pois seu squid não ira responder..
Faz o seguinte /etc/squid/init.d stop
shutdown -h now
/etc/squid/init.d start
Se isso não resolver aconselho vc pegar o backup do seu squid que acredito que vc tenha e subir outro boa sorte..


7. Re: Squid nao inicia [RESOLVIDO]

Elgio Schlemer
elgio

(usa OpenSuSE)

Enviado em 27/04/2009 - 15:32h

Manda ai o resultado dos seguintes comandos executados COMO ROOT:

ls -la /var/log/squid/

lsattr ls -la /var/log/squid/

df -k

A saida destes comandos poderá dar maiores detalhes sobre o teu problema e assim poderemos de ajudar melhor. Explico o propósito de cada comando e já digo o que se esperaria em uma situação normal:

ls -la /var/log/squid/
Para ver se os donos e as permissões dos arquivos de logs do squid estão corretas. Deve obter algo como:
# ls -la /var/log/squid/
total 476
drwxr-x--- 2 squid root 4096 Apr 14 12:48 .
drwxr-xr-x 15 root root 4096 Apr 27 12:07 ..
-rw-r----- 1 squid nogroup 205663 Apr 16 13:09 access.log
-rw-r----- 1 squid nogroup 13217 Apr 16 13:17 cache.log
-rw-r----- 1 root root 0 Apr 14 12:48 rcsquid.log
-rw-r----- 1 squid nogroup 243915 Apr 16 13:09 store.log

Ao contrário do que dito ACIMA, NÃO SE DEVE, repito, NÃO SE DEVE dar permissão 777 para os logs. Isto é uma atitude desesperada, mas completamente equivocada e com um ROMBO de segurança. Os arquivos devem pertencer ao squid e só ele deve poder escrever!

lsattr ls -la /var/log/squid/
Para ver se não tem arquivos com flags de kernel ligado, raramente usado, mas...

df -k
Para ver se não estás com a partição/disco onde estão os logs cheio.

[]'s


8. Re: Squid nao inicia [RESOLVIDO]

Dênis Wallace de Souza
comfaa

(usa Debian)

Enviado em 27/04/2009 - 17:18h

comigo ja aconteceu algo parecido, eu resolvi removendo e instalando novamente o Squid


9. Pergunta

davidson clayton de carvalho
dclayton2509

(usa Red Hat)

Enviado em 28/04/2009 - 08:47h

Amigos


Dei permissoes ao acces.log e setei o squid como effect user


meu squid rodou normalmete.


inicie com sucesso o servico named

mas a internet so chega para meu servidor e as maquinas do meu dominio nao recebem

setei o proxy no browser e a gateway nas maquinas.


Ai quando dou um ping no ip do servidor de internet ele responde mas

quando adiciono a porta 3128 ao ping ele para de responder.


Grato,



10. Re: Squid nao inicia [RESOLVIDO]

Marcio Borges
marcio_cb

(usa OpenSuSE)

Enviado em 28/04/2009 - 21:13h

Quanto a questao das estacoes o ip_forward vc alterou

echo 1 > /proc/sys/net/ipv4/ip_forward

talvez ajude