Squid Parou

1. Squid Parou

Marco Aurélio
marcoalbama

(usa Fedora)

Enviado em 07/11/2007 - 10:02h

Estou mexendo com o squid a pouco tempo , e ele parou , talvez por alguma alteração indevida. Estou com um monte de usuários ligando a coisa tá critica aqui.

Quando tento navegar ele dá essa mensagem de erro:

* Unable to forward this request at this time.

This request could not be forwarded to the origin server or to any parent caches. The most likely cause for this error is that:
*The cache administrator does not allow
this cache to make direct connections to
origin servers, and

*All configured parent caches are currently
unreachable

Alguém sabe dizer o que pode estar acontendo ?

Obrigado
Ricardo Leite



  


2. Re: Squid Parou

Marcelo Cavalcante Rocha
kalib

(usa Arch Linux)

Enviado em 07/11/2007 - 10:04h

Tenta ver o status do squid...

/etc/init.d/squid status

Se ele tiver parado...de um start nele...

/etc/init.d/squid start

E veja se dá certo..do contrário poste aqui novamente..


3. Nao esta respondendo

Marco Aurélio
marcoalbama

(usa Fedora)

Enviado em 07/11/2007 - 10:52h

Obrigado pela resposta rápida.

Dei o start , mas quando vou navegar ele fica procurando a pagina e nao sai disso . Demorou uns 15 minutos de deu o mesmo erro.


4. Re: Squid Parou

Eduardo Bueno de Oliveira
predator

(usa Debian)

Enviado em 07/11/2007 - 11:09h

voce falou "talvez alguma alteração indevida" voce lembra qual ultima alteração que voce fez?
outra coisa tenta zerar o cache dele

squid stop
squid -z
squid start


5. Mudou o erro

Marco Aurélio
marcoalbama

(usa Fedora)

Enviado em 07/11/2007 - 11:33h

Dei os comamandos

funap01:/# ./etc/init.d/squid stop
funap01:/# ./etc/init.d/squid -z
2007/11/07 12:17:29| Creating Swap Directories
funap01:/# ./etc/init.d/squid start

Porém agora mudou o erro :
Connection Failed

The system returned:
(110) Connection timed outThe remote host or network may be down.





6. Re: Squid Parou

Thiago Fernandes de Melo
m4tri_x

(usa Ubuntu)

Enviado em 18/12/2007 - 18:44h

tenta assim:
#squid -D


7. squid

paulo
prgs.linux

(usa CentOS)

Enviado em 22/12/2007 - 00:42h

Amigo quando configurou o squid vc deixou quanto para armazenar log??...vc ver isso dentro do squid.conf com certeza ele ja deve ta lotado vc tem que limpar manualmente...
#cd /var/lib/squid/cache
no meu caso fica nesse diretorio pq uso slack

dentro dele basta da um rm -rf *
depois cria eles novamente :
# zquid -Z&
# /etc/rc.d/rc.squid start

tudo ok...!!!!!!!!!!


8. SQUID

Marcelo de Souza Sant´Anna
SantAnna

(usa Outra)

Enviado em 22/12/2007 - 21:36h

Sugiro que você jogue aqui parte do seu /var/log/messages e do seu /var/log/squid/squid.out que fale a respeito do problema, para podermos tentar ajudá-lo. Tente colocar também o seu squid.conf aqui, ao menos a parte que diz respeito ao cache e as ACLs.

Verifique se o squid está com direito de acesso ao diretório aonde está o cache e se você não inverteu alguma política no seu conf.

Isto ocorre normalmente quando o squid não está com acesso ao diretório cache ou o "http_access deny all" está no lugar errado.



9. SQUID

Marcelo de Souza Sant´Anna
SantAnna

(usa Outra)

Enviado em 22/12/2007 - 21:39h

Também existe uma maneira não muito segura de resolver isto, mas resolve até você ter tempo de descobrir o que está havendo, que é incluindo a seguinte linha no seu conf:

always_direct allow all

OBS.: Lembre-se que você não deve manter isto!!! Utilize apenas temporariamente até depurar o problema com mais calma.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts