Problema estranho com SARG

1. Problema estranho com SARG

JoHn
johnpisces

(usa Outra)

Enviado em 10/11/2010 - 12:05h

Galera, um seguinte...

Tenho aqui um Squid com Sarg e Apache2 rodando tranquilo...

Acontece que do nada quando dou o comando sarg para gerar os relatórios ele dá esta mensagem:
/tmp/sarg/.unsort Diretório não Encontrado.

Ele gera os relatórios, acesso normal pelo Apache2, mas queria entender o PQ dessa mensagem repentina sendo que ninguem mexeu no servidor !!!

Grato pela atenção.


  


2. Re: Problema estranho com SARG

Raul
raulinux

(usa Slitaz)

Enviado em 10/11/2010 - 14:18h

posta seu sarg.conf

vc ja tentou criar esta pasta para testar e ver oq acontece




3. Re: Problema estranho com SARG

JoHn
johnpisces

(usa Outra)

Enviado em 10/11/2010 - 17:28h

Bom, quando criei a pasta e dei o comando sarg, apareceu um monte de erros e depois a pasta sumiu.


Tava tudo funcionando legal até ontem de manha... Já uso esse sistema com squid e sarg já a uns 4 meses...

Segue meu Sarg.Conf ( A maioria dos campos está comentada por isso não postarei aqui)
# sarg.conf

language Portuguese

access_log /var/log/squid/access.log

title "Squid User Access Reports"

font_face Tahoma,Verdana,Arial

header_color darkblue

header_bgcolor blanchedalmond

font_size 9px

background_color white

text_color #000000

text_bgcolor lavender

title_color green

temporary_dir /tmp

output_dir /var/www/sarg

resolve_ip

user_ip no

topuser_sort_field BYTES reverse

user_sort_field BYTES reverse

exclude_users /etc/squid/sarg.users

exclude_hosts /etc/squid/sarg.hosts

date_format u

lastlog 0

remove_temp_files yes

index yes

index_tree file

overwrite_report yes

records_without_userid ip

use_comma yes

mail_utility mailx

topsites_num 100

topsites_sort_order CONNECT D

index_sort_order D

exclude_codes /etc/squid/sarg.exclude_codes

max_elapsed 28800000

report_type topusers topsites sites_users users_sites date_time denied auth_failures site_user_time_date downloads

usertab /etc/squid/sarg.usertab

long_url no

date_time_by bytes

charset Latin1

show_successful_message no

show_read_statistics no

topuser_fields NUM DATE_TIME USERID CONNECT BYTES %BYTES IN-CACHE-OUT USED_TIME MILISEC %TIME TOTAL AVERAGE

user_report_fields CONNECT BYTES %BYTES IN-CACHE-OUT USED_TIME MILISEC %TIME TOTAL AVERAGE

topuser_num 0

site_user_time_date_type table

download_suffix "zip,arj,bzip,gz,ace,doc,iso,adt,bin,cab,com,dot,drv$,lha,lzh,mdb,mso,ppt,rtf,src,shs,sys,exe,dll,mp3,avi,mpg,mpeg"


4. Re: Problema estranho com SARG

Raul
raulinux

(usa Slitaz)

Enviado em 11/11/2010 - 12:41h

estava dando uma pesquisada e vi q um cara teve o mesmo problema q vc e ele so resolvel reinstalando o sarg