NatACL não autentica

1. NatACL não autentica

Guilherme de Morais Teixeira
guimteixeira

(usa Debian)

Enviado em 30/03/2011 - 13:50h

Ajuda NatACL nao libera usuarios
Olá galera,

instalei o NATAcl aqui no meu trabalho.

Ele, quando o usuario entra diz que o certificado nao é confiavel e também quando digito o usuario e senha pré configurado ele diz o seguinte no firefox:

Access DENIED
- IP address/Login/Password not allowed

E no IE:

O site recusou-se a mostrar a página da Web
HTTP 403
Causas prováveis:
•Este site requer que você faça logon.

Você pode tentar:


Alguém sabe o por quê?


  


2. Re: NatACL não autentica

Guilherme de Morais Teixeira
guimteixeira

(usa Debian)

Enviado em 30/03/2011 - 16:38h

Estive mexendo aqui e fui rever os LOGs do NatACL, eu segui um tutorial aqui do VOL mesmo.

Olha o que o LOG diz:

[Wed Mar 30 13:32:11] [INFO] WAN ADDRESS [eth2:192.168.3.1]

[Wed Mar 30 13:32:11] [IPTABLES_PROXY] Init
[Wed Mar 30 13:32:11] [IPTABLES_PROXY] Added interface [eth2]
[Wed Mar 30 13:32:11] [IPTABLES_PROXY] /sbin/iptables -t nat -F
[Wed Mar 30 13:32:11] [IPTABLES_PROXY] Added interface [eth2]
[Wed Mar 30 13:32:11] [IPTABLES_PROXY] /sbin/iptables -t nat -I PREROUTING -i eth2 -p tcp -s 192.168.3.0/24 -d 0/0 --dport 80 -j DNAT --to-destination 192.168.3.1:5121
[Wed Mar 30 13:33:18] [AUTH] [ 192.168.3.11] [ fabio] Invalid Password
[Wed Mar 30 13:34:42] [AUTH] [ 192.168.3.11] [ 6325] Invalid Password
[Wed Mar 30 13:42:48] [AUTH] [ 192.168.3.12] [ fabio] Invalid Password
[Wed Mar 30 13:43:16] [AUTH] [ 192.168.3.12] [ fabio] Invalid Password
[Wed Mar 30 13:43:54] [AUTH] [ 192.168.3.12] [ admin] Invalid Password
[Wed Mar 30 13:47:20] [AUTH] [ 192.168.3.12] [ fabio] Invalid Password
[Wed Mar 30 13:48:20] [AUTH] [ 192.168.3.12] [ fabio] Invalid Password
[Wed Mar 30 14:22:37] [AUTH] [ 192.168.3.12] [ fabio] Invalid Password
[Wed Mar 30 14:25:23] [AUTH] [ 192.168.3.12] [ fabio] Invalid Password
[Wed Mar 30 16:10:21] [AUTH] [ 192.168.3.12] [ fabio] Invalid Password
[Wed Mar 30 16:10:45] [AUTH] [ 192.168.3.12] [ fabio] Invalid Password
[Wed Mar 30 16:32:50] [AUTH] [ 192.168.3.12] [ fabio] Invalid Password

########################

No Mysql SQL esta assim:

mysql> use NatACL;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> show tables;
+------------------+
| Tables_in_NatACL |
+------------------+
| users |
+------------------+
1 row in set (0.00 sec)

mysql> select * from users;
+----+-------+----------+-------------+--------------+---------+
| id | user | password | expire_type | expire_value | address |
+----+-------+----------+-------------+--------------+---------+
| 1 | fabio | teste | 1 | 0 | NULL |
+----+-------+----------+-------------+--------------+---------+
1 row in set (0.00 sec)

##########

Gostaria de ver o SELECT do NatACL. Será que é a forma que a senha está no banco. Será que é alguma encriptação no campo password que deve ser feita na inserção (md5 e afins)?

Obrigado
Valeuu


3. Re: NatACL não autentica

Guilherme de Morais Teixeira
guimteixeira

(usa Debian)

Enviado em 31/03/2011 - 08:11h

Alguém consegue imaginar o que seja?


4. Re: NatACL não autentica

Adalberto Mendes
Sr.Mendes

(usa CentOS)

Enviado em 04/04/2012 - 18:15h

Oi, você conseguiu resolver o problema?
Qual versão do NatACL esta usando?

Abraços


5. Re: NatACL não autentica

Adalberto Mendes
Sr.Mendes

(usa CentOS)

Enviado em 04/04/2012 - 18:20h

Oi, você conseguiu resolver o problema?
Qual versão do NatACL esta usando?

Abraços


6. Re: NatACL não autentica

Leonardo Silva
leonardodsl

(usa Debian)

Enviado em 09/12/2013 - 01:50h

Bom dia Amigos. Vocês conseguiram resolver o problema para rodar o NatACL?




7. Re: NatACL não autentica

Buckminster
Buckminster

(usa Debian)

Enviado em 09/12/2013 - 04:59h

leonardodsl escreveu:

Bom dia Amigos. Vocês conseguiram resolver o problema para rodar o NatACL?



http://natacl.sourceforge.net/README.pt.html


8. Re: NatACL não autentica

Buckminster
Buckminster

(usa Debian)

Enviado em 09/12/2013 - 04:59h

E o troféu Pá de Ouro por escavação de tópicos antigos desta vez vai para...

http://www.evoo.com.br/forum/files/pa_de_ouro_923_149.jpg


9. Cavocando

DANIEL ZANATA
zanatazan

(usa Debian)

Enviado em 20/01/2017 - 00:50h

O arquivo que contém o select é o auth_mysql.so
select expire_type, expire_value, address from users where user='%s' and password='%s'

o select esta correto porem da o mesmo erro de Invalid Password

dei uma olhada tbm no NatACL pra ver de onde se origina as telas de erro, possivelmente da pra personalizar..

agora fica a pergunta porque acusa password invalido?


10. Cavoquei umpouco mais

DANIEL ZANATA
zanatazan

(usa Debian)

Enviado em 20/01/2017 - 01:30h

Galera solução para esse erro
tá no tipo da tabela
altere o codigo do mysql.DUMP
De:
TYPE=MyISAM;

Para:
ENGINE=MyISAM;

DAI RODA BELEZINHA HUAHUAH FLW






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts