IPTABLES não está gravando [RESOLVIDO]

1. IPTABLES não está gravando [RESOLVIDO]

Everton A Azevedo
everlolo

(usa Ubuntu)

Enviado em 16/05/2011 - 21:35h

Boa Noite Amigos,

Meu script de IPTABLES é o seguinte:

_______________________________________________
#! /bin/bash

modprobe iptable_nat
modprobe ip_nat_ftp
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 3128
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

#Bloqueia MSN
iptables -A FORWARD -i eth1 -p tcp –dport 1863 -j DROP
__________________________________________________________

Eu gravei ele com o nome "firewall" na pasta /etc/init.d, depois no terminal dei o comando "ln -s /etc/init.d/firewall /etc/rc2.d/S19firewall". Até ontem tava funcinando e gravando tudo normal. Agora não está mais. Não está gravando nada nada. Quando dou o comando "iptables -L", eis o que aperece:

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


Não faço idéia do que pode ser. Alguém pode me ajudar? Eu uso o ubuntu.


  


2. Re: IPTABLES não está gravando [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 16/05/2011 - 22:58h

dá uma olhada:
http://blog.cesar.augustus.nom.br/instalando-o-firewall-no-linux.html


3. Re: IPTABLES não está gravando [RESOLVIDO]

yros aguiar
yros

(usa Slackware)

Enviado em 17/05/2011 - 12:48h

tenta iptables -L -t nat e ver se sai aparece algo


4. Re: IPTABLES não está gravando [RESOLVIDO]

Jean Lourenço Dias
jeanldias

(usa Outra)

Enviado em 17/05/2011 - 16:23h

Amigo, notei que na primeira linha de seu script, no chamado shebang, há um espaço que possivelmente seja indesejado:
#! /bin/bash

Confira também as permissões do seu script, olhe se tem permissão de execução.
Um abraço, T+!


5. Re: IPTABLES não está gravando [RESOLVIDO]

MeioLouko
meiolouko

(usa Slackware)

Enviado em 17/05/2011 - 16:28h

Outra coisa, veja se o script criado esta como executavel.




6. Re: IPTABLES não está gravando [RESOLVIDO]

MeioLouko
meiolouko

(usa Slackware)

Enviado em 17/05/2011 - 16:32h

Mais uma coisa.

Pelo que vi vc criou o link para o rc2.d, init 2, to sem ubuntu para ver, mas se não me engano, o nivel de inicialização normal é o init 3, rc3.d.


7. Re: IPTABLES não está gravando [RESOLVIDO]

Everton A Azevedo
everlolo

(usa Ubuntu)

Enviado em 26/05/2011 - 21:22h

Pessoal,

Eu estava digitando o comando errado (iptables -L). O correto era iptables -L -t nat. Obrigado ä todos pela ajuda!