Erro no squid [RESOLVIDO]

1. Erro no squid [RESOLVIDO]

Julian Castaman
maninhx

(usa Slackware)

Enviado em 05/06/2008 - 08:42h

Acabei de instalar meu squid. tentei varios firewall de configuracao aqui do VOL. Mas todos estão dando o mesmo erro quando digito #squid -k reconfigure

segue o erro.

squid: ERROR: No running copy

ja tentei essa dica http://www.squid-cache.org.br/index.php?option=com_content&task=view&id=79&Itemid=28 mas não funcionou.


  


2. Re: Erro no squid [RESOLVIDO]

Matheus Marcondes da Silva
matheus.silva

(usa Debian)

Enviado em 05/06/2008 - 08:50h

Tentou dar um "squid &" para iniciar o squid?
Esse erro ai é quando ele não ta rodando.

por via das dúvidas da um killall -9 squid e depois squid & pra iniciar..

dai tenta dar um squid -k reconfigure


3. Re: Erro no squid [RESOLVIDO]

Julian Castaman
maninhx

(usa Slackware)

Enviado em 05/06/2008 - 09:07h

dei um #killall -9 squid apareceu
squid: no process killed
dai digitei #squid & apareceu
[1]2773 (parece ter iniciado pois dei um #killall -9 squid apareceu [1]+ Done squid)
digitei novamente o #squid &. até ai parece estar tudo bem.
mas dei o #squid -k reconfigure apareceu:
squid: ERROR: No running copy
[1]+ Done squid

e agora?


4. Re: Erro no squid [RESOLVIDO]

Eduardo Paim Silveira
eduardo

(usa CentOS)

Enviado em 05/06/2008 - 09:25h

De um "service squid start" para iniciar, ou um "squid -D". Veja se estes comandos funcionam para você.

O squid está rodando como?


5. Re: Erro no squid [RESOLVIDO]

Luciano Gomes
lucianopqd

(usa Ubuntu)

Enviado em 05/06/2008 - 09:34h

Amigo faz o seguinte, em um terminal (Alt+F1) vc digita tail -f /var/log/squid/cache.log, e em outro terminal (Alt+F2) vc executa squid -z e volta para o (Alt+F1), observa o erro que vai dar acredito que ele não esteja conseguindo criar o spool por não haver a pasta, se for isso é só criar mkdir /var/spool/squid e dar o direito chmod 777 /var/spool/squid e executar novamente o squid -z que ele vai criar a estrura de spool aí sim o service squid start.

Não esquece, o LOG que vai te dizer onde está o erro.


6. Re: Erro no squid [RESOLVIDO]

Eduardo Paim Silveira
eduardo

(usa CentOS)

Enviado em 05/06/2008 - 09:51h

O lucianopqd já se adiantou e deu tudo explicadinho cara, é só fazer funcionar agora.
Qualquer coisa posta os Logs.


7. Re: Erro no squid [RESOLVIDO]

Julian Castaman
maninhx

(usa Slackware)

Enviado em 05/06/2008 - 10:25h

acho que deu certo.
eu tava fazendo como root dai dava erro mas fiz com o usuario squid dai não deu mais o erro. acho que era mesmo problema nas permissoes.
vlw galera. se der novamento o erro volto aqui.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts