Simulador de circuito (eletrônica) Yenka fechando inesperadamente ao abrir [RESOLVIDO]

1. Simulador de circuito (eletrônica) Yenka fechando inesperadamente ao abrir [RESOLVIDO]

Wilker Azevedo
cytron

(usa Slackware)

Enviado em 24/12/2012 - 03:46h

Olá pessoal!

Instalei um software simulador de circuitos da yenka via pacote .package onde ocorreu tudo normal. Mas ao executar o programa ele abre bonitinho e após uns 7 segundos ele fecha independente de mexer nele ou não.

Dá uma força aí galera!

Estou usando Slack Current (32b)

Rodando do terminal tenho este retorno:

=============================================
(process:15412): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()

(process:15412): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()

(process:15412): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: assertion `G_TYPE_IS_INTERFACE (interface_type)' failed

(process:15412): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

(process:15412): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(process:15412): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

(process:15412): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed
Got signal 11, faulty address is 0x28, from 0xb045c22f
Random number seed: 1356327077
[bt] Execution path:
[bt] /usr/lib/libgdk_pixbuf-2.0.so.0(gdk_pixbuf_new_from_data+0x13f) [0xb045c22f]
[bt] linux-gate.so.1(__kernel_rt_sigreturn+0) [0xffffe40c]
[bt] /usr/lib/libgdk_pixbuf-2.0.so.0(gdk_pixbuf_new_from_data+0x13f) [0xb045c22f]
[bt] /usr/lib/libgdk_pixbuf-2.0.so.0(gdk_pixbuf_from_pixdata+0x151) [0xb0465191]
[bt] /usr/lib/libgdk_pixbuf-2.0.so.0(gdk_pixbuf_new_from_inline+0x68) [0xb0468ea8]
[bt] /usr/lib/mozilla/plugins/libflashplayer.so(+0x535028) [0xaf4f1028]
[bt] /usr/lib/mozilla/plugins/libflashplayer.so(+0x53511e) [0xaf4f111e]
[bt] /usr/lib/mozilla/plugins/libflashplayer.so(+0x53b1bd) [0xaf4f71bd]
[bt] /usr/lib/mozilla/plugins/libflashplayer.so(NP_Initialize+0x2cd) [0xaf4f200d]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x6c17b3) [0xb5afd7b3]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x6c19a2) [0xb5afd9a2]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x56d659) [0xb59a9659]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x567c28) [0xb59a3c28]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x568980) [0xb59a4980]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x694fee) [0xb5ad0fee]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x51835e) [0xb595435e]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x50d40a) [0xb594940a]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x518a6c) [0xb5954a6c]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x518aef) [0xb5954aef]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x22ec07) [0xb566ac07]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x9b9fb4) [0xb5df5fb4]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x160ba5) [0xb559cba5]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x15ddec) [0xb5599dec]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x15f438) [0xb559b438]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x188dbb) [0xb55c4dbb]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x23a226) [0xb5676226]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x48f664) [0xb58cb664]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x42c792) [0xb5868792]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x42ce8f) [0xb5868e8f]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x46b821) [0xb58a7821]
[bt] Kernel/3rdparty/libQtWebKit.so.4(+0x430103) [0xb586c103]


  


2. Re: Simulador de circuito (eletrônica) Yenka fechando inesperadamente ao abrir [RESOLVIDO]

Ricardo Fabiano Silva
madrugada

(usa Gentoo)

Enviado em 24/12/2012 - 04:11h

Ele é executado pelo navegador? Você instalou o flashplayer?
Lendo o manual(http://www.yenka.com/en/Installing_on_Linux/), me parece que vai precisar deste pacote:
http://www.slackware.com/~alien/slackbuilds/gst-plugins-ugly/pkg/13.37/gst-plugins-ugly-0.10.18-i486...


3. Re: Simulador de circuito (eletrônica) Yenka fechando inesperadamente ao abrir [RESOLVIDO]

Wilker Azevedo
cytron

(usa Slackware)

Enviado em 24/12/2012 - 11:11h

Não é via navegador. É programa normal. Já tinha visto a questão da dependência
Pelo que consta no retorno do erro parece algo relacionado a glib, mas não encontrei nada no site da Yenka sobre versão da glib.
Costumo ver erros semelhantes a este quando preciso atualizar a glib ou o programa requer uma versão mais antiga, no entanto este progama simulador é muito atualizado. Imagino que ele seja compatível com a última glib.

Já uso Linux a mais de 10 anos, uso SOMENTE LINUX. Sempre lutei bravamente para nunca depender do windows. Sou testemunha vida de que é possível sobreviver sem windows, até edição e composição de vídeo fiz no Linux trabalhando em uma produtora.

Mas na área de simulação de circuitos sempre foi fraco, mas finalmente encontrei um programa que parece ser muito bom. Depois de uma instalação tão bonita o bicho não roda? Inadmissível.

Vamos vencer mais esta!!!


4. Re: Simulador de circuito (eletrônica) Yenka fechando inesperadamente ao abrir [RESOLVIDO]

Wilker Azevedo
cytron

(usa Slackware)

Enviado em 24/12/2012 - 12:07h

Ocorreu algo interessante...

Fui insistindo em abrir o programa, toda vez que abria eu tentava mexer rapidamente até chegar nas próximas telas. Derrepente consegui chegar na interface principal e ele não fechou.
Pelo que percebi o erro acontece por executar algo que não é reconhecido pelo glib, provavelmente problema de versão.
Simulei um circuito e foi beleza, mas derrepente ao executar alguma outra função ele fechou com o mesmo problema.

Interessante é que o programa realmente parece ser via web, mas ao mesmo tempo não parece. Está meio confuso. Lendo a respeito dele ainda não achei informações o suficiente.
Estou iniciando um artigo pra apresentar ele à comunidade. Achei este programa muito bom. A galera merece conhecer.

Espero que possamos resolver este problema.


5. Re: Simulador de circuito (eletrônica) Yenka fechando inesperadamente ao abrir [RESOLVIDO]

Wilker Azevedo
cytron

(usa Slackware)

Enviado em 24/12/2012 - 15:06h

Novidades:

O problema ocorre no menu principal (modo View), pois quando estou no modo Edit posso utilizar o simulador normalmente.
Como o programa inicia no modo View tenho que clicar rapidamente em Edit antes do bug acontecer.


6. Re: Simulador de circuito (eletrônica) Yenka fechando inesperadamente ao abrir [RESOLVIDO]

Wilker Azevedo
cytron

(usa Slackware)

Enviado em 25/12/2012 - 12:27h

madrugada escreveu:

Ele é executado pelo navegador? Você instalou o flashplayer?
Lendo o manual(http://www.yenka.com/en/Installing_on_Linux/), me parece que vai precisar deste pacote:
http://www.slackware.com/~alien/slackbuilds/gst-plugins-ugly/pkg/13.37/gst-plugins-ugly-0.10.18-i486...


Você tinha razão! Algo a ver com o flashplayer, mas quer ver o que tem de sinistro? Retirei o flashplayer.so e o programa iniciou normalmente. Ou seja, precisa dele, mas sem tem dá problema, se não tem funciona. Agora tenho que ficar tirando e colocando o flashplayer no diretório plugins toda vez que vou navegar ou usar o yenka.

rodando o yenka com parâmetros (--help, --<qualquer-coisa> dá um belo "Segmentation fault" hehe.

Mas um dia descubro como resolver isso.

So vou marcar este tópico como resolvido quando eu realmente resolver. Não vai demorar, é questão de dias.


7. Re: Simulador de circuito (eletrônica) Yenka fechando inesperadamente ao abrir [RESOLVIDO]

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 26/12/2012 - 07:10h

cytron escreveu:

madrugada escreveu:

Ele é executado pelo navegador? Você instalou o flashplayer?
Lendo o manual(http://www.yenka.com/en/Installing_on_Linux/), me parece que vai precisar deste pacote:
http://www.slackware.com/~alien/slackbuilds/gst-plugins-ugly/pkg/13.37/gst-plugins-ugly-0.10.18-i486...


Você tinha razão! Algo a ver com o flashplayer, mas quer ver o que tem de sinistro? Retirei o flashplayer.so e o programa iniciou normalmente. Ou seja, precisa dele, mas sem tem dá problema, se não tem funciona. Agora tenho que ficar tirando e colocando o flashplayer no diretório plugins toda vez que vou navegar ou usar o yenka.

rodando o yenka com parâmetros (--help, --<qualquer-coisa> dá um belo "Segmentation fault" hehe.

Mas um dia descubro como resolver isso.

So vou marcar este tópico como resolvido quando eu realmente resolver. Não vai demorar, é questão de dias.


Resolveu?


8. Re: Simulador de circuito (eletrônica) Yenka fechando inesperadamente ao abrir [RESOLVIDO]

Wilker Azevedo
cytron

(usa Slackware)

Enviado em 26/12/2012 - 17:08h

Bom, ainda está dando problemas de incompatibilidade com o flashplayer. Mas provavelmente é com a versão.

Tirando o flashplayer o programa roda normalmente, acho que pode ser considerado como resolvido.

Valeu!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts