Não consigo instalar o Brackets no Debian 10.

1. Não consigo instalar o Brackets no Debian 10.

diego
diegoYAK

(usa Debian)

Enviado em 21/01/2020 - 14:15h

Olá pessoal.
Sou novo no Linux e estou tentando instalar o Brackets.Release.1.14.1.64-bit.deb no Debian 10, toda vez que eu tento instalar aparece estas mensagem abaixo:


sudo dpkg -i Brackets.Release.1.14.1.64-bit.deb
(Lendo banco de dados ... 177241 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar Brackets.Release.1.14.1.64-bit.deb ...
A descompactar brackets (1.14.1-17752) sobre (1.14.1-17752) ...
dpkg: problemas com dependências impedem a configuração de brackets:
brackets depende de gconf-service; porém:
Pacote gconf-service não está instalado.
brackets depende de libgconf-2-4 (>= 2.31.1); porém:
Pacote libgconf-2-4 não está instalado.
brackets depende de libpango1.0-0 (>= 1.22.0); porém:
Pacote libpango1.0-0 não está instalado.
brackets depende de libcurl3; porém:
Pacote libcurl3 não está instalado.

dpkg: erro ao processar o pacote brackets (--install):
problemas de dependência - deixando desconfigurado
A processar 'triggers' para hicolor-icon-theme (0.17-2) ...
Erros foram encontrados durante o processamento de:
brackets



  


2. Re: Não consigo instalar o Brackets no Debian 10.

Avena
avena

(usa Debian)

Enviado em 21/01/2020 - 14:44h

veja se
apt update


e depois
apt -f install


para ver se consegue resolver o problema de dependências


3. Infelizmente não dei certo ainda

diego
diegoYAK

(usa Debian)

Enviado em 22/01/2020 - 16:52h

Então eu rodei o comando apt-update, mas aparece esta mensagem:

root@debian:/home/diegof# apt update
Atingido:1 http://security.debian.org/debian-security buster/updates InRelease
Atingido:2 http://deb.debian.org/debian buster InRelease
Atingido:3 http://deb.debian.org/debian buster-updates InRelease
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
1 package can be upgraded. Run 'apt list --upgradable' to see it.

root@debian:/home/diegof# apt list --upgradable
Listing... Pronto
libtiff5/stable 4.1.0+git191117-2~deb10u1 amd64 [upgradable from: 4.0.10-4]
N: There is 1 additional version. Please use the '-a' switch to see it


E quando roda o comando apt-f install , ele corrige a dependência mas remove o Brackets !

root@debian:/home/diegof# apt -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os pacotes a seguir serão REMOVIDOS:
brackets
0 pacotes atualizados, 0 pacotes novos instalados, 1 a serem removidos e 1 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 321 MB de espaço em disco serão liberados.
Você quer continuar? [S/n]



4. Re: Não consigo instalar o Brackets no Debian 10.

Avena
avena

(usa Debian)

Enviado em 22/01/2020 - 19:44h

sua lista de repositórios esta pequena, tem melhorar esta lista de repositórios.

leia este ou algo no site aqui do viva o linux sobre source.list do debian
https://linuxdicasesuporte.blogspot.com/2019/06/sourceslist-completa-para-o-debian-10.html

antes de sair instalando .deb, estude sobre o apt, repositorios e tudo mais que envolve isto do debian. pois possível o brackets estar em algum repositório.

sendo que brackets, atom e vscode todos são feito usando o electronjs






5. Obrigado pelo o artigo sobre o /sources.list

diego
diegoYAK

(usa Debian)

Enviado em 23/01/2020 - 17:55h

Apos eu te lido o artigo, realmente estava faltando na minha lista o quarto tipo de repositório o backport, eu adicionei e salvei, e rodei o comando apt-update, mas sem sucesso na instalação do Brackets, toda vez aparece dpkg: problemas com dependências impedem a configuração de brackets: e as mesmas mensagens.

Dando uma olhada no man apt e apt --help, quando eu rodo o comando sudo apt search brackets aparece um lista busca como:

Sorting... Pronto
Full Text Search... Pronto
backupninja/stable 1.1.0-2.1 all
lightweight, extensible meta-backup system

brackets/now 1.14.1-17752 amd64 [residual-config]
(none)

cl-curry-compose-reader-macros/stable 20171227-1 all
Reader macros for function partial application and composition.

debdry/stable 0.2.2-1 all
Semi-assisted automatic Debian packaging..............


E quando eu rodo o comando sudo apt list brackets, aparece:

Listing... Pronto
brackets/now 1.14.1-17752 amd64 [installed,local]








6. Re: Não consigo instalar o Brackets no Debian 10.

Avena
avena

(usa Debian)

Enviado em 23/01/2020 - 18:01h

conseguiu entao instalar? busque rodar o comando brackets

apt install brackets

ou instalar o .deb baixado do site do brackets, se quiser instale o gdebi que para te ajudar a instalar pacotes .debm já que esta iniciando.




7. RE: Não consigo instalar o Brackets no Debian 10

diego
diegoYAK

(usa Debian)

Enviado em 23/01/2020 - 18:56h

Eu ainda não conseguir instalar Brackets, acabei instalando o gdebi e rodei o comando:

sudo apt install brackets
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
O pacote brackets não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte

E: O pacote 'brackets' não tem candidato para instalação

Mas o pacote esta no /Downloads

~/Downloads$ ls
Brackets.Release.1.14.1.64-bit.deb



8. Re: Não consigo instalar o Brackets no Debian 10.

Avena
avena

(usa Debian)

Enviado em 24/01/2020 - 02:20h

otimo, busque usar o gdebi ou dpkg -i para instalar o pacote do brackets.

realmente instalar o brackets é algo simples, ele usa o electronjs para ser feito, então vai ter algumas dependências, que espero que agora com repositorios mais completos consiga resolver.

qualquer coisa busque sobre instalação de aplicativos no debian, tem o synaptic que pode ajudar a localizar e instalar o brackets e outros aplicativos. qualquer coisa busque instalar o Snap - https://snapcraft.io/store - ou flatpak - https://www.flatpak.org/

Snap no debian
https://snapcraft.io/install/snap-store/debian

Flatpak no debian
https://www.flatpak.org/setup/Debian


9. Re: Não consigo instalar o Brackets no Debian 10

diego
diegoYAK

(usa Debian)

Enviado em 24/01/2020 - 19:25h

Usei o GDebi para instalar o brackets, o mesmo acusa uma mensagem de erro:

Erro: A dependencia não é contentável:libcurl3

Pode ter algo de errado com o alguma biblioteca do próprio pacote, só para testar você conseguiu instalar o Brackets no seu Debian 10 ?


10. Não consigo instalar o Brackets no Debian 10

Alan
alan_interadm

(usa Debian)

Enviado em 05/02/2020 - 10:19h

Bom Dia

Depois de muito procurar e tentar vários procedimentos, eu consegui instalar o Brackets no Debian 10 da seguinte forma:

Após varias tentativas via terminal e baixando o arquivo .deb (Brackets.Release.1.14.1.64-bit.deb) sempre dava erro de dependências.

1º Tentei via Flatpak, quase deu certo. https://www.flatpak.org/setup/Debian/

Mostrava que estava instalado, mas, não executava.

2º Funcionou! Segui os procedimentos neste link: https://snapcraft.io/install/brackets/debian Instalação via snapd

sudo apt update
sudo apt install snapd

sudo snap install brackets --classic

*Atenção * Após a instalação tentei executar, mas não funcionou, precisei reiniciar a máquina para o Brackets aparecer no menu e se tornar executável.

Sistema Operacional Debian 10.2 (x86-64)
Versão do Cinnamon 3.8.8
Kernel do Linux 4.19.0.6-amd64

Release 1.14 build 1.14.0-17740 (release 329d08ffc)
build timestamp: Fri Apr 26 2019 17:04:50 GMT+0000

Abraços

Alan











Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts