sem touch screen em modo gráfico

1. sem touch screen em modo gráfico

Jaguar
J_Adler

(usa Arch Linux)

Enviado em 28/03/2010 - 09:27h

Ola galera do vol, procurei em muitos lugares na internet e não encontrei respostas às minhas perguntas ...
então vamos com uma de cada vez ...
comprei um hp tx2 touchsmart 1274nr ... retirei o vista e instalei o slackware 13 x86_64 ...
o que esta acontecendo é que quando ele esta em modo texto, o touchscreen responde sem problemas .... mas quando inicio o modo gráfico ele para ... já bootei com um cd do slax que tenho aqui e apesar de estar descalibrado o touchscreen funciona normalmente em modo gráfico ...
eu gostaria que alguém me ajudasse a resolver este problema!


  


2. Re: sem touch screen em modo gráfico

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 28/03/2010 - 12:33h

Se funcionou em modo texto mas não em modo gráfico, o problema tá dentro do arquivo /etc/X11/xorg.conf. Procure saber no google sobre como configurar o touchscreen no xorg.conf.


3. Re: sem touch screen em modo gráfico

Jaguar
J_Adler

(usa Arch Linux)

Enviado em 28/03/2010 - 12:39h

o problema é que sempre que modifico a configuração do xorg ele não carrega mais .... ai tenho que voltar com o backup.


4. Re: sem touch screen em modo gráfico

Jaguar
J_Adler

(usa Arch Linux)

Enviado em 30/03/2010 - 11:12h

Bom ...
ainda não consegui resolver meu problema.
atualizei o kernel para o 2.6.33.1 (o que resolveu o problema com o som- ótimo).
o touchscreen continua funcionando somente em modo texto ... quando carrego o modo gráfico ele para ... sendo que depois de atualizar o sistema eu fui dar uma olhada no arquivo xorg.conf ... encontrei apenas o arquivo xorg.conf-vesa.
Agora, tenho certeza de que este arquivo não esta sendo carregado ... pq fiz uma copia dele com o nome de xorg.conf e reiniciei o ambiente gráfico (e para minha surpresa, não iniciou - removi o arquivo xorg.conf e ele volta a carregar o X).
A mesma coisa acontece quando instalo o driver da minha placa ATI HD3200 e digito aticonfig --initial (o que cria um arquivo xorg.conf com as configurações básicas da placa).
só consigo iniciar o modo gráfico quando não se encontra nenhum arquivo xorg.conf dentro de /etc/X11

É aqui que estou concentrando minha atenção agora ...
agradeço a todos do VOL desde já!


5. sem touch screen em modo gráfico

cssn
c4

(usa Slackware)

Enviado em 03/04/2010 - 03:06h

Eu uso o slackware 13 x86_64 no meu note e não tive problemas. A minha placa de vídeo é a mesma que a sua (ATI Radeon HD 3200), mas vamos por partes:
Primeiro, não funciona nada do seu touch, nem move o curosor? Caso ele mova o cursor, mas não funcione o clique (toque), vc só precisa habilitar com o comando "synclient tapbutton1=1";
Segundo, essa placa funciona sem problemas com o driver proprietário da ATI "ati-driver-installer-9-12-x86.x86_64.run" nessa versão do slack. Por acaso vc atualizou para o slackare64-current ou atualizou o xorg?

Aguardo...


6. Re: sem touch screen em modo gráfico

Jaguar
J_Adler

(usa Arch Linux)

Enviado em 03/04/2010 - 09:15h

O cursor move normalmente, inclusive o scroll ... o único problema é que tenho sempre que habilitar com o comando "synclient TapButton1=1" ...
o driver da ATI que baixei foi o "ati-driver-installer-10-2-x86.x86_64.run".
Quando instalei o slack 13 com o kernel 2.6.29.6, não tinha problemas em instalar o driver da ATI, nem com a configuração "aticonfig --initial"
sendo que eu atualizei o kernel para kernel 2.6.33.1, pois li no site http://www.lii-enac.fr/en/projects/shareit/linux.html que eu para ter suporte ao touchscreen eu deveria ter o kernel 2.6.31 ou mais recente ... eu poderia ter usado o que vem no dvd do slack, mas achei melhor colocar o 2.6.33.1 ... sendo que quando instalo o driver da ATI citado acima ou crio algum arquivo xorg.conf, não consigo inicializar o ambiente X.
Como saber a versão do xorg que utilizo?
não tenho certeza, mas parece que tenho que ter a versão mais recente do xorg também ...
O dispositivo que tenho em meu notebook é o n-trig da DuoSense ... e diz que o driver esta disponível desde o kernel 2.6.31 ...


7. Re: sem touch screen em modo gráfico

cssn
c4

(usa Slackware)

Enviado em 03/04/2010 - 13:17h

j_adler, o kernel 2.6.29 tem suporte para o touch sim, eu usava e funcionava certinho. Considerando que vc use o slack com interface gráfica, configura o synclient pra inicia junto com KDE ou XFCE. No KDE ALT+F2 = systemsettings, depois vá em advanced > task scheduler > new task, adiciona o comando e manda rodar no boot. No XFCE também tem como fazer isso, é mais fácil que no KDE. Vc também pode criar um script de inicialização pro slack.
Quanto à sua ATI, se vc só atualizou o kernel e não o xorg, o problema é menor. Nessa versão do xorg que vem com o slack13-64 vc só precisa instalar o "ati-driver-installer-9-12-x86.x86_64.run" que vai funcionar. A versão que vc citou (ati-driver-installer-10-2-x86.x86_64.run) é para uma versão posterior do xorg. Eu não aconselho atualizar o xorg, fiz isso e não consegui aceleração 3D de forma alguma. Dessa forma, tenta instalar o "ati-driver-installer-9-12-x86.x86_64.run" que deve funcionar. Se não funcionar, faz um downgrade e instala esse driver que te falei.


8. Re: sem touch screen em modo gráfico

Jaguar
J_Adler

(usa Arch Linux)

Enviado em 03/04/2010 - 16:29h

C4, a dica que vc me deu é para habilitar o touchpad na inicialização!? pq isso não é o que me preocupa agora ... quero habilitar mesmo é o touchscreen, multitouch.
com a versão do kernel 2.6.29.6 eu não tinha som, mas bastava atualizar o alsa ... (coisa que não precisou no novo kernel - mas com isso estou tranquilo) ...
ainda com o kernel antigo, consigo instalar o driver novo da ATI (coisa que não acontece no novo kernel) ... tenho aceleração gráfica sem problemas ... cheguei a instalar o fingerprint sem muitos problemas no kernel 2.6.29.6 (não tentei no 2.6.33.1), vou voltar com a instalação antiga e ai tentarei modificar o xorg.conf, para ver se tenho os mesmo erros que tive agora ... (coisa que eu não havia tentado antes) ....
uma coisa que me preocupa é o fato de ter lido que o dispositivo n-trig só tem seus drivers nos kerneis mais atuais ....
enfim .... vou voltar com a donfiguração antiga para ver o que vai acontecer .... (já que um outro problema apareceu - a opção "desktop" do system settings simplesmente não funciona ... sempre que clico ali, a janela some) ....
ao final da reinstalação, volto para postar os resultados.


9. Ainda sem o touch ...

Jaguar
J_Adler

(usa Arch Linux)

Enviado em 08/04/2010 - 15:06h

Bom é isso ai galera, reinstalei o slackware 13.0 com o kernel que vem com ele .... o 2.6.29.6 ....
no modo gráfico ele reconhece o touch ... mas quando inicio o X, ele para .... bom, acho que se eu conseguir configurar o xorg corretamente resolverei o problema ....
já instalei o driver da placa de video .... mas quando modifico as configurações, em alguns casos ele não inicia o X novamente ....
bom, vou concentrar meus esforços em configurar o xorg ... e então depois, retorno aqui para postar o que aconteceu e deixar uma ajuda para quem possa passar pelo problema que eu ...
Vlw por toda a ajuda que tenham me dado ... e é isso ai ... seguindo aprendendo, apanhando (e muito), mas aprendendo.

C4, será que vc poderia me passar a configuração do seu xorg, para eu ver se irá funcionar no meu .... as configurações que estão nele, são as que o comando aticonfig --initial coloca ...


10. xorg.conf

cssn
c4

(usa Slackware)

Enviado em 12/04/2010 - 17:32h

Pedido difícil, atualmente estou rodando Gentoo, mas nunca precisei mexer no xorg.conf (ao menos no Slackware 13), aqui a hal fazia tudo certinho, ou seja, a minha configuração era a padrão da instalação. E aquela história do touch em modo gráfico, vc pode sim habilitar pelo xorg, mas eu sempre fui direto no synclient tapbutton1=1, enfim, o meu xorg.conf deve ser igual ao seu.
Contudo, vou te passar o meu xorg.conf do Gentoo, a configuração deve ser a mesma, quem sabe funcione:

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Protocol" "event"
Option "Device" ""
Option "LeftEdge" "1900"
Option "RightEdge" "5400"
Option "TopEdge" "1900"
Option "BottomEdge" "4000"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "180"
Option "MaxTapMove" "220"
Option "VertScrollDelta" "100"
Option "MinSpeed" "0.3"
Option "MaxSpeed" "0.50"
Option "AccelFactor" "0.080"
Option "SHMConfig" "on"
Option "TapButton1" "1"
Option "TapButton2" "2"
Option "TapButton3" "3"
EndSection




11. Re: sem touch screen em modo gráfico

Jaguar
J_Adler

(usa Arch Linux)

Enviado em 19/04/2010 - 17:17h

C4 ... Bom ... eu usei as suas configurações .... e mesmo assim não deu certo
quando eu me refiro ao touch ... não é o touchpad ... e sim o touchscreen .... quando estou em modo gráfico, basta eu passar o dedo pela tela do pc para o cursor seguir meu toque e selecionar toda a area por onde eu passo .... o touchpad já esta sendo iniciado com o comando que foi passado acima ...


12. Re: sem touch screen em modo gráfico

Jaguar
J_Adler

(usa Arch Linux)

Enviado em 06/05/2010 - 21:23h

Olá c4, eu baixei o driver que vc colocou ai em cima ... e ainda sim não consegui fazer o touchscreen funcionar ...
fiquei tanto tempo sem responder, pois estava em época de prova na faculdade e de medição no serviço ....
gostaria de saber o que eu poderia fazer .... acredito mesmo que seja a configuração do xorg ... pois em modo texto funciona perfeitamente o touchscreen ... (já ta ficando chato eu repetir várias vezes isso aqui)





01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts