modo texto com problemas [RESOLVIDO]

1. modo texto com problemas [RESOLVIDO]

Diego Junior do Carmo Oliveira
diegojr554

(usa CentOS)

Enviado em 25/09/2010 - 21:08h

Boa noite pessoal,

Estou com um problema no meu slackware 13.1 instalado no meu notebook HP, é o seguinte, quando eu digito qualquer comando o terminal retorna que o comando não foi encontrado e isso acontece com qualquer comando, por exemplo, o comando para ir para o modo gráfico startx retorna que o comando não foi encontrado, mesmo logado como root não da pra usar comandos como ifconfig, lspci, lsusb, pico, vi, mcedit, mount, etc. Quando eu aperto tab 2x seguidas para listar todos os comando aparecem apenas 132 possibilidades tanto como root quando em usuário normal.


  


2. MELHOR RESPOSTA

Tadzio Buscácio
Tadzio

(usa Linux Mint)

Enviado em 25/09/2010 - 23:28h

no terminal:
[email protected]: $ export PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

isso restaura o $PATH na seção, se quiser tornar permanente grava no ~/.bashrc




3. hmm...

sombriks
sombriks

(usa Slackware)

Enviado em 25/09/2010 - 22:05h

Olá,

Sua instalação foi full? Se não foi, faça uma instalação full.

Se tiver sido uma instalação full então deve ter ocorrido algum problema e recomendo baixar novamente o DVD.


4. Re: modo texto com problemas [RESOLVIDO]

Diego Junior do Carmo Oliveira
diegojr554

(usa CentOS)

Enviado em 25/09/2010 - 22:23h

foi sim, todos esses comando que eu citei funcionavam normalmente...


5. fstab

sombriks
sombriks

(usa Slackware)

Enviado em 25/09/2010 - 22:48h

seu fstab tinha algo especial? como uma partição pro /usr? se funcionava antes e agora não mais, poucas alternativas sobram:

- defeito na partição

- /etc/profile quebrado

copie a saída do export e posta no pastebin e manda o link


6. Re: modo texto com problemas [RESOLVIDO]

Diego Junior do Carmo Oliveira
diegojr554

(usa CentOS)

Enviado em 25/09/2010 - 22:59h

cara acho que é defeito com o /etc/profile mesmo, por que a ultima coisa que eu fiz antes de dar defeito foi modificar ele para instalar o java jdk seguindo um tutorial aqui mesmo do viva o linux que está nessa pagina:
http://www.vivaolinux.com.br/artigo/Instalando-e-configurando-o-Java-JDK-no-Slackware-Linux?pagina=2
eu adicionei isso aqui no final do /etc/profile:
export JAVA_HOME=/opt/jdk1.6.0_11
export CLASSPATH="$JAVA_HOME/lib"
export PATH="$JAVA_HOME/bin"
export MANPATH="$JAVA_HOME/man"

até pensei em tirar mais como num tava funcionando o vi, mcedit, pico, e nem dá para iniciar o modo gráfico...
se tiver uma forma de restaurar isso ajuda ai


7. Re: modo texto com problemas [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 25/09/2010 - 23:02h

Vixi meu, o jdk vem no próprio dvd do slack, dentro da pasta extras. Não precisa seguir esse tutorial enorme, é só da um installpkg


8. Re: modo texto com problemas [RESOLVIDO]

Tadzio Buscácio
Tadzio

(usa Linux Mint)

Enviado em 25/09/2010 - 23:12h

seu problema está aqui:
export PATH="$JAVA_HOME/bin"
você deixa somente no path esta pasta.

o certo é:
export PATH="$PATH:$JAVA_HOME/bin"


assim você preserva o seu PATH e apenas adiciona no final este dir.


9. Re: modo texto com problemas [RESOLVIDO]

Diego Junior do Carmo Oliveira
diegojr554

(usa CentOS)

Enviado em 25/09/2010 - 23:21h

ok entendi, mais como vou fazer isso se eu não consigo abrir nada nem usar nenhum comando?


10. Re: modo texto com problemas [RESOLVIDO]

Diego Junior do Carmo Oliveira
diegojr554

(usa CentOS)

Enviado em 26/09/2010 - 00:09h

vlw ai pessoal,
fiz o que o Tadzio falou e deu certo, e ainda coloquei o path export PATH="$PATH:$JAVA_HOME/bin" assim e agora tá funcionando blz






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts