Problema com lilo

1. Problema com lilo

Antonio jose
antoniojose12

(usa Fedora)

Enviado em 08/08/2017 - 00:09h

Seguinte, eu instalei o Slackware e ja tinha como distro padrao o debian.
O problema que no boot nao aparece mais o debian, ajudem


  


2. Re: Problema com lilo

Ricardo Fabiano Silva
madrugada

(usa Gentoo)

Enviado em 08/08/2017 - 07:05h

Posta uma foto do Gparted e nos diga em que partição está o Slackware e em qual está o Debian.

Com um chroot no Debian, você pode reinstalar o grub2, e fazer o grub do Debian bootar o Slack também.


3. Re: Problema com lilo

Antonio jose
antoniojose12

(usa Fedora)

Enviado em 08/08/2017 - 10:32h

SDA 1 --> Debian
SDA 3 --> Slackware
SDA 5 --> Debian


4. Re: Problema com lilo

Kowalski
kowalskii

(usa Arch Linux)

Enviado em 08/08/2017 - 11:31h

Eu optei por usar o Grub do Manjaro para bootar meu Slackware. Não gosto do lilo. Você pode reinstalar o grub no Debian pelo chroot, usando um live CD do mesmo.
Essa dica pode ajudar: https://www.vivaolinux.com.br/dica/Como-recuperar-o-GRUB-em-3-comandos-Esse-funciona

Podes também instalar o grub no Slackware: https://www.vivaolinux.com.br/dica/Slackware-com-o-GRUB
Se preferir usar o lilo não saberei ajudar... :P
-----------------------------------------
---- Linux Counter #606350 ----


5. Re: Problema com lilo

Ricardo Fabiano Silva
madrugada

(usa Gentoo)

Enviado em 08/08/2017 - 12:43h

antoniojose12 escreveu:

SDA 1 --> Debian
SDA 3 --> Slackware
SDA 5 --> Debian

Inicie o sistema pelo Slackware e abra uma sessão no Konsole ou outro emulador de terminal.

Supondo que o sistema raiz do Debian que deve gerenciar o boot está em /dev/sda1:
Cria o diretório para o ponto de montagem
mkdir /mnt/Debian 


Monta a partição /dev/sda1 no diretório criado. Caso resolva usar sda3, altere o comando
mount /dev/sda1 /mnt/Debian 


Monta os diretórios do sistema
mount --bind /proc /mnt/Debian/proc
mount --bind /run /mnt/Debian/run
mount --bind /sys /mnt/Debian/sys
mount --bind /dev /mnt/Debian/dev
mount --bind /dev/pts /mnt/Debian/dev/pts


Preenche o arquivo /etc/resolv.conf, para que possa ter internet no ambiente chroot
cp /etc/resolv.conf /mnt/Debian/etc/resolv.conf 


Inicia o chroot propriamente dito
chroot /mnt/Debian /bin/bash 


Agora estando dentro do ambiente Debian via terminal, você pode utilizar o update-grub, o grub-install ou:
apt-get install --reinstall grub-pc 


Como tem o Debian em SDA1, sou obrigado a crer que não está utilizando um ambiente GPT+UEFI.




6. Re: Problema com lilo

Ricardo Fabiano Silva
madrugada

(usa Gentoo)

Enviado em 09/08/2017 - 18:24h

Conseguiu algum progresso?
Teve alguma dificuldade?