Pacotes necessário para compilar um driver

1. Pacotes necessário para compilar um driver

jairson camargo
jairson.camargo

(usa Mandriva)

Enviado em 31/03/2021 - 08:50h

Bom dia
Estou enfrentando um problema , usamos uma distribuição baseada no slackware 14.2, que se chama conecto-linux, que e uma versão capada, apenas com os modulos para funcionamento de caixa(PDV).Preciso instalar um driver de um leitor biometrico (Hamester III), o driver funciona perfeitamente no slackware 14.2 quando instalado completo, porém a problemática e que não posso instalar ele completo, pois essa distribuição especifica ja esta em produção em N clientes. Vamos ao problema :
Essa distro não tem o make instalado, e falta varias dependência para que funcione adequadamente, ja procurei bastante mas não encontrei ate o momento, quais pacotes devo instalar , pois sempre falta alguma lib. alguém poderia me dar essa força?


  


2. Re: Pacotes necessário para compilar um driver

edps
edps

(usa Slackware)

Enviado em 11/04/2021 - 20:05h


jairson.camargo escreveu:

Bom dia
Estou enfrentando um problema , usamos uma distribuição baseada no slackware 14.2, que se chama conecto-linux, que e uma versão capada, apenas com os modulos para funcionamento de caixa(PDV).Preciso instalar um driver de um leitor biometrico (Hamester III), o driver funciona perfeitamente no slackware 14.2 quando instalado completo, porém a problemática e que não posso instalar ele completo, pois essa distribuição especifica ja esta em produção em N clientes. Vamos ao problema :
Essa distro não tem o make instalado, e falta varias dependência para que funcione adequadamente, ja procurei bastante mas não encontrei ate o momento, quais pacotes devo instalar , pois sempre falta alguma lib. alguém poderia me dar essa força?


Se é mesmo derivada do Slackware, você tem que no mínimo checar se o mirror para a release está habilitado.

Faça isso em /etc/slackpkg/mirrors

Depois proceda com:

# slackpkg update gpg
# slackpkg update
# slackpkg install-new
# slackpkg upgrade-all
# slackpkg clean-system


Já que dizes que é algo derivado, TALVEZ não seja RECOMENDADO executar o último comando porque qualquer coisa que tenha sido empacotada e instalada e que não seja parte da release oficial SERÁ REMOVIDA! (a menos que tenha sido inclusa em /etc/slackpkg/blacklist).

good luck








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts