Olá de novo

1. Olá de novo

Perfil removido
removido

(usa Nenhuma)

Enviado em 08/04/2008 - 13:21h

Tô me entendendo bem com o Slack e principalmente com o slapt-get/gslapt. Ajudam com as dependências, pq eu vou ficar maluco para resolver todas. Espero que funcione.

Mas estou com outro problema. Meu teclado não está funcionando, principalmente a tecla da contra-barra e da barra vertical (a tecla fica entre o shift e o z).

Já fui em Centro de Controle > Regional e Acessibilidade > Layout de Teclado.
Está assim: Layout Brazil, Mapa de Teclado br e Variante Abnt2.

Meu xorg.conf está assim:
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/share/X11/rgb"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/TTF"
FontPath "/usr/share/fonts/OTF"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/75dpi/:unscaled"
EndSection

Section "Module"
Load "glx"
Load "extmod"
Load "xtrap"
Load "record"
Load "GLcore"
Load "dbe"
Load "dri"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "abnt2"
Option "XkbLayout" "br"
Option "XkbVariant" "abnt2"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
#DisplaySize 410 260 # mm
Identifier "Monitor0"
VendorName "SAM"
ModelName "SyncMaster"
### Comment all HorizSync and VertRefresh values to use DDC:
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "Dac6Bit" # [<bool>]
#Option "Dac8Bit" # [<bool>]
#Option "BusType" # [<str>]
#Option "CPPIOMode" # [<bool>]
#Option "CPusecTimeout" # <i>
#Option "AGPMode" # <i>
#Option "AGPFastWrite" # [<bool>]
#Option "AGPSize" # <i>
#Option "GARTSize" # <i>
#Option "RingSize" # <i>
#Option "BufferSize" # <i>
#Option "EnableDepthMoves" # [<bool>]
#Option "EnablePageFlip" # [<bool>]
#Option "NoBackBuffer" # [<bool>]
#Option "DMAForXv" # [<bool>]
#Option "FBTexPercent" # <i>
#Option "DepthBits" # <i>
#Option "PCIAPERSize" # <i>
#Option "AccelDFS" # [<bool>]
#Option "DDCMode" # [<bool>]
#Option "MonitorLayout" # [<str>]
#Option "IgnoreEDID" # [<bool>]
#Option "UseFBDev" # [<bool>]
#Option "MergedFB" # [<bool>]
#Option "CRT2HSync" # [<str>]
#Option "CRT2VRefresh" # [<str>]
#Option "CRT2Position" # [<str>]
#Option "MetaModes" # [<str>]
#Option "MergedDPI" # [<str>]
#Option "MergedXinerama" # [<bool>]
#Option "MergedXineramaCRT2IsScreen0" # [<bool>]
#Option "MergedNonRectangular" # [<bool>]
#Option "MergedMouseRestriction" # [<bool>]
#Option "DisplayPriority" # [<str>]
#Option "PanelSize" # [<str>]
#Option "ForceMinDotClock" # <freq>
#Option "ColorTiling" # [<bool>]
#Option "VideoKey" # <i>
#Option "RageTheatreCrystal" # <i>
#Option "RageTheatreTunerPort" # <i>
#Option "RageTheatreCompositePort" # <i>
#Option "RageTheatreSVideoPort" # <i>
#Option "TunerType" # <i>
#Option "RageTheatreMicrocPath" # <str>
#Option "RageTheatreMicrocType" # <str>
#Option "ScalerWidth" # <i>
#Option "RenderAccel" # [<bool>]
#Option "SubPixelOrder" # [<str>]
#Option "ShowCache" # [<bool>]
#Option "DynamicClocks" # [<bool>]
#Option "VGAAccess" # [<bool>]
#Option "ReverseDDC" # [<bool>]
#Option "LVDSProbePLL" # [<bool>]
#Option "AccelMethod" # <str>
#Option "ConstantDPI" # [<bool>]
#Option "ReverseDisplay" # [<bool>]
#Option "DRI" # [<bool>]
Identifier "Card0"
Driver "ati"
VendorName "ATI Technologies Inc"
BoardName "R430 [Radeon X800 (PCIE)]"
BusID "PCI:2:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Colei tudo para que vocês possa me ajudar a ver se há algo a mais que possa ser otimizado.

Não sei mais o que fazer com para resolver esse negócio do teclado. Houve um momento em que ele funcionou direito.

Detalhe, fora do ambiente gáfico, ele funciona normalmente. Mas eu preciso dessa tecla, muito, no ambiente gáfico.

Quem puder ajuda, agradeço!



  


2. Olá de novo

Edwal F. Paiva Filho
nicolo

(usa Ubuntu)

Enviado em 08/04/2008 - 15:48h

Amigo se não me falha a memória o layout do teclado deveria ser pt_br ou pt-br, pois se refere à língua. A língua br é bretão.
Verifique isso.


3. Re: Olá de novo

Perfil removido
removido

(usa Nenhuma)

Enviado em 08/04/2008 - 22:21h

O meu ta igual, salvo que o keyboard ta como 1:

Identifier "Keyboard1"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "abnt2"
Option "XkbLayout" "br"
Option "XkbVariant" "abnt2"


4. Re: Olá de novo

Rafael Silva de Santana
fulllinux

(usa Slackware)

Enviado em 08/04/2008 - 22:34h

# xorgcfg -textmode


5. Re: Olá de novo

sombriks
sombriks

(usa Slackware)

Enviado em 09/04/2008 - 15:07h

sua configuração está igual à minha,

fora a possibilidade vc não ter um teclado abnt2, vascule a sua pasta e a do root por xorg.conf "de bobeira", pois se o X encontra um desses na pasta do usuário ele é usado preferencialmente.

também desfaça qualquer modificação feita via kde, deixando a configuração correta atuar.


6. O que eu já fiz

Perfil removido
removido

(usa Nenhuma)

Enviado em 09/04/2008 - 18:51h

1) Confirmado: meu teclado é abnt2. Não é muito difícil descobrir. É só olhar para ele. rsrsrsrsr

2) Boa dica. Procurei por outro xorg.conf mas não há outro além do /etc/X11/xorg.conf.

3) O xorgcfg só vai alterar o xorg.conf, e isso não adianta se as configurações batem com meu hardware.

4) A configuração feita pelo KDE não surtem qualquer efeito. Já tentei quase todas as opções mas a única alteração que se dá é o sumiço do C Cedilha e a troca das teclas para as de um teclado internacional padrão. Acho que a coisa tá no xorg.conf mesmo.

5) Não contei uma coisa, porque na verdade não acho que faça qualquer diferença, ja que no Ubuntu meu teclado funciona perfeitamente. É que ele é um Microsoft Digital Pro USB. Prefiro o teclado da MS porque escrevo muito e não agüento teclado ruim. (Se ao menos fosse possível comprar um teclado daqueles da HP, que só vem com máquinas HP ... mas não isto é possível.) Não acredito, todavia, que o modelo e o fabricante do teclado possam causar esse transtorno todo.

Meu problema é que a maioria das senhas que tenho usa o caractere "|", que não aparece no Slack! Estou ficando maluco.

Mas valeu a ajuda pessoal!

abs
Lucas


7. Re: Olá de novo

sombriks
sombriks

(usa Slackware)

Enviado em 09/04/2008 - 19:46h

Sem pânico (vide mochileiro das galáxias, :D)

Vou te sugerir fazer como eu faria:

A partir do runlevel 3 (abra um xterm; su; telinit 3; depois faça login) entre como root, use o fluxbox como desktop... abra um xterm e use o comando xorgcfg;

Ele vai te dar uma janelinha representando os periféricos do presentes no atual xorg.conf. daí vc usa o mouse, clicando e segurando sobre um dos periféricos desejados (no caso o teclado) e selecionando a opção "configure".

o bom é que a partir do menu vc escolhe dentro de uma lista o que vc achar que funciona, e pode abrir o gvim de lago pra ir vendo se a opção escolhida é a correta. Basicamente vc seleciona uma opção, dá ok e testa. Se não for, volta e escolhe outra.

Ao acabar vá no quit e garanta que seja lá o que ele tentar salvar vai estar sob /etc/X11; pra não ter riscos.

Eventualmente o xorgcfg dá uns paus, mas nada que um pouco de vi ou joe não resolva.

O fato do teclado ser MS pode exigir alguma coisa de especial a mais, mas eu não creio muito nisso... Se mesmo após estes procedimentos a barra continuar errada deve .have algo no xorg do ubuntu que possa ajudar. dê uma lida nele, se o seu slackware for o 12 o Xserver dos dois é bem igual.

Tente isso e volte pra dizer no que deu.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts