Firefox mais atual e com muito mais bugs.. [RESOLVIDO]

1. Firefox mais atual e com muito mais bugs.. [RESOLVIDO]

Fernando Tietê da Silveira Fragoso
f_tyet

(usa Slackware)

Enviado em 21/12/2013 - 16:57h

O Firefox do meu Slack 14.1 (64-bit) está de rosca...

O flashplayer plug-in deu pau e bugou do nada... :-(

No Chrome tá 100%, com som e sem travar e bugar o youtube... por que, meu Deus??!!! kkkk

P.S.: a versão instalada do firefox no meu sistema é a 24.1.1



Fernando Tietê, de férias (rsrs).


  


2. Re: Firefox mais atual e com muito mais bugs.. [RESOLVIDO]

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 21/12/2013 - 17:16h

Instale o Firefox 26 baixando o tarball da Mozilla (é pré-compilado e roda direto após descompactar).


3. Re: Firefox mais atual e com muito mais bugs.. [RESOLVIDO]

Fernando Tietê da Silveira Fragoso
f_tyet

(usa Slackware)

Enviado em 21/12/2013 - 18:22h

pinduvoz escreveu:

Instale o Firefox 26 baixando o tarball da Mozilla (é pré-compilado e roda direto após descompactar).


Opa, vou tentar...

Tipo... apago o 24.1.1 com o "slackpkg clean-system" e mando pau na instalação do 26?


mas, valeu, desde já!!


4. já resolvi...

Fernando Tietê da Silveira Fragoso
f_tyet

(usa Slackware)

Enviado em 21/12/2013 - 18:41h

Eu localizei o .txz do mozilla-firefox-24.1.1 e o removi, com o removepkg, mesmo...

E estou baixando o 26, direto do www.mozilla.com...

vejamos se os bugs do flashplayer se vão, de uma vez por todas...


Assim que der (se der) certo, eu marco como resolvido.. ;-)


5. Re: Firefox mais atual e com muito mais bugs.. [RESOLVIDO]

Fernando Tietê da Silveira Fragoso
f_tyet

(usa Slackware)

Enviado em 21/12/2013 - 20:07h

f_tyet escreveu:

pinduvoz escreveu:

Instale o Firefox 26 baixando o tarball da Mozilla (é pré-compilado e roda direto após descompactar).


Opa, vou tentar...

Tipo... apago o 24.1.1 com o "slackpkg clean-system" e mando pau na instalação do 26?


mas, valeu, desde já!!


Olá, de novo, meu querido...

Eu instalei o Firefox 26, depois de apagar o 24.1.1 (padrão do Slack 14.1)... mas eu não consigo "reinstalar" o flashplayer plugin... alguma luz?


6. Re: Firefox mais atual e com muito mais bugs.. [RESOLVIDO]

Fernando Tietê da Silveira Fragoso
f_tyet

(usa Slackware)

Enviado em 21/12/2013 - 20:09h

além disso,

se eu rodo

$firefox

ele abre o browser, mas aparece o seguinte:


(process:18447): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

(firefox:18447): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "oxygen-gtk",

(firefox:18447): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "oxygen-gtk",
GLib-GIO-Message: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications.


O que significa?


7. Re: Firefox mais atual e com muito mais bugs.. [RESOLVIDO]

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 22/12/2013 - 09:42h

f_tyet escreveu:

além disso,

se eu rodo

$firefox

ele abre o browser, mas aparece o seguinte:


(process:18447): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

(firefox:18447): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "oxygen-gtk",

(firefox:18447): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "oxygen-gtk",
GLib-GIO-Message: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications.


O que significa?


Significa que o bom e velho patch do tio Pat (que corrige esse bug do Firefox) não foi aplicado. Vamos aprender a instalar a versão mais atual do Firefox do jeito Slack? Passo a passo:

0) Remova o Firefox que você instalou descompactando o tar.bz2 da Mozilla.

1) Rode os comandos
 # lftp -c 'open http://slackbuilds.org/ ; mirror mirror/slackware/slackware-14.1/source/xap/mozilla-firefox/'
# cd mozilla-firefox
# rm firefox-24.1.0*
# chmod +x mozilla-firefox.SlackBuild
# wget ftp://ftp.mozilla.org/pub/firefox/releases/26.0/source/firefox-26.0.source.tar.bz2
# ./mozilla-firefox.SlackBuild

Explicando: o primeiro comando faz um mirror do repositório do Slackware copiando tanto o SlackBuild de compilação do Firefox quanto os patches do tio Pat. O segundo comando entra no diretório criado pelo mirror do primeiro comando. O terceiro comando apaga os arquivos da versão oficial do Firefox no 14.1 (que é o 24.1.0esr). O quarto torna o script SlackBuild executável. O quinto baixa a versão mais atual do Firefox. O sexto cria o pacote em /tmp/mozilla-firefox alguma coisa. Instale o novo pacote com
 # upgradepkg --reinstall --install-new /tmp/mozilla-firefox* 

No Slackware é assim, você pode usar os sources para atualizar por conta própria um pacote. Bem-vindo à distribuição GNU / Linux que funciona de verdade!


8. Re: Firefox mais atual e com muito mais bugs.. [RESOLVIDO]

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 22/12/2013 - 19:19h

Siga a dica do lCavalheiro, que é slacker de carteirinha.

Eu fui apenas um slacker de fim-de-semana, ou um simples sunday-slacker (rsrsrsr).




9. Re: Firefox mais atual e com muito mais bugs.. [RESOLVIDO]

Fernando Tietê da Silveira Fragoso
f_tyet

(usa Slackware)

Enviado em 22/12/2013 - 21:10h

pinduvoz escreveu:

Siga a dica do lCavalheiro, que é slacker de carteirinha.

Eu fui apenas um slacker de fim-de-semana, ou um simples sunday-slacker (rsrsrsr).




Que nada... todo conhecimento, pouco ou muito, no universo linux, é sempre a porta aberta para aprender muito.

Eu, hoje, ainda tenho muito o que aprender... mas, comecei - no linux- em 1996... com uma versão engatinhante do RedHad... hehe... quando eu me deparei com o Slakck, eu me fascinei... mas a falta de tempo para aprender me fez que eu partisse para os debian-like...

Enfim, estou de volta e - mesmo com filho, mulher etc. - tenho dado um jeito de me aprofundar no Slack...

Agradeço ao lcavalheiro, e já estou colocando os comandos, aí em cima, em prática... mas estou fazendo algumas adaptações, até pq não sou tão leigo, e mais!, já tinha feito algumas mudanças por aqui...

E, claro, agradeço, também, pinduvoz...

Não desista do Linux... precisamos de pessoas como você! rsrs



10. Re: Firefox mais atual e com muito mais bugs.. [RESOLVIDO]

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 22/12/2013 - 22:24h

Desistir? Nem pensar.

É que eu não tenho mais paciência para Linux complicado, e como já usei todos eles, fico com meu fácil Ubuntu (e com o Fedora, que quase sempre tenho instalado).

O lcavalheiro tira uma da minha cara por conta do Ubuntu, mas... eu deixo pra lá (rsrs). Não vou discutir com slacker, pois eles são muito teimosos (mais que eu, com certeza).

Abraço e boa sorte com seu Slack.


11. Re: Firefox mais atual e com muito mais bugs.. [RESOLVIDO]

Fernando Tietê da Silveira Fragoso
f_tyet

(usa Slackware)

Enviado em 22/12/2013 - 22:36h

pinduvoz escreveu:

Desistir? Nem pensar.

É que eu não tenho mais paciência para Linux complicado, e como já usei todos eles, fico com meu fácil Ubuntu (e com o Fedora, que quase sempre tenho instalado).

O lcavalheiro tira uma da minha cara por conta do Ubuntu, mas... eu deixo pra lá (rsrs). Não vou discutir com slacker, pois eles são muito teimosos (mais que eu, com certeza).

Abraço e boa sorte com seu Slack.


Hehe...
É isso aí...

Eu tenho um "plano" muito maior, que é fazer a minha esposa (que nem o RuWindows sabe usar direito) se torne uma usuária do Linux...

Ela, aliás, estava quase se acostumando com o o Linux Mint 16, que eu tenho instalado aqui na máquina... mas já se diz confundida pelo Slack 14.1...

Hehe... eu gosto do Ubuntu e gostei muito da Linux Mint... mas são muito práticos demais... eu gosto é de linhas de comando, mesmo! rsrs


Abraços,


Fernando Tietê.


12. Re: Firefox mais atual e com muito mais bugs.. [RESOLVIDO]

Fernando Tietê da Silveira Fragoso
f_tyet

(usa Slackware)

Enviado em 22/12/2013 - 23:45h

lcavalheiro escreveu:

f_tyet escreveu:

além disso,

se eu rodo

$firefox

ele abre o browser, mas aparece o seguinte:


(process:18447): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

(firefox:18447): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "oxygen-gtk",

(firefox:18447): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "oxygen-gtk",
GLib-GIO-Message: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications.


O que significa?


Significa que o bom e velho patch do tio Pat (que corrige esse bug do Firefox) não foi aplicado. Vamos aprender a instalar a versão mais atual do Firefox do jeito Slack? Passo a passo:

0) Remova o Firefox que você instalou descompactando o tar.bz2 da Mozilla.

1) Rode os comandos
 # lftp -c 'open http://slackbuilds.org/ ; mirror mirror/slackware/slackware-14.1/source/xap/mozilla-firefox/'
# cd mozilla-firefox
# rm firefox-24.1.0*
# chmod +x mozilla-firefox.SlackBuild
# wget ftp://ftp.mozilla.org/pub/firefox/releases/26.0/source/firefox-26.0.source.tar.bz2
# ./mozilla-firefox.SlackBuild

Explicando: o primeiro comando faz um mirror do repositório do Slackware copiando tanto o SlackBuild de compilação do Firefox quanto os patches do tio Pat. O segundo comando entra no diretório criado pelo mirror do primeiro comando. O terceiro comando apaga os arquivos da versão oficial do Firefox no 14.1 (que é o 24.1.0esr). O quarto torna o script SlackBuild executável. O quinto baixa a versão mais atual do Firefox. O sexto cria o pacote em /tmp/mozilla-firefox alguma coisa. Instale o novo pacote com
 # upgradepkg --reinstall --install-new /tmp/mozilla-firefox* 

No Slackware é assim, você pode usar os sources para atualizar por conta própria um pacote. Bem-vindo à distribuição GNU / Linux que funciona de verdade!



--------------------------------

lcavalheiro, aproveitando a ocasião, já que vc me ajudou a resolver a questão da atualização do Firefox, e, consequentemente, do flashplayer... me ajuda aqui:


todo .txz que eu instalo, seja do Slackbuilds, seja de outra fonte...


no final aparece o seguinte:

 Installing package mozilla-firefox-26.0-x86_64-1.txz:
PACKAGE DESCRIPTION:
# mozilla-firefox (Mozilla Firefox Web browser)
#
# This project is a redesign of the Mozilla browser component written
# using the XUL user interface language. Firefox empowers you to
# browse faster, more safely and more efficiently than with any other
# browser.
#
# Visit the Mozilla Firefox project online:
# http://www.mozilla.org/projects/firefox/
#
/sbin/ldconfig: /usr/lib64/libv4l2.so.0 is not a symbolic link

/sbin/ldconfig: /usr/lib64/libv4lconvert.so.0 is not a symbolic link

Executing install script for mozilla-firefox-26.0-x86_64-1.txz.
Package mozilla-firefox-26.0-x86_64-1.txz installed.



(Já pesquisei, mas não achei nada específico pra esse "problema")

Só pra te dar uma "dica", eu passei a receber essa msg, depois que instalei (na unha) ou v4l para que o skype reconhecesse a minha webcam, que o sistema já reconhecia, mas ele não.





01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts