Emulador PS2 Slackware [RESOLVIDO]

1. Emulador PS2 Slackware [RESOLVIDO]

Robson Alves Feijo
Tukiss

(usa Debian)

Enviado em 02/01/2017 - 00:29h

BOA NOITE!

Bem, depois de apanhar um pouco para instalar o Slack, consegui :D

Agora depois de um tempo para instalar os programas, consegui instalar os emuladores do SNES, PSONE e só falta mais dois... Que seria o PS2 e o Dolphin.

Instalei as três dependências que são:
Portaudio, Soundtouch, wxGTK3 e SDL2!

Porém, segue essa mensagem de erro:

  /usr/lib64/gcc/x86_64-slackware-linux/5.3.0/../../../../x86_64-slackware-linux/bin/ld:
cannot find -lgcc_s

collect2: error: ld returned 1 exit status

CMakeFiles/cmTC_f0773.dir/build.make:97: recipe for target 'cmTC_f0773'
failed

gmake[1]: *** [cmTC_f0773] Error 1

gmake[1]: Leaving directory
'/tmp/SBo/pcsx2-2016.07.31_e329b6f/build/CMakeFiles/CMakeTmp'

Makefile:126: recipe for target 'cmTC_f0773/fast' failed

gmake: *** [cmTC_f0773/fast] Error 2





CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
CMakeLists.txt:2 (project)


-- Configuring incomplete, errors occurred!
See also "/tmp/SBo/pcsx2-2016.07.31_e329b6f/build/CMakeFiles/CMakeOutput.log".
See also "/tmp/SBo/pcsx2-2016.07.31_e329b6f/build/CMakeFiles/CMakeError.log".

pcsx2:
Would you like to continue processing th


Desde já agradeço a atenção!


  


2. MELHOR RESPOSTA

johnf
johnf

(usa Slackware)

Enviado em 02/01/2017 - 08:05h

Já habilitou o multilib?


3. Re: Emulador PS2 Slackware

Robson Alves Feijo
Tukiss

(usa Debian)

Enviado em 02/01/2017 - 08:46h

Não... :/

Dei uma pesquisada ao você falar, é MUITO COMPLICADO. E ainda pode quebrar o sistema. Vou tentar outro dia.

Obrigado pela resposta.

"O Debian está na raíz deste grande ecossistema de distribuições de Software Livre existentes: mesmo se você não está usando o Debian diretamente, e mesmo se seu fornecedor não te disse, existe uma chance de você estar neste exato momento se beneficiando do trabalho da comunidade Debian."



4. Re: Emulador PS2 Slackware [RESOLVIDO]

Robson Alves Feijo
Tukiss

(usa Debian)

Enviado em 02/01/2017 - 08:55h

Achei um jeito fácil ao pesquisar no YouTube, pelo Zezão da Capoeira. Agora vou ver se funfa! :D

O site o o comando:



https://vidagnu.blogspot.com.br/2016/07/como-habilitar-instalar-multilibs-en.html

$ su
# cd /usr/local/
# SLACKVER=14.2
# mkdir multilib
# cd multilib
# lftp -c "open http://taper.alienbase.nl/mirrors/people/alien/multilib/ ; mirror -c -e ${SLACKVER}"
# cd ${SLACKVER}
# upgradepkg --reinstall --install-new *.t?z
# upgradepkg --install-new slackware64-compat32/*-compat32/*.t?z


"O Debian está na raíz deste grande ecossistema de distribuições de Software Livre existentes: mesmo se você não está usando o Debian diretamente, e mesmo se seu fornecedor não te disse, existe uma chance de você estar neste exato momento se beneficiando do trabalho da comunidade Debian."



5. Re: Emulador PS2 Slackware [RESOLVIDO]

Ricardo Fabiano Silva
madrugada

(usa Slackware)

Enviado em 02/01/2017 - 10:03h

Não é só habilitar multilib. As próprias dependências do SBO também precisam ser compilados e convertidos em compat-32.
O sbotools pode fazer este trabalho por você.

Eu instalei o pcsx2 no meu Slack e funciona sem problemas.


6. Re: Emulador PS2 Slackware [RESOLVIDO]

Robson Alves Feijo
Tukiss

(usa Debian)

Enviado em 02/01/2017 - 10:16h

madrugada escreveu:

Não é só habilitar multilib. As próprias dependências do SBO também precisam ser compilados e convertidos em compat-32.
O sbotools pode fazer este trabalho por você.

Eu instalei o pcsx2 no meu Slack e funciona sem problemas.


Me passa o tuto lá no outro tópico que abri madruga por favor!



"O Debian está na raíz deste grande ecossistema de distribuições de Software Livre existentes: mesmo se você não está usando o Debian diretamente, e mesmo se seu fornecedor não te disse, existe uma chance de você estar neste exato momento se beneficiando do trabalho da comunidade Debian."



7. Re: Emulador PS2 Slackware [RESOLVIDO]

Ricardo Fabiano Silva
madrugada

(usa Slackware)

Enviado em 02/01/2017 - 16:35h

Tukiss escreveu:

madrugada escreveu:

Não é só habilitar multilib. As próprias dependências do SBO também precisam ser compilados e convertidos em compat-32.
O sbotools pode fazer este trabalho por você.

Eu instalei o pcsx2 no meu Slack e funciona sem problemas.


Me passa o tuto lá no outro tópico que abri madruga por favor!



"O Debian está na raíz deste grande ecossistema de distribuições de Software Livre existentes: mesmo se você não está usando o Debian diretamente, e mesmo se seu fornecedor não te disse, existe uma chance de você estar neste exato momento se beneficiando do trabalho da comunidade Debian."


Estou de férias e longe do meu Slack por uns dias. Então fica difícil um tutorial

Mas instala este pacote:
https://slackbuilds.org/repository/14.2/system/sbotools/?search=sbotools

Um dos programas que vem neste pacote é o "sboinstall". Roda no terminal "man sboinstall" e você vai ver que tem opção para compilar e instalar compat-32.

Põe um link do outro tópico.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts