Kernel Panic - Slackware 64 bit Current - problemas multilib [RESOLVIDO]

1. Kernel Panic - Slackware 64 bit Current - problemas multilib [RESOLVIDO]

Thiago Zangaro
zasdrakano

(usa Slackware)

Enviado em 26/08/2019 - 13:14h

eu utilizo um distribuição espanhola WifiSlax - https://es.wikipedia.org/wiki/WiFiSlax. Por ser muito facil de utilizar, e sabendo que era originário do famoso Slackware, resolvi instalar o Slackware para aprender sempre um pouco mais.

No WifiSlax é facil instalar o Anydesk, Wine entre outros

Mas no Slackware o wine é do capeta. Desejo que o wine abra alguns pequenos aplicativos do Ruwindows, de 32 bits. Apenas consegui instalar o wine64 no Slackware, pois segundo um pouco que eu li para que o wine funcione tanto 32 bits, quanto 64 bits, preciso instalar uma tal de "multilib".

Nas buscas "googlianas" descobri um tal de Alien Bob, que tinha um belo script "multlib.sh", e que esse prometia instalar o multilib com sucesso.

Bem finalizando a história: tentei esse scrpit, tentei diversos tutoriais, todas vez que tento compilar e instalar esse inferno de Multilib, consigo um bom Kernel Panic, e já era minha instalação do Slackware.

Pergunta:

01 - Tem algum link com a instalação do Slackware x86/64bits Currente, já com esse multilib implantado e totalmente funcional, para que o wine funcione corretamente tanto 32 bits, quanto 64 bits???




  


2. MELHOR RESPOSTA

edps
edps

(usa Slackware)

Enviado em 26/08/2019 - 22:01h


Essa é a forma que eu faço geralmente:

# lftp -c 'open http://slackware.com/~alien/multilib/ ; mirror -c -e current'
# upgradepkg --reinstall --install-new current/*.t?z
# upgradepkg --reinstall --install-new current/slackware64-compat32/a-compat32/*.t?z
# upgradepkg --reinstall --install-new current/slackware64-compat32/ap-compat32/*.t?z
# upgradepkg --reinstall --install-new current/slackware64-compat32/d-compat32/*.t?z
# upgradepkg --reinstall --install-new current/slackware64-compat32/l-compat32/*.t?z
# upgradepkg --reinstall --install-new current/slackware64-compat32/n-compat32/*.t?z
# upgradepkg --reinstall --install-new current/slackware64-compat32/x-compat32/*.t?z
# upgradepkg --reinstall --install-new current/slackware64-compat32/xap-compat32/*.t?z


3. Re: Kernel Panic - Slackware 64 bit Current - problemas multilib [RESOLVIDO]

johnf
johnf

(usa Slackware)

Enviado em 26/08/2019 - 21:18h


Cara, teria que verificar os erros para melhor te ajudar. Eu, particularmente, nunca vi uma .ISO já com o multilib habilitado, mas já configurei e não é um bicho de sete cabeças não.
Bom, não sei se nessa tal de WifiSlax funcionaria, mas no Slackware em si, eu configurei através desse artigo:
https://www.vivaolinux.com.br/artigo/Guia-Pos-Instalacao-do-Slackware-edicao-2015
Pode até ser de 2015, mas ajuda muito, só alterar uma coisa aqui outra ali.
Bom, qualquer coisa posta os erros que ficará melhor para ajudarmos você.


4. Re: Kernel Panic - Slackware 64 bit Current - problemas multilib [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 26/08/2019 - 21:46h

Eu tinha alguma coisa sobre isso em meus arquivos (não era o script, eu usava o lftp para baixar todos os arquivos e depois instalava), mas não encontrei, então vamos a alternativa:

# wget https://ufpr.dl.sourceforge.net/project/slackpkgplus/slackpkg%2B-1.7.0-noarch-10mt.txz
upgradepkg --reinstall --install-new slackpkg+-1.7.0-noarch-10mt.txz

Edite o arquivo /etc/slackpkg/slackpkgplus.conf deixando modificando as seguintes linhas:
#PKGS_PRIORITY=( multilib ) 

deixe assim:
PKGS_PRIORITY=( multilib ) 

Já a linha:
REPOPLUS=( slackpkgplus ) 

deixe assim:
REPOPLUS=( slackpkgplus multilib ) 

E a linha:
# Slackware current - x86_64
#MIRRORPLUS['multilib']=http://bear.alienbase.nl/mirrors/people/alien/multilib/current/ 

deixe assim:
MIRRORPLUS['multilib']=http://bear.alienbase.nl/mirrors/people/alien/multilib/current/ 


Feito isso, execute:

# slackpkg update gpg
# slackpkg update
# slackpkg upgrade-all
# slackpkg search multilib
# slackpkg upgrade multilib
# slackpkg install multilib




5. Re: Kernel Panic - Slackware 64 bit Current - problemas multilib [RESOLVIDO]

Eric
Grinder

(usa Slackware)

Enviado em 27/08/2019 - 01:20h

Eu faço como o edps usando o lftp. É bem simples, basta baixar os arquivos e digitar os comandos para instalar obviamente estando na pasta baixada do multilibs que estará como o nome de "current"
upgradepkg --reinstall --install-new *.t?z 

upgradepkg --install-new slackware64-compat32/*-compat32/*.t?z 


- - - - -
www.gitlab.com/grinder
www.github.com/ericfernandesferreira
www.youtube.com/candelabrus1


6. Re: Kernel Panic - Slackware 64 bit Current - problemas multilib [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 28/08/2019 - 21:17h


zasdrakano escreveu:

Mas no Slackware o wine é do capeta. Desejo que o wine abra alguns pequenos aplicativos do Ruwindows, de 32 bits. Apenas consegui instalar o wine64 no Slackware, pois segundo um pouco que eu li para que o wine funcione tanto 32 bits, quanto 64 bits, preciso instalar uma tal de "multilib".


Eu tô quase passando a bola, mas ainda mantenho o WIne Staging e por causa desse post acabei por habilitar o Multillib na VM do Slack 14.2 para poder empacotar a versão 4.14, as imagens da VM com o WIne Staging rodando estão nessa minha nova dica no meu blog:

https://edpsblog.wordpress.com/2019/08/28/how-to-slackware-multilib/

Para compilar esse SlackBuild tanto para 64bit como 32bit, basta ler isso:

https://slackbuilds.org/slackbuilds/14.2/system/wine-staging/README







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts