wget ação POST com parâmetros [RESOLVIDO]

1. wget ação POST com parâmetros [RESOLVIDO]

Isomi Luiz da Silva
clicsis

(usa Debian)

Enviado em 07/05/2008 - 08:05h

Pediria o auxílio dos amigos no sentido de mais essa questão.
Envia parâmetros "POST" via wget.

Abaixo o caminho que já tentei sem exito.
==============================
wget
--base="http://www.site.com.br/pasta/admin.php"
--referer="http://www.site.com.br/pasta/admin.php"
--post-data="a=post&id=368&message='mensagem'&close=true" http://www.site.com.br/pasta/admin.php
===============================


Observação:
- Todo o código wget está em uma única linha, aqui coloquei um em cada linha para melhor organizar a visualização.


  


2. MELHOR RESPOSTA

Lame Duck
lame_duck_hat

(usa Outra)

Enviado em 07/05/2008 - 09:45h

Nunca usei o método POST, mas acredito estar certo.
O que pode acontecer é que o site precise receber uma informação de que você não é um "robô".

Para isso usamos a opção: --user-agent="Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"

isso fará o wget dizer ao servidor que ele é o navegador Mozilla.
Muitos servidores não enviam, nem recebem nenhuma informação se o navegador não for o Mozilla, Internet Explorer, Opera...
Tente essa opção, se não funcionar me avise, daí assim que estiver com um computador com Linux poderei testar melhor a opção Post do wget

3. Re: wget ação POST com parâmetros [RESOLVIDO]

Isomi Luiz da Silva
clicsis

(usa Debian)

Enviado em 08/05/2008 - 00:02h

Já havia tentado antes, mas fiz conforme mencionou:

wget
--user-agent="Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"
--base="http://www.site.com.br/admin.php"
--referer="http://www.site.com.br/admin.php"
--post-data="&a=post&id=368&message=Respondido&close=true"
http://www.site.com.br/admin.php

Tudo em uma única linha e aparentemente executou sem problema, porem o resultado esperado para a execução do mesmo não ocorrer. Nessa situação em específico, estou fazendo um teste com um sistema de chamado onde o parâmetro "close=true" fecharia o mesmo, mas no entanto o parâmetro não está sendo passado, eo menos não para fazer a função funcionar.

Novamente lhe agradeço pelo auxílio. Vou continuar com outros testes por aqui, enquanto aguardo a ajuda dos amigos.


4. Re: wget ação POST com parâmetros [RESOLVIDO]

Lame Duck
lame_duck_hat

(usa Outra)

Enviado em 08/05/2008 - 09:01h

Testei o comando --post-data para me logar em um fórum e conseguí.
Aparentemente o modo como você está utilizando está certo.
Eu só não sei para que serve a opção "base" do wget.

O que pode acontecer é que o Formulário do HTML mande uma variável "escondida" que você pode não ter visto.

Abra o código fonte do HTML e veja se encontra algum campo input type="hidden",
nele deverá conter "name=nomecampo",
"value=valorcampo"...

Você deverá adicionar isso no campo de envio por post do wget.
No meu exemplo ficaria:
--post-data="nomecampo=valorcampo"

Alguns sites usam mais de um input hidden para evitar que o pessoal use robôs, então fique atento.


5. Re: wget ação POST com parâmetros [RESOLVIDO]

Elgio Schlemer
elgio

(usa OpenSuSE)

Enviado em 08/05/2008 - 09:35h

Pra mim funcionou em uma página MINHA.
Cookies?
(além de tudo que já foi dito, como variáveis escondidas)






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts