fiz um script e não sei o por que não funciona [RESOLVIDO]

1. fiz um script e não sei o por que não funciona [RESOLVIDO]

matheus novaes marinho
Novaesma

(usa Outra)

Enviado em 08/09/2020 - 09:17h

Bom dia, Boa tarde, Boa noite!!
bom fiz esse script e n sei pq ele funciona, acho q é por conta das funções q posso ter feito errado, mas n sei

#!/bin/bash


###LOG para controle de entrada e saida do acesso remoto

echo "|--------------------------------------------" >> $LOG
echo " Sincronizacao iniciada em $INICIO" >> $LOG

##copia dos arquivos do SFA2 e acceso remoto no usuario

CHPE()
{
echo $ scp /home/saai/Catalogo/CHPE/2020/* [email protected]:/home/Teste/Catalogo/CHPG/
}

CHPI()
{
echo $ scp /home/saai/Catalogo/CHPI/2020/* [email protected]:/home/Teste/Catalogo/CHPG/
}

CHPG()
{
echo $ scp /home/saai/Catalogo/CHPG/2020/* [email protected]:/home/Teste/Catalogo/CHPG/
}

echo " Sincronizacao Finalizada em $FINAL" >> $LOG
echo "|--------------------------------------------" >> $LOG



  


2. Re: fiz um script e não sei o por que não funciona

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 08/09/2020 - 09:40h

#!/usr/bin/env bash

###LOG para controle de entrada e saída do acesso remoto
LOG=./reg-log.txt
echo "|--------------------------------------------" >> $LOG
echo "Sincronização iniciada" >> $LOG

##copia dos arquivos do SFA2 e acesso remoto no usuário
CHPE(){
echo scp /home/saai/Catalogo/CHPE/2020/* [email protected]:/home/Teste/Catalogo/CHPG/
}

CHPI(){
echo scp /home/saai/Catalogo/CHPI/2020/* [email protected]:/home/Teste/Catalogo/CHPG/
}

CHPG(){
echo scp /home/saai/Catalogo/CHPG/2020/* [email protected]:/home/Teste/Catalogo/CHPG/
}
CHPE
CHPI
CHPG
echo "Sincronização Finalizada" >> $LOG
echo "|--------------------------------------------" >> $LOG

$INICIO e $FINAL não faz sentido ela não foi definida.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


3. Re: fiz um script e não sei o por que não funciona [RESOLVIDO]

matheus novaes marinho
Novaesma

(usa Outra)

Enviado em 08/09/2020 - 09:43h

mas de resto ta certo ne??


4. Re: fiz um script e não sei o por que não funciona

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 08/09/2020 - 09:46h

Novaesma escreveu:

mas de resto ta certo ne??


Não eu corrigi um monte de coisa incluindo a ortografia.
Na verdade esse script esta muito simples.
Ele deveria ter um IF para verificar se a sincronização realmente foi feita com sucesso.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


5. Re: fiz um script e não sei o por que não funciona

meteoro
meteoro16

(usa Outra)

Enviado em 08/09/2020 - 09:47h

O primeiro problema é que vc declarou as três funções mas não executou nenhuma.
Não seria necessário definir três funções se você vai executar as três imediatamente depois..

Outra coisa estranha:
echo $ scp /home/saai/Catalogo/CHPE/2020/* [email protected]:/home/Teste/Catalogo/CHPG/

O que é esse $ sozinho?
O que vc quer fazer com esse comando exatamente?

Outra coisa, para manter o script organizado, aprendi aqui com alguém
não lembro quem, que por sua vez ouviu da professora,
que devemos definir primero variáveis, depois as funções e depois começamos
a parte de execução do script...

E cuidado em jogar as variáveis sem escapá-las com aspas duplas!!
Do jeito que está, não é seguro, isso quer dizer que se houver espaço
em branco no nome do arquivo vai dar muitos problemas.



6. Re: fiz um script e não sei o por que não funciona

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 08/09/2020 - 09:55h

E acabei de remover o $ que o meteoro16 acabo de dizer abaixo eu nem tinha visto.
Eu não testei eu só corrige.
Eu aprende script bash com 2 cursos do youtube:
https://www.youtube.com/watch?v=ZM--I3NJ2jY&list=PLXoSGejyuQGpf4X-NdGjvSlEFZhn2f2H7
O outro eu não me lembro.
youtube ensina o básico.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


7. Re: fiz um script e não sei o por que não funciona

matheus novaes marinho
Novaesma

(usa Outra)

Enviado em 08/09/2020 - 10:02h

meteoro16 escreveu:

O primeiro problema é que vc declarou as três funções mas não executou nenhuma.
Não seria necessário definir três funções se você vai executar as três imediatamente depois..

Outra coisa estranha:
echo $ scp /home/saai/Catalogo/CHPE/2020/* [email protected]:/home/Teste/Catalogo/CHPG/

O que é esse $ sozinho?
O que vc quer fazer com esse comando exatamente?

Outra coisa, para manter o script organizado, aprendi aqui com alguém
não lembro quem, que por sua vez ouviu da professora,
que devemos definir primero variáveis, depois as funções e depois começamos
a parte de execução do script...

E cuidado em jogar as variáveis sem escapá-las com aspas duplas!!
Do jeito que está, não é seguro, isso quer dizer que se houver espaço
em branco no nome do arquivo vai dar muitos problemas.


então quero q copie os arquivos q estão dentro dos respectivos diretórios e mande para o usuário Teste.
e então para fazer as funções tenho q declara eles pra ai funcionar, isso?!?!


8. Re: fiz um script e não sei o por que não funciona

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 08/09/2020 - 10:08h

Novaesma escreveu:
então quero q copie os arquivos q estão dentro dos respectivos diretórios e mande para o usuário Teste.
e então para fazer as funções tenho q declara eles pra ai funcionar, isso?!?!

Você já declaro o que você não fez é chamá-las.
Não precisava de função nisso ai.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


9. Re: fiz um script e não sei o por que não funciona

matheus novaes marinho
Novaesma

(usa Outra)

Enviado em 08/09/2020 - 10:13h

aguamole escreveu:

Novaesma escreveu:
então quero q copie os arquivos q estão dentro dos respectivos diretórios e mande para o usuário Teste.
e então para fazer as funções tenho q declara eles pra ai funcionar, isso?!?!

Você já declaro o que você não fez é chamá-las.
Não precisava de função nisso ai.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


tendi agr obrigado!!

uma ultima pergunta
echo  scp /home/saai/Catalogo/CHPE/2020/* [email protected]:/home/user/Catalogo/CHPG/  
se eu repetir isso para outros usurário vai da treta??



10. Re: fiz um script e não sei o por que não funciona [RESOLVIDO]

matheus novaes marinho
Novaesma

(usa Outra)

Enviado em 08/09/2020 - 10:14h

aguamole escreveu:

E acabei de remover o $ que o meteoro16 acabo de dizer abaixo eu nem tinha visto.
Eu não testei eu só corrige.
Eu aprende script bash com 2 cursos do youtube:
https://www.youtube.com/watch?v=ZM--I3NJ2jY&list=PLXoSGejyuQGpf4X-NdGjvSlEFZhn2f2H7
O outro eu não me lembro.
youtube ensina o básico.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


vlw vou da uma olhada.


11. Re: fiz um script e não sei o por que não funciona [RESOLVIDO]

meteoro
meteoro16

(usa Outra)

Enviado em 08/09/2020 - 10:51h

olá,

Você já rodou esse comando no terminal?
Gostaria de saber o que aparece aí, aqui no meu o `echo` somente imprime os argumentos
passados para ele. O comando `scp` não pode ser executado atráves de um echo dessa forma..

Não faz sentido esse comando..
Uma sugestão:

<code>
#!/bin/bash

###LOG para controle de entrada e saída do acesso remoto
LOG=reg-log.txt

{
##copia dos arquivos do SFA2 e acesso remoto no usuário
scp /home/saai/Catalogo/CHPE/2020/* [email protected]:/home/Teste/Catalogo/CHPG/ || exit 1

scp /home/saai/Catalogo/CHPI/2020/* [email protected]:/home/Teste/Catalogo/CHPG/ || exit 1

scp /home/saai/Catalogo/CHPG/2020/* [email protected]:/home/Teste/Catalogo/CHPG/ || exit 1

echo "Sincronização Finalizada com Sucesso"
} | tee "$LOG"
</code>

Não sei se esse nedereço de IP é mesmo do INPE,
mas o INPE eu nem queria ajudar nada e ninguém que tenha relação com INPE,
uma instituição que não está fazendo um trabalho
técnico bom o suficiente, conclusões atrapalhadas.
Boa sorte.


12. Re: fiz um script e não sei o por que não funciona [RESOLVIDO]

matheus novaes marinho
Novaesma

(usa Outra)

Enviado em 08/09/2020 - 11:08h

meteoro16 escreveu:

olá,

Você já rodou esse comando no terminal?
Gostaria de saber o que aparece aí, aqui no meu o `echo` somente imprime os argumentos
passados para ele. O comando `scp` não pode ser executado atráves de um echo dessa forma..

Não faz sentido esse comando..
Uma sugestão:

<code>
#!/bin/bash

###LOG para controle de entrada e saída do acesso remoto
LOG=reg-log.txt

{
##copia dos arquivos do SFA2 e acesso remoto no usuário
scp /home/saai/Catalogo/CHPE/2020/* [email protected]:/home/Teste/Catalogo/CHPG/ || exit 1

scp /home/saai/Catalogo/CHPI/2020/* [email protected]:/home/Teste/Catalogo/CHPG/ || exit 1

scp /home/saai/Catalogo/CHPG/2020/* [email protected]:/home/Teste/Catalogo/CHPG/ || exit 1

echo "Sincronização Finalizada com Sucesso"
} | tee "$LOG"
</code>

Não sei se esse nedereço de IP é mesmo do INPE,
mas o INPE eu nem queria ajudar nada e ninguém que tenha relação com INPE,
uma instituição que não está fazendo um trabalho
técnico bom o suficiente, conclusões atrapalhadas.
Boa sorte.


é o ip é do INPE, mas vlw pela ajuda.
o [*****] é ser estagiário aqui dentro e ta mexendo com uma linguagem q nunca mexi.



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts