Problemas com senhas

1. Problemas com senhas

Aldefax G. Kuhn
agk

(usa Debian)

Enviado em 08/11/2005 - 17:20h

Boa tarde colegas!
Estou tendo dificuldades para exportar senhas em scripts, tanto senhas de proxy quanto do samba.

Tenho alguns scripts onde necessito acessar a internet e para isso preciso exportar o proxy dentro desse script.
Estou fazendo assim:
export http_proxy=http://usuario:[email protected]_do_proxy:porta
http_proxy=ftp://usuario:[email protected]_do_proxy:porta

Até aí tudo bem, sempre funcionou normalmente sem problemas.
O problema que estou tendo é quando uso caracteres especias na senha, parece não exportar corretamente.

O mesmo problema ocorre com os scripts que tenho para montar compartilhamento de um servidor Windows NT.
Ex:
smbmount //MICRO_REDE/COMPARTILHAMENTO /home/usuario/mnt/MICRO_REDE/ -o username=usuario%senha,fmask=644,dmask=755,uid=1000,gid=1000,debug=0,workgroup=DOMINIO

Esse problema ocorre com o caractere "@", "%", "$", ":", talvez ocorra com outros também, mas não testei.
Como a política de senhas exige que se tenha caracteres especiais nas senhas tenho que resolver esse problema.
Grato pela atenção colegas.


  


2. Re: Problemas com senhas

Fernando Iury Alves Costa
fernandoiury

(usa Red Hat)

Enviado em 08/11/2005 - 18:41h

bom eu não sei ao certo mas "acho" que o shell pode estar interpretando esses caracteres.

experimente usar ' (aspas simples ou plic, como diz o julio neves)

isso não deixará o shell interpretá-los

ex: 'username'='usuario%senha,fmask=644,dmask=755,uid=1000,gid=1000,debug=0,workgroup=DOMINIO'

export 'http_proxy'='http://usuario:[email protected]_do_proxy:porta'

e por aí vai...

[]´s


3. Re: Problemas com senhas

Aldefax G. Kuhn
agk

(usa Debian)

Enviado em 08/11/2005 - 19:19h

Isso mesmo, coloquei as aspas e funcionou perfeitamente. Acho que vou acabar comprando alguns desses livros do Julio Neves, eheheh.
Valeu pela força!!