Problemas com apt-get

1. Problemas com apt-get

wygor felipe vyacheslavovich
vyacheslavovich

(usa Ubuntu)

Enviado em 23/04/2014 - 19:51h

galera to ha horas passando apurado com o meu notebook... ele roda o ubuntu 10.10 maverickeu nao to conseguindo instalar o wireshark nem nenhum outro programa no pc pelo software center ou pelo terminal

o problema primário é esse:

=========================================================================================================

root@infotech-server:/home/infotech# apt-get install wireshark
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
gnome-menus : Quebra: alacarte (< 0.13.2-2) mas 0.13.2-0ubuntu1 está para ser instalado
E: Pacotes quebrados
root@infotech-server:/home/infotech#

=========================================================================================================

ja atualizei o /etc/apt/sources.list um quinquilhão de vezes pq o o comando nao alcançava nenhum repositório ai eu consegui uma lista interessante, um tanto velha mas funcionou rodei o comando

# apt-get update e ele alcançou todos os repositórios mas quando rodei o comando #apt-get install deu nisso ai em cima

peço ajuda a todos,tenho muitos conhecimentos em linux mas eu eu sou um tanto espertinho me dêem uma ideia de como solucionar esse problema

thankyou all so much!


  


2. Re: Problemas com apt-get

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 23/04/2014 - 20:22h

seu problema é simples... Ubuntu 10 é muito antigo não é mais atualizável, não há mais suporte ou pacotes para ele.

não adiantará trocar os repositórios, não há pacotes para ele. Ubuntu não é Rolling Release...

faça backup de seus arquivos e instale limpo o Ubuntu novo, o 14.


3. Re: Problemas com apt-get

danilo
danilosampaio

(usa Debian)

Enviado em 24/04/2014 - 11:16h

Se você realmente precisa manter a versão mais antiga do seu Ubuntu, talvez ainda exista uma solução:

Pelo que entendi, o pacote 'gnome-menus' depende do pacote 'alacarte', e o problema é que no seu repositório a versão do 'alacarte' que está disponível é a '0.13.2-0ubuntu1' que é menor do que a versão requerida '0.13.2-2'.

Sugestão para tentar resolver seu problema:

- Instale manualmente o pacote 'alacarte' na versão '0.13.2-2' (baixe o binário ou o fonte)
- E depois tente instalar o wireshark novamente

P.S. as instalações manuais podem depender de outras instalações, e assim por diante. Prepare-se para o pior :(

Boa sorte.


4. Re: Problemas com apt-get

Lucas Doná Sfalcin
lucasdona

(usa Linux Mint)

Enviado em 24/04/2014 - 11:55h

As vezes eu faço uma "gambiarra" para instalar programas, heheheh, sempre funcionou comigo.
Mudo os nomes em /etc/apt/sources.list para uma distribuição que tem suporte.
Pode usar o comando sed para alterar os nomes para não ter muito trabalho.

Exemplo, mudar o repositório do ubuntu 10.10 (Maverick) para o 12.10 (Quantal)

sudo sed -i "s/maverick/quantal/g" /etc/apt/sources.list 


Só dar um apt-get update pra atualizar a lista e pronto.
Não é muito aconselhável, mas funciona.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts