Servidor não compartilha a conexão para rede interna [RESOLVIDO]

1. Servidor não compartilha a conexão para rede interna [RESOLVIDO]

silvio antonio dos santos
pqd

(usa Debian)

Enviado em 08/12/2010 - 12:05h

Olá meus amigos estou com um problema com meu servidor, estou utilizando um Debian lenny, meus arquivos.conf aparentemente estão corretos, estou postando eles aqui para que vcs deem uma olhada por favor, e se tiver algo errado me corrijam ok obrigado.

#configuração do Squid

http_port 3128
visible_hostname servidor

cache_mem 64 MB
maximum_object_size_in_memory 64 KB
maximum_object_size 512 MB
minimum_object_size 0 KB
cache_swap_low 90
cache_swap_high 95
cache_dir ufs /var/spool/squid/ 5000 16 256
cache_access_log /var/log/squid/access.log
refresh_pattern ^ftp: 15 20% 2280
refresh_pattern ^gopher: 15 0% 2280
refresh_pattern . 15 20% 2280

acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl SSL_ports port 443 563
acl Safe_ports port 21 80 443 563 70 210 280 488 59 777 901 1025-65535
acl purge method PURGE
acl CONNECT method CONNECT

http_access allow manager localhost
http_access deny manager
http_access allow purge localhost
http_access deny purge
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports


acl redelocal src 192.168.3.0/24
http_access deny !redelocal

acl bloqueados url_regex -i "/etc/squid/bloqueados"
http_access deny bloqueados

auth_param basic realm Squid
auth_param basic program /usr/lib/squid/ncsa_auth /etc/squid/squid_passwd
acl autenticados proxy_auth REQUIRED
http_access allow autenticados

http_access allow localhost
http_access allow redelocal
http_access deny all
#########################################################################

#O meu arquivo do iptables ficou assim:

#cd /etc/roteamento
sevidor:/etc/roteamento# vi firewall.sh


# Conf do FIREWALL

REDEMASQ=192.168.3.0/24


iptables -P INPUT DROP
iptables -P FORWARD DROP
iptables -P OUTPUT ACCEPT
iptables -A INPUT -i lo -j ACCEPT
iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT

echo 1 > /proc/sys/net/ipv4/ip_forward

iptables -t nat -A POSTROUTING -s $REDEMASQ -o eth2 -j MASQUERADE
iptables -A FORWARD -o eth1 -m state --state NEW,INVALID -j DROP
iptables -A FORWARD -o eth1 -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -i eth1 -s $REDEMASQ -j ACCEPT
iptables -A FORWARD -j DROP
iptables -A INPUT -j DROP

echo "Roteamento habilitado com sucesso"
##########################################################################



  


2. Re: Servidor não compartilha a conexão para rede interna [RESOLVIDO]

Francisco Wótila C. Cruz
Wotila_Carneiro

(usa Ubuntu)

Enviado em 09/12/2010 - 12:42h

Tenta adicionar essas linhas:

modprobe iptable_nat
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

*substitua eth0 pela placa de internet

Vê ai se dá certo.


3. Resolvi

silvio antonio dos santos
pqd

(usa Debian)

Enviado em 10/12/2010 - 08:32h

Ola caros colegas o problema foi solucionado muito obrigado.Eu tinha 2 problemas:
1 O meu server não estava compartilhando a net.
Solução era o numero das placas de redes que estavam errado.
2 O Squid não estava funcionando nas estações da rede,as mesmas não conseguiam acessar a internet através do proxy.
Solução Não sei se tem algo a ver, mas após eu ter instalado o Apache o proxy começou a funcionar redondinho.

Obrigado a todos






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts