Servidor IBM com Software RAID 1 e Ubuntu Server

1. Servidor IBM com Software RAID 1 e Ubuntu Server

Paulo Roberto de Oliveira Braga
pr02nl

(usa Debian)

Enviado em 21/08/2012 - 15:55h

Prezados,

Estou com problemas para instalar o Ubuntu Server 12.04 em uma maquina da IBM, mas precisamente a System x3100 M4. Possuo dois hds de 500Gb cada e preciso fazer Raid 1 com os dois, já tentei fazer criar o Raid no setup, mas o Ubuntu não reconhece, já criei o particionamento com o Software Raid do Linux e até consegui instalar, mas sem uma partição EFI fora do Raid ele não consegue bootar. Então meu problema atual é, preciso que os dois HD's consigam dar boot, pois no caso atual somente um da boot, se ele falhar o sistema não inicia, se o segundo falhar tudo bem.

Espero que a comunidade possa me ajudar, já estou apanhando a dois dias e já googlei muito e ainda não encontrei uma solução.


  


2. Re: Servidor IBM com Software RAID 1 e Ubuntu Server

Teófilo Alenquer
alenquer

(usa Outra)

Enviado em 27/08/2012 - 18:06h

Amigo, não consigo sequer iniciar a instalação do ubuntu 12.04 nessa máquina. Ela abre o menu para escolher a instalação, clico em iniciar a instalação mas a tela fica preta. Você poderia me dar uma dica ai do que fazer?


3. Re: Servidor IBM com Software RAID 1 e Ubuntu Server

Diego Gomes Teixeira
diegogt

(usa Outra)

Enviado em 23/10/2012 - 16:23h

estou com o mesmo problema do amigo Alenquer. Se alguém tiver alguma solução, favor comentar.

grato.


4. Re: Servidor IBM com Software RAID 1 e Ubuntu Server

Marcelo Becker Franzen
mbfranzen

(usa Ubuntu)

Enviado em 08/11/2012 - 10:01h

Estou com o mesmo problema, estou tentando instalar com debian. O máximo que consegui foi ele reconhecer o raid colocando a opção dmraid=true na tela inicial de instalação digitando TAB, mas na hora do particionamento do disco ele diz que está Readonly e não completa a operação. Ontem na madrugada instalei o Opensuse e reconheceu tudo, particionou e me entregou o servidor instalado e pronto para funcionamento. Hoje vou instalar o Centos e o Fedora para ver qual fica melhor.



5. Re: Servidor IBM com Software RAID 1 e Ubuntu Server

Angelo de Barros Delphini
ADelphini

(usa Arch Linux)

Enviado em 06/02/2013 - 09:20h

Estou com o mesmo problema encontrei este passo a passo...

http://laurobmb.wordpress.com/2011/09/07/criando-raid-1-no-ibm-x3500m3/

Quem conseguir avise...

Att.


6. Re: Servidor IBM com Software RAID 1 e Ubuntu Server

Angelo de Barros Delphini
ADelphini

(usa Arch Linux)

Enviado em 06/02/2013 - 10:31h

Consegui resolver com este cd...

http://www-947.ibm.com/support/entry/portal/docdisplay?lndocid=migr-60624

Abraços.



7. Re: Servidor IBM com Software RAID 1 e Ubuntu Server

Fabricio André da Silva BAptista
fabricomp

(usa Debian)

Enviado em 28/07/2013 - 15:44h

Adelphini,

Poderia descrever como você resolveu utilizando o CD? estou com o mesmo problema.

Abraços.



8. Re: Servidor IBM com Software RAID 1 e Ubuntu Server

Angelo de Barros Delphini
ADelphini

(usa Arch Linux)

Enviado em 11/10/2013 - 19:06h

Na verdade eu consegui seguindo este passo a passo:

http://laurobmb.wordpress.com/2011/09/07/criando-raid-1-no-ibm-x3500m3/

Mas somente que utilizando este CD:

http://www-947.ibm.com/support/entry/portal/docdisplay?lndocid=migr-60624

Att.


9. Re: Servidor IBM com Software RAID 1 e Ubuntu Server

Elgio Schlemer
elgio

(usa OpenSuSE)

Enviado em 07/02/2014 - 20:09h

mbfranzen escreveu:

Estou com o mesmo problema, estou tentando instalar com debian. O máximo que consegui foi ele reconhecer o raid colocando a opção dmraid=true na tela inicial de instalação digitando TAB, mas na hora do particionamento do disco ele diz que está Readonly e não completa a operação. Ontem na madrugada instalei o Opensuse e reconheceu tudo, particionou e me entregou o servidor instalado e pronto para funcionamento. Hoje vou instalar o Centos e o Fedora para ver qual fica melhor.


Dois anos após este post, cá estou eu com o mesmo problema.
Mesmo servidor, RAID 1, etc.

Ubuntu 12.04 LTS i386: não detecta disco algum, impossibilitando sequer o particionamento. dmraid=true no grub não surtiu efeito (durante a instalação ele pergunta se quer ativar o RAID, mesmo respondendo que sim, nada feito)

Ubuntu 12.04 LTS AMD64: não passa do grub. Grub abre um console onde não se consegue fazer nada.

Estou baixando agora um Debian. Centos e Fedora funcionou? Não queria OpenSuse. Apesar de adorar esta distro, não quero ficar longe do apt-get!


10. SOLUÇÃO

Péricles Guimarães Fortes
pgfortes

(usa Debian)

Enviado em 12/03/2014 - 17:13h

Eu tambem estava com o mesmo problema, Servidor IBM x3100 M4 dois hds de 2Tb cada, instalando o debian 6.0.5 amd64,

solucionei através de dois topicos:

http://www.vivaolinux.com.br/topico/Servidores-Linux-para-iniciantes/RAID-1-em-HDs-de-2TB

http://stackful-dev.com/raid-install-ubuntu-server-on-a-large-hard-drive.html

o segundo Link é em ingles, mas se tiver o chrome instalado basta manda-lo traduzir.
No meu caso, fiz o seguinte particionamento:

partição 1: bios_grub (100MB) - Sem RAID
partição 2: Swap (30 GB) - RAID
partição 3: \ (100GB) - RAID
partição 4: \arquivos (1.9 TB) - RAID

Espero ter ajudado!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts