Servidor CentOS! Cai a Luz fico sem internet.... [RESOLVIDO]

1. Servidor CentOS! Cai a Luz fico sem internet.... [RESOLVIDO]

Mateus
mhasselein

(usa CentOS)

Enviado em 04/04/2013 - 14:02h

Olá galera! Sou um pouco leigo em servidor Linux. Vi que cada vez que cai a luz e reinicia o servidor fico sem internet...Dae chamamos uma empresa e logo o cara coloca no ar a internete novamente...O que pode ser, o que devo fazer para mim mesmo colocar no ar a internet???Utilizamos CentOS 6.2...


  


2. Re: Servidor CentOS! Cai a Luz fico sem internet.... [RESOLVIDO]

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 04/04/2013 - 14:05h

Na boa, o script d firewall não tá sendo executado durante o boot. Encontre-o e coloque para ser executado dentro d /etc/rc.local.


3. Re: Servidor CentOS! Cai a Luz fico sem internet.... [RESOLVIDO]

João Paulo Carneiro
jptudobem

(usa Debian)

Enviado em 04/04/2013 - 14:24h

Bem ixperta essa empresa também heim?!


4. Re: Servidor CentOS! Cai a Luz fico sem internet.... [RESOLVIDO]

Mateus
mhasselein

(usa CentOS)

Enviado em 04/04/2013 - 14:31h

E como eu acho este arquivo? Como é o nome dele?


5. Re: Servidor CentOS! Cai a Luz fico sem internet.... [RESOLVIDO]

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 04/04/2013 - 14:44h

Ixi, kra, o nome são eles q escolhem, mas não é tão difícil d achar. Tente executar o comando abaixo (como root):


find / -iname "*.sh"


E veja se há algum script com nome d firewall ou iptables ou algo do gênero.


6. Re: Servidor CentOS! Cai a Luz fico sem internet.... [RESOLVIDO]

Marcelo Theodoro
MarceloTheodoro

(usa Debian)

Enviado em 04/04/2013 - 14:51h

Faz o seguinte, se logue no mesmo usuário que eles usam, e dê o comando "history"

Vai mostrar o histórico de comandos.
Ou se preferir, procure pelo arquivo .bash_history no home do usuário.


7. Re: Servidor CentOS! Cai a Luz fico sem internet.... [RESOLVIDO]

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 04/04/2013 - 14:52h

MarceloTheodoro escreveu:

Faz o seguinte, se logue no mesmo usuário que eles usam, e dê o comando "history"

Vai mostrar o histórico de comandos.
Ou se preferir, procure pelo arquivo .bash_history no home do usuário.


É mais inteligente essa opção...


8. Re: Servidor CentOS! Cai a Luz fico sem internet.... [RESOLVIDO]

Mateus
mhasselein

(usa CentOS)

Enviado em 04/04/2013 - 15:02h

Me esqueci de mensionar é só quando cai a luz pois as baterias no nobreak ta pifada.
Mesmo que eles tenham feito remotamente eu posso ver os comandos?



9. Re: Servidor CentOS! Cai a Luz fico sem internet.... [RESOLVIDO]

Marcelo Theodoro
MarceloTheodoro

(usa Debian)

Enviado em 04/04/2013 - 15:04h

mhasselein escreveu:

Mesmo que eles tenham feito remotamente? Posso ver os comandos?


Se você tiver acesso ao usuário que eles usaram, sim.


10. Re: Servidor CentOS! Cai a Luz fico sem internet.... [RESOLVIDO]

Mateus
mhasselein

(usa CentOS)

Enviado em 04/04/2013 - 21:14h

Aqui tem os comandos dados!!!!
tail -f /var/log/squid/access.log
echo "1" > /proc/sys/net/ipv4/ip_forward
ifconfig
ping 8.8.8.8
arp
tail -f /var/log/squid/access.log
nano /etc/squid/squid.conf
tail -f /var/log/squid/access.log
/etc/init.d/firewall start
iptables -L
tail -f /var/log/squid/access.log

Se alguem puder me ajudar...


11. Re: Servidor CentOS! Cai a Luz fico sem internet.... [RESOLVIDO]

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 05/04/2013 - 10:05h

Basicamente é isso:

echo "1" > /proc/sys/net/ipv4/ip_forward 


Ou vc pode colocá-lo no /etc/rc.local ou vc pode editar o arquivo /etc/sysctl.conf, inserindo a opção net.ipv4.ip_forward = 1.


12. Re: Servidor CentOS! Cai a Luz fico sem internet.... [RESOLVIDO]

Vinicius Cardoso Merlim
viniciusmerlim

(usa CentOS)

Enviado em 05/04/2013 - 12:01h

MarceloTheodoro escreveu:

Faz o seguinte, se logue no mesmo usuário que eles usam, e dê o comando "history"

Vai mostrar o histórico de comandos.
Ou se preferir, procure pelo arquivo .bash_history no home do usuário.


hehehehe eu faria isso tbm...

Porém, se nao der certo... tenta ifconfig eth0 up
vai que eh só a config de rede que nao sobe.
ou um /etc/init.d/network restart

sei la, vc tem q explicar mais isso ai



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts