Problema para conectar no VBoxHeadless

1. Problema para conectar no VBoxHeadless

Bruno
brunomc

(usa CentOS)

Enviado em 13/03/2019 - 15:14h

Pessoal boa tarde,

Estou quebrando a cabeça a 2 semanas e depois de ser direcionado algumas vezes para o vivaolinux, pensei em pedir ajuda aqui.

Meu objetivo é colocar para funcionar uma máquina virtual CentOS 7 no Virtualbox, utilizando o VBox Headless. O Host também é CentOS 7.

Eu instalei o CentOS 7 e em seguida o VirtualBox 6.0.4. Dei o start na máquina virtual e recebi a mensagem de
VRDE server is listening on port 3389.
. Porém da minha máquina windows não estou conseguindo acessar via mstsc, utilizando o ip do Host 192.168.1.6 ou 192.168.1.6:3389.

Segue o showvminfo da máquina virtual. Agradeço desde já a ajuda.

[root@excomvh ~]# VBoxManage showvminfo "CentOS 7 Conexos App"
Name: CentOS 7 Conexos App
Groups: /
Guest OS: Red Hat (64-bit)
UUID: 4329b261-22b1-4206-879b-14c59157874f
Config file: /root/VirtualBox VMs/CentOS 7 Conexos App/CentOS 7 Conexos App.vbox
Snapshot folder: /root/VirtualBox VMs/CentOS 7 Conexos App/Snapshots
Log folder: /root/VirtualBox VMs/CentOS 7 Conexos App/Logs
Hardware UUID: 4329b261-22b1-4206-879b-14c59157874f
Memory size 4096MB
Page Fusion: disabled
VRAM size: 8MB
CPU exec cap: 100%
HPET: disabled
CPUProfile: host
Chipset: piix3
Firmware: BIOS
Number of CPUs: 1
PAE: enabled
Long Mode: enabled
Triple Fault Reset: disabled
APIC: enabled
X2APIC: enabled
Nested VT-x/AMD-V: disabled
CPUID Portability Level: 0
CPUID overrides: None
Boot menu mode: message and menu
Boot Device 1: DVD
Boot Device 2: HardDisk
Boot Device 3: Not Assigned
Boot Device 4: Not Assigned
ACPI: enabled
IOAPIC: enabled
BIOS APIC mode: APIC
Time offset: 0ms
RTC: local time
Hardw. virt.ext: enabled
Nested Paging: enabled
Large Pages: disabled
VT-x VPID: enabled
VT-x unr. exec.: enabled
Paravirt. Provider: Default
Effective Paravirt. Prov.: KVM
State: aborted (since 2019-03-13T17:21:31.000000000)
Monitor count: 1
3D Acceleration: disabled
2D Video Acceleration: disabled
Teleporter Enabled: disabled
Teleporter Port: 0
Teleporter Address:
Teleporter Password:
Tracing Enabled: disabled
Allow Tracing to Access VM: disabled
Tracing Configuration:
Autostart Enabled: disabled
Autostart Delay: 0
Default Frontend:
Storage Controller Name (0): IDE Controller
Storage Controller Type (0): PIIX4
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0): 2
Storage Controller Port Count (0): 2
Storage Controller Bootable (0): on
IDE Controller (0, 0): /root/ConexosApp.vdi (UUID: e7990260-5333-4555-8c35-a4d4e174d086)
IDE Controller (0, 1): /tmp/CentOS7.iso (UUID: e9b06631-7331-4d43-8bc9-d66e3b712453)
NIC 1: MAC: 080027677F58, Attachment: NAT, Cable connected: on, Trace: off (file: none), Type: 82540EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none
NIC 1 Settings: MTU: 0, Socket (send: 64, receive: 64), TCP Window (send:64, receive: 64)
NIC 2: disabled
NIC 3: disabled
NIC 4: disabled
NIC 5: disabled
NIC 6: disabled
NIC 7: disabled
NIC 8: disabled
Pointing Device: PS/2 Mouse
Keyboard Device: PS/2 Keyboard
UART 1: disabled
UART 2: disabled
UART 3: disabled
UART 4: disabled
LPT 1: disabled
LPT 2: disabled
Audio: enabled (Driver: ALSA, Controller: AC97, Codec: STAC9700)
Audio playback: disabled
Audio capture: disabled
Clipboard Mode: disabled
Drag and drop Mode: disabled
VRDE: enabled (Address 192.168.1.6, Ports 3389, MultiConn: off, ReuseSingleConn: off, Authentication type: null)
Video redirection: disabled
VRDE property : TCP/Ports = "3389"
VRDE property : TCP/Address = "192.168.1.6"
VRDE property : VideoChannel/Enabled = <not set>
VRDE property : VideoChannel/Quality = <not set>
VRDE property : VideoChannel/DownscaleProtection = <not set>
VRDE property : Client/DisableDisplay = <not set>
VRDE property : Client/DisableInput = <not set>
VRDE property : Client/DisableAudio = <not set>
VRDE property : Client/DisableUSB = <not set>
VRDE property : Client/DisableClipboard = <not set>
VRDE property : Client/DisableUpstreamAudio = <not set>
VRDE property : Client/DisableRDPDR = <not set>
VRDE property : H3DRedirect/Enabled = <not set>
VRDE property : Security/Method = <not set>
VRDE property : Security/ServerCertificate = <not set>
VRDE property : Security/ServerPrivateKey = <not set>
VRDE property : Security/CACertificate = <not set>
VRDE property : Audio/RateCorrectionMode = <not set>
VRDE property : Audio/LogPath = <not set>
OHCI USB: disabled
EHCI USB: disabled
xHCI USB: disabled

USB Device Filters:

<none>

Bandwidth groups: <none>

Shared folders:<none>

Capturing: not active
Capture audio: not active
Capture screens: 0
Capture file: /root/VirtualBox VMs/CentOS 7 Conexos App/CentOS 7 Conexos App.webm
Capture dimensions: 1024x768
Capture rate: 512kbps
Capture FPS: 25kbps
Capture options:

Guest:

Configured memory balloon size: 0MB




  


2. Re: Problema para conectar no VBoxHeadless

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 14/03/2019 - 10:13h


NIC 1: MAC: 080027677F58, Attachment: NAT, Cable connected: on, Trace: off (file: none), Type: 82540EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none


Veja q vc configurou a interface de rede como NAT. Assim vc não vai conseguir nunca. Vc tem q configurar em modo Bridge pra pegar o IP da rede física.
--
http://br.linkedin.com/in/renatocarneirop
http://www.facebook.com/renatocarneirop

"Não acredite no que eu digo, pois é a minha experiência e não a sua. Experimente, indague e busque." - Osho Rajneesh


3. Re: Problema para conectar no VBoxHeadless

Bruno
brunomc

(usa CentOS)

Enviado em 14/03/2019 - 16:41h

Oi Renato, obrigado pela atenção.

Fiz a mudança que você sugeriu. Mas continuo sem conseguir conectar na vm.

Comando usado:
VBoxManage modifyvm "CentOS 7 Conexos App" --nic1 bridged --bridgeadapter1 em1 


Confirmando nome do adaptador
[root@excomvh ~]# ifconfig
em1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.1.6 netmask 255.255.255.0 broadcast 192.168.1.255
inet6 fe80::eb56:f533:eb95:f9c0 prefixlen 64 scopeid 0x20<link>
ether d0:94:66:af:3b:b1 txqueuelen 1000 (Ethernet)
RX packets 21881 bytes 3933678 (3.7 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 291 bytes 55627 (54.3 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 16


Novo showvminfo
[root@excomvh ~]# VBoxManage showvminfo "CentOS 7 Conexos App"
Name: CentOS 7 Conexos App
Groups: /
Guest OS: Red Hat (64-bit)
UUID: 4329b261-22b1-4206-879b-14c59157874f
Config file: /root/VirtualBox VMs/CentOS 7 Conexos App/CentOS 7 Conexos App.vbox
Snapshot folder: /root/VirtualBox VMs/CentOS 7 Conexos App/Snapshots
Log folder: /root/VirtualBox VMs/CentOS 7 Conexos App/Logs
Hardware UUID: 4329b261-22b1-4206-879b-14c59157874f
Memory size 4096MB
Page Fusion: disabled
VRAM size: 8MB
CPU exec cap: 100%
HPET: disabled
CPUProfile: host
Chipset: piix3
Firmware: BIOS
Number of CPUs: 1
PAE: enabled
Long Mode: enabled
Triple Fault Reset: disabled
APIC: enabled
X2APIC: enabled
Nested VT-x/AMD-V: disabled
CPUID Portability Level: 0
CPUID overrides: None
Boot menu mode: message and menu
Boot Device 1: DVD
Boot Device 2: HardDisk
Boot Device 3: Not Assigned
Boot Device 4: Not Assigned
ACPI: enabled
IOAPIC: enabled
BIOS APIC mode: APIC
Time offset: 0ms
RTC: local time
Hardw. virt.ext: enabled
Nested Paging: enabled
Large Pages: disabled
VT-x VPID: enabled
VT-x unr. exec.: enabled
Paravirt. Provider: Default
Effective Paravirt. Prov.: KVM
State: running (since 2019-03-14T19:37:47.713000000)
Monitor count: 1
3D Acceleration: disabled
2D Video Acceleration: disabled
Teleporter Enabled: disabled
Teleporter Port: 0
Teleporter Address:
Teleporter Password:
Tracing Enabled: disabled
Allow Tracing to Access VM: disabled
Tracing Configuration:
Autostart Enabled: disabled
Autostart Delay: 0
Default Frontend:
Storage Controller Name (0): IDE Controller
Storage Controller Type (0): PIIX4
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0): 2
Storage Controller Port Count (0): 2
Storage Controller Bootable (0): on
IDE Controller (0, 0): /root/ConexosApp.vdi (UUID: e7990260-5333-4555-8c35-a4d4e174d086)
IDE Controller (0, 1): /tmp/CentOS7.iso (UUID: e9b06631-7331-4d43-8bc9-d66e3b712453)
NIC 1: MAC: 080027677F58, Attachment: Bridged Interface 'em1', Cable connected: on, Trace: off (file: none), Type: 82540EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none
NIC 2: disabled
NIC 3: disabled
NIC 4: disabled
NIC 5: disabled
NIC 6: disabled
NIC 7: disabled
NIC 8: disabled
Pointing Device: PS/2 Mouse
Keyboard Device: PS/2 Keyboard
UART 1: disabled
UART 2: disabled
UART 3: disabled
UART 4: disabled
LPT 1: disabled
LPT 2: disabled
Audio: enabled (Driver: ALSA, Controller: AC97, Codec: STAC9700)
Audio playback: disabled
Audio capture: disabled
Clipboard Mode: disabled
Drag and drop Mode: disabled
Session name: headless
Video mode: 1024x768x32 at 0,0 enabled
VRDE: enabled (Address 192.168.1.6, Ports 3389, MultiConn: off, ReuseSingleConn: off, Authentication type: null)
VRDE port: 3389
Video redirection: disabled
VRDE property : TCP/Ports = "3389"
VRDE property : TCP/Address = "192.168.1.6"
VRDE property : VideoChannel/Enabled = <not set>
VRDE property : VideoChannel/Quality = <not set>
VRDE property : VideoChannel/DownscaleProtection = <not set>
VRDE property : Client/DisableDisplay = <not set>
VRDE property : Client/DisableInput = <not set>
VRDE property : Client/DisableAudio = <not set>
VRDE property : Client/DisableUSB = <not set>
VRDE property : Client/DisableClipboard = <not set>
VRDE property : Client/DisableUpstreamAudio = <not set>
VRDE property : Client/DisableRDPDR = <not set>
VRDE property : H3DRedirect/Enabled = <not set>
VRDE property : Security/Method = <not set>
VRDE property : Security/ServerCertificate = <not set>
VRDE property : Security/ServerPrivateKey = <not set>
VRDE property : Security/CACertificate = <not set>
VRDE property : Audio/RateCorrectionMode = <not set>
VRDE property : Audio/LogPath = <not set>
OHCI USB: disabled
EHCI USB: disabled
xHCI USB: disabled

USB Device Filters:

<none>

Available remote USB devices:

<none>

Currently Attached USB Devices:

<none>

Bandwidth groups: <none>

Shared folders:<none>

VRDE Connection: not active
Clients so far: 0

Capturing: not active
Capture audio: not active
Capture screens: 0
Capture file: /root/VirtualBox VMs/CentOS 7 Conexos App/CentOS 7 Conexos App.webm
Capture dimensions: 1024x768
Capture rate: 512kbps
Capture FPS: 25kbps
Capture options:

Guest:

Configured memory balloon size: 0MB
OS type: RedHat_64
Additions run level: 0

Guest Facilities:

No active facilities.




4. Re: Problema para conectar no VBoxHeadless

Bruno
brunomc

(usa CentOS)

Enviado em 14/03/2019 - 17:09h

Fiquei na dúvida se tinha instalado o Ext pack correto, mas está certo sim.

 VBoxManage list extpacks
Extension Packs: 1
Pack no. 0: Oracle VM VirtualBox Extension Pack
Version: 6.0.4
Revision: 128413
Edition:
Description: USB 2.0 and USB 3.0 Host Controller, Host Webcam, VirtualBox RDP, PXE ROM, Disk Encryption, NVMe.
VRDE Module: VBoxVRDP
Usable: true
Why unusable:



5. Re: Problema para conectar no VBoxHeadless

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 15/03/2019 - 09:43h

Pelo visto vc tá configurando a interface de rede com IP fixo, correto? Se sim, deixe q o DHCP entregue as configurações pra sua VM. Assim, ele vai configurar gateway, IP, máscara e DNS automaticamente.

--
http://br.linkedin.com/in/renatocarneirop
http://www.facebook.com/renatocarneirop

"Não acredite no que eu digo, pois é a minha experiência e não a sua. Experimente, indague e busque." - Osho Rajneesh


6. Re: Problema para conectar no VBoxHeadless

Bruno
brunomc

(usa CentOS)

Enviado em 15/03/2019 - 10:00h

Nesse caso não dá, não tenho DHCP ativo na rede.


7. Re: Problema para conectar no VBoxHeadless

Bruno
brunomc

(usa CentOS)

Enviado em 15/03/2019 - 10:06h

Reparei que o arquivo .vdi não está na mesma pasta do restante da VM. Isso é um problema?

/root/ConexosApp.vdi

Config file: /root/VirtualBox VMs/CentOS 7 Conexos App/CentOS 7 Conexos App.vbox
Snapshot folder: /root/VirtualBox VMs/CentOS 7 Conexos App/Snapshots
Log folder: /root/VirtualBox VMs/CentOS 7 Conexos App/Logs





8. Re: Problema para conectar no VBoxHeadless

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 15/03/2019 - 10:48h

brunomc escreveu:

Nesse caso não dá, não tenho DHCP ativo na rede.


Então revise essas confs ae, pq tem alguma coisa errada. Vc já mudou pra bridge, então é só configurar a rede corretamente.

--
http://br.linkedin.com/in/renatocarneirop
http://www.facebook.com/renatocarneirop

"Não acredite no que eu digo, pois é a minha experiência e não a sua. Experimente, indague e busque." - Osho Rajneesh


9. Re: Problema para conectar no VBoxHeadless

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 15/03/2019 - 10:48h

brunomc escreveu:

Reparei que o arquivo .vdi não está na mesma pasta do restante da VM. Isso é um problema?

/root/ConexosApp.vdi

Config file: /root/VirtualBox VMs/CentOS 7 Conexos App/CentOS 7 Conexos App.vbox
Snapshot folder: /root/VirtualBox VMs/CentOS 7 Conexos App/Snapshots
Log folder: /root/VirtualBox VMs/CentOS 7 Conexos App/Logs




Se fosse problema, sua VM nem teria rodado.

--
http://br.linkedin.com/in/renatocarneirop
http://www.facebook.com/renatocarneirop

"Não acredite no que eu digo, pois é a minha experiência e não a sua. Experimente, indague e busque." - Osho Rajneesh


10. Re: Problema para conectar no VBoxHeadless

Bruno
brunomc

(usa CentOS)

Enviado em 15/03/2019 - 10:50h

Eu decidi reinstalar tudo do zero, e tentar identificar algum problema no processo.

Imagino que o correto seja marcar esse tópico como resolvido e abrir um novo caso necessário.

Agradeço toda a ajuda.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts