Erro Aptitude

1. Erro Aptitude

Clayton José de Sousa
clayton.sousa

(usa Debian)

Enviado em 13/04/2011 - 00:00h

Pessoal,

Não sei o que aconteceu mais quando vou instalar algum pacote com o aptitude ou apt-get aparece a seguinte mensagem:

aptitude: symbol lookup error: /usr/lib/libstdc++.so.6: undefined symbol: _ZNSt8messagesIcE2idE, version GLIBCXX_3.4

Não consigo mais instalar pacotes.


  


2. Re: Erro Aptitude

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 13/04/2011 - 09:48h

Ixi... vc fez alguma caca ae.

Quando acontece isso, é pq vc pode t atualizado o compilador C (gcc) para uma versão superior à compilada do sistema ou vc tá tentando instalar algum aplicativo já compilado com o gcc 3.4 e q esteja chiando no momento da execução.


3. Re: Erro Aptitude

Clayton José de Sousa
clayton.sousa

(usa Debian)

Enviado em 13/04/2011 - 10:19h

Qualquer coisa que eu faça no aptiude ou apt-get da esse erro, até mesmo o aptitude update.

Tem solução?


4. Re: Erro Aptitude

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 13/04/2011 - 10:37h

Solução tem. O problema é descobrir a origem, d acordo com o q disse anteriormente. Nesse caso, é vc q tem q saber o q andou fazendo nesses últimos dias.


5. Re: Erro Aptitude

Raul Lopes S. Grangeiro
raulgrangeiro

(usa Fedora)

Enviado em 13/04/2011 - 12:58h

Eae cumpade, eu não sei bem que erro é esse, e não sou usuário avançado, mas tenta remover o gcc com o comando:

$ sudo dpkg -r gcc

Depois você tenta instalar ele de novo:

$ sudo apt-get install gcc

ou

$ sudo aptitude install gcc

Espero ter ajudado!


6. Re: Erro Aptitude

Clayton José de Sousa
clayton.sousa

(usa Debian)

Enviado em 13/04/2011 - 21:53h

Continua dando o mesmo erro.

Não consigo instalar nada é fogo mesmo esse erro.


7. Re: Erro Aptitude

Clayton José de Sousa
clayton.sousa

(usa Debian)

Enviado em 15/04/2011 - 11:17h

A esses dias atrás tentamos instalar o pacote NX server faltou algumas bibliotecas e instalamos.


8. Re: Erro Aptitude

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 15/04/2011 - 13:12h

Clayton,

tenta este comando dpkg –configure -a



9. Re: Erro Aptitude

Clayton José de Sousa
clayton.sousa

(usa Debian)

Enviado em 19/04/2011 - 09:13h

Ja tentei de tudo um pouco mais nada acho que vou ter que apelar para a formatação.


10. tente aí seu moço

Perfil removido
removido

(usa Nenhuma)

Enviado em 19/04/2011 - 22:05h


não tenho certeza se é o 5 ou o 6, até porque meu Debian já deixou de ser puramente Stable rsrsrs, o GCC por exemplo é o do Testing = 4.4.5

# apt-get install --reinstall libstdc++5 libstdc++6

e se quiser também:

# apt-get install libstdc++6-4.5-dev

* vê o 4.5 ali em cima, o equivalente para o GCC instalado, caso o seu seja o 4.4 use isso:

# apt-get install libstdc++6-4.4-dev

se o 4.3:

# apt-get install libstdc++6-4.3-dev

para descobrir qual a versão do GCC instalado:

$ gcc --version (meu exemplo):

$ gcc --version
gcc (Debian 4.5.2-8) 4.5.2
Copyright (C) 2010 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


espero tê-lo ajudado.



ou cê pode tentar forçar a nstalação desse pacote bixado:

# dpkg -i --force- /var/cache/apt/archives/libstdc++-VERSÃO.deb