RAID 1 mdadm problemas com boot [RESOLVIDO]

1. RAID 1 mdadm problemas com boot [RESOLVIDO]

Helder da Silva Falcão
helderfalcao

(usa Ubuntu)

Enviado em 20/12/2011 - 16:12h

Olá pessoal, boa tarde, estou montando um servidor UBUNTU 11.10 e estou tentando implantar RAID1 em 2 H.Ds de 1.5TB mas não consigo dar boot por um dos H.Ds (só pelo principal) o que eu preciso fazer para que o boot ocorra tanto sem um H.D como sem o outro?

Obs. Já coloquei em pratica algumas práticas aqui do VOL mas nd....
E tbm segui este tutorial do UBUNTU:
https://help.ubuntu.com/community/Installation/SoftwareRAID?action=fullsearch&context=180&va...

Mas tbm sem resultado, obrigado pela ajuda!




  


2. MELHOR RESPOSTA

Roger
rootgerr

(usa Slackware)

Enviado em 31/01/2012 - 17:46h

Seria bom, que voce postasse a solução obtida, assim, outros usuários com o mesmo problema, terão um caminho a seguir :)

3. Re: RAID 1 mdadm problemas com boot [RESOLVIDO]

Roger
rootgerr

(usa Slackware)

Enviado em 20/12/2011 - 18:14h

não sei se aplica ao grub 2 também mas tente:

# grub --no-floppy

Você deverá ver o prompt do grub: o comando find irá listar seus HDs:

grub>
grub> find /boot/grub/stage1
(hd0,0)
(hd1,0)
grub>

Agora se seus dispositivos de boot forem /dev/sda e /dev/sdb, faça o seguinte para instalar o grub na MBR /dev/sda (troque conforme as SUAS partições):

grub> device (hd0) /dev/sda
grub> root (hd0,0)
grub> setup (hd0)

Agora para a MBR do /dev/sdb:

grub> device (hd0) /dev/sdb
grub> root (hd0,0)
grub> setup (hd0)

Estes comandos irão dizer ao grub para assumir o drive (hd0), então caso um de seus discos falhe, o outro poderá realizar o boot (se estiverem setados como RAID1).




4. Não deu certo...

Helder da Silva Falcão
helderfalcao

(usa Ubuntu)

Enviado em 21/12/2011 - 13:56h

Obrigado pela dica rootgerr, mas no começo já não da certo...
De primeira não vem com o grub e eu tenho que instalar.
E depois o primeiro comando que vc me passou não funcionou, os outros vi tutorias similares mas tbm não funcionaram...
Será que se eu descobrir como fazer estes mesmos comandos no grub2 dá certo?
De qualquer forma obrigado e se alguém puder ajudar, agradeço muito!
To prescisando..
rsrs
Boa tarde e até mais.



5. Re: RAID 1 mdadm problemas com boot [RESOLVIDO]

Roger
rootgerr

(usa Slackware)

Enviado em 21/12/2011 - 17:33h

Como está o particionamento dos discos? Tem como postar?



6. Particionamento

Helder da Silva Falcão
helderfalcao

(usa Ubuntu)

Enviado em 21/12/2011 - 17:45h

Tem sim!

#Cópia do MDSTAT

Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
md0 : active raid1 sdb1[2] sda1[0]
310480760 blocks super 1.2 [2/2] [UU]

md1 : active raid1 sdb5[1] sda5[0]
2085876 blocks super 1.2 [2/2] [UU]

#Cópia do "df"

Sist. Arq. 1K-blocos Usado Disp. Uso% Montado em
/dev/md0 305608816 4099652 285985128 2% /
udev 1014272 8 1014264 1% /dev
tmpfs 409296 1148 408148 1% /run
none 5120 0 5120 0% /run/lock
none 1023236 1180 1022056 1% /run/shm
/dev/loop0 99150 5671 88359 7% /var/spool/havp






7. Re: RAID 1 mdadm problemas com boot [RESOLVIDO]

Roger
rootgerr

(usa Slackware)

Enviado em 21/12/2011 - 17:55h

Olha nunca testei mas quem sabe se fizer assim:

desplug o hd2 e pelo terminal mande um update-grub após vá de grub-install /dev/sda

caregue normalmente repita o processo desta vez desplugando o sda e faça no sdb o mesmo processo

como disse nunca testei já que voce aparentemente não tem uma partição de boot separada acho que é a única coisa a tentar



8. Fisicamente ou logicamente

Helder da Silva Falcão
helderfalcao

(usa Ubuntu)

Enviado em 22/12/2011 - 09:01h

Cara, duas coisas:
1 - Faço isso via comando do mdadm ou fisicamente?


9. Re: RAID 1 mdadm problemas com boot [RESOLVIDO]

Roger
rootgerr

(usa Slackware)

Enviado em 22/12/2011 - 19:17h

Fisicamente o mdadm não localiza sda sdb etc.. ele só "entende" md0, md1 e assim por diante


10. Consegui, quase...!

Helder da Silva Falcão
helderfalcao

(usa Ubuntu)

Enviado em 23/12/2011 - 10:39h




11. Consegui, quase...!

Helder da Silva Falcão
helderfalcao

(usa Ubuntu)

Enviado em 23/12/2011 - 10:44h

GAlera, seguindo parte do tutorial deste link:
http://www.howtoforge.com/how-to-set-up-software-raid1-on-a-running-system-incl-grub2-configuration-...
Consegui dar boot pelos dois HDs!
Porém me deparei com mais um problema, quando volto com o sistema com os dois HDs, o RAID não voltou a se sincronizar, olhando o tutorial do UBUNTU sobre RAID, eles falam que após o teste, alterar o arquivo:
/etc/initramfs-tools/conf.d/mdadm

E setar false no BOOT_DEGRADED=true.

Mas mesmo assim, quando reiniciei, meu RAID ficou assim:
Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
md9 : active raid1 sdb7[1]
117185464 blocks super 1.2 [2/1] [_U]

md6 : active raid1 sdb1[1]
488278904 blocks super 1.2 [2/1] [_U]

md10 : active raid1 sdb9[1]
244428664 blocks super 1.2 [2/1] [_U]

md5 : active raid1 sda8[0] sdb8[1]
9763768 blocks super 1.2 [2/2] [UU]

md8 : active raid1 sdb6[1]
117185464 blocks super 1.2 [2/1] [_U]

md7 : active raid1 sdb5[1]
488278904 blocks super 1.2 [2/1] [_U]

unused devices: <none>

Obrigado A ajuda de todos do VAO, grande abraço e feliz NATAL.!


12. Remontar Raid

Minduim Power
minduim

(usa Ubuntu)

Enviado em 29/01/2012 - 21:04h

Para remontar o RAID execute o seguinte comando para remontar o "md9", fazar este procedimento para os demais "mds":

#mdadm -a /dev/md9 /dev/sda7

Espero ter ajudado.
Veja se você pode me ajudar:
http://www.vivaolinux.com.br/topico/GRUB/Ubuntu-1110-Raid1-via-software-nao-funciona



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts