recycle, em hd montada não recupera arquivo [RESOLVIDO]

1. recycle, em hd montada não recupera arquivo [RESOLVIDO]

caio
caionarezzi

(usa CentOS)

Enviado em 11/07/2018 - 16:53h

Olá, tenho um servidor formatado com CentOS 7 e no meu SAMBA tenho duas pasta uma chamado HD e outra SSD, a pasta HD eu montei uma hd externa de 1TB e na pasta SSD esta direto com a pasta / no samba criei uma pasta lixeira, para conseguir recuperar os arquivos excluidos sem querer, mas na pasta HD não consegui realizar o mesmo processo, se alguem ja passou por isso, ja realizei diversos testes, mas não consegui
desde ja grato

segue abaixo meu smb.conf

[global]
netbios name = KING
workgroup = GRUPO
security = user
map to guest = Bad user
wins support =yes
ntlm auth = yes
lanman auth = yes
client ntlmv2 auth = yes
dns proxy = no
log file = /var/log/samba/%m.log
max log size = 100000
recycle:keeptree = yes
recycle:versions= yes
recycle:repository = /lixeira/
recycle:exclude = *.tmp
[hd]
path = /hd
browsable = yes
writable = yes
guest ok = yes
read only = no
create mask = 0777
directory mask = 0777
vfs objects = recycle
[ssd]
path = /ssd
browsable = yes
writable = yes
guest ok = yes
read only = no
create mask = 0777
directory mask = 0777
vfs objects = recycle
[lixeira]
path=/lixeira/
writable = yes
read only = no
browsable = yes
guest ok = yes



  


2. Re: recycle, em hd montada não recupera arquivo [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 11/07/2018 - 19:38h

Velho ... pelo que andei constatando, a lixeira só funciona na mesma partição do compartilhamento ... aqui eu tenho 2 compartilhamentos em patições distintas e coloquei a lixeira em uma 3ª, não consegui acessar nem excluir por nenhum compartilhamento,aí passei a lixeira pra mesma partição do compartilhamento 1, aí obtive sucesso apenas no compartilhamento 1 ... então o lance é não fazer a lixeira global quando se tem compartilhamentos em partições distintas mas sim fazer uma lixeira por compartilhamento ... não sei se isso é o funcionamento correto ou é encrenca do samba 4, algum user mais experiente pode fazer esse esclarecimento.


------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------



3. Re: recycle, em hd montada não recupera arquivo [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 11/07/2018 - 20:42h

Dei uma fuçada aqui e consegui colocar a lixeira em partição distinta .. só que dizem que essa mudança faz perder a auditoria do samba

coloquei na sessão global assim
vfs objects = recycle crossrename
crossrename:sizelimit = 2000

recycle:versions = yes
recycle:repository = /var/samba/trash/%u
recycle:exclude = *.tmp, *.log, *.obj, *.bak
recycle:exclude_dir = tmp, cache


dei permissão 777 na lixeira
chmod +R 777  /var/samba/trash  


Sessão lixeira do smb normal
[lixeira]
path = /var/samba/trash/%u
writable = yes

------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------



4. Re: recycle, em hd montada não recupera arquivo[RESOLVIDO]

caio
caionarezzi

(usa CentOS)

Enviado em 12/07/2018 - 09:26h

Nossa cara, obrigado estava ja pensando que tivesse montado errado a hd mas não fazia sentido nem um kkk funcionou perfeitamente vou estudar as demais configurações do recycle parece util, e quando a auditoria consegui visualizar pelo /var/log normal

desde ja grato


01110000 01100001 01110010 01100001 00100000 01100110 01110010 01100101 01101110 01110100 01100101 00100000 01110011 01100101 01101101 01110000 01110010 01100101 00100000  



5. Re: recycle, em hd montada não recupera arquivo [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 12/07/2018 - 09:36h

essa parada do crossrename era uma gambiarra de um Bug ( acho ) , não sei se virou parâmetro.

OBS: Não deixe de assinalar aquela "melhor resposta".

Abçs.

------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts