Servidor não aparece no ambiente de rede Windows

1. Servidor não aparece no ambiente de rede Windows

Anderson Diego Ribeiro
Anderson_Diego

(usa Ubuntu)

Enviado em 29/01/2013 - 09:01h

Olá amigos.

Possuo em minha rede um servidor Samba (Ubuntu 12.10) e 3 estações c/ Windows 7.

Este servidor é apenas um servidor de arquivos, e pelo fato da rede ser pequena, não tenho a necessidade de um servidor de domínio.

O Samba esta funcionando corretamente. Consigo acessá-lo a partir das estações windows, usando seu endereço IP ou nome host.
Porem, ao acessar o ambiente de rede, nas estações que possuem o Windows 7, só consigo ver as 3 estações (windows) e o servidor Samba não aparece listado.

Todas as Maquinas da rede (3 estações + Servidor Samba) estão no mesmo grupo de trabalho (Brasil).

Alguém tem alguma idéia do que pode estar errado ?

Já li outros tópicos aqui do forum, que tratam deste mesmo problema. Fiz diversas alterações no arquivo de configuração do samba, e não consegui nada.

segue abaixo o arquivo smb.conf

[global]
netbios name = Servidor01
workgroup = Brasil
server string = Servidor01
security = share
local master = yes
os level = 100
preferred master = yes
wins support = yes
log file = var/log/samba/log.%m
max log size = 1000


[Documentos]
comment = Pasta de Documentos Diversos
path = /samba/docs
writable = yes
guest ok = yes
public = yes
browseable = yes
read only = no
create mask = 777
directory mask = 777

[arquivos]
comment = Pasta de Arquivos diversos
path = /samba/arquivos
writable = yes
guest ok = yes
public = yes
browseable = yes
read only = no
create mask = 777
directory mask = 777



agradeço qualquer ajuda.
Abç.


  


2. Re: Servidor não aparece no ambiente de rede Windows

Reginaldo de Matias
saitam

(usa Slackware)

Enviado em 29/01/2013 - 10:36h

Anderson_Diego escreveu:

Olá amigos.

Possuo em minha rede um servidor Samba (Ubuntu 12.10) e 3 estações c/ Windows 7.

Este servidor é apenas um servidor de arquivos, e pelo fato da rede ser pequena, não tenho a necessidade de um servidor de domínio.

O Samba esta funcionando corretamente. Consigo acessá-lo a partir das estações windows, usando seu endereço IP ou nome host.
Porem, ao acessar o ambiente de rede, nas estações que possuem o Windows 7, só consigo ver as 3 estações (windows) e o servidor Samba não aparece listado.

Todas as Maquinas da rede (3 estações + Servidor Samba) estão no mesmo grupo de trabalho (Brasil).

Alguém tem alguma idéia do que pode estar errado ?

Já li outros tópicos aqui do forum, que tratam deste mesmo problema. Fiz diversas alterações no arquivo de configuração do samba, e não consegui nada.

segue abaixo o arquivo smb.conf

[global]
netbios name = Servidor01
workgroup = Brasil
server string = Servidor01
security = share
local master = yes
os level = 100
preferred master = yes
wins support = yes
log file = var/log/samba/log.%m
max log size = 1000


[Documentos]
comment = Pasta de Documentos Diversos
path = /samba/docs
writable = yes
guest ok = yes
public = yes
browseable = yes
read only = no
create mask = 777
directory mask = 777

[arquivos]
comment = Pasta de Arquivos diversos
path = /samba/arquivos
writable = yes
guest ok = yes
public = yes
browseable = yes
read only = no
create mask = 777
directory mask = 777



agradeço qualquer ajuda.
Abç.



iniciar>executar>\\Servidor01

acessa ? qual mensagem de erro ?

Qual versão do Windows 7 ?


3. Re: Servidor não aparece no ambiente de rede Windows

Anderson Diego Ribeiro
Anderson_Diego

(usa Ubuntu)

Enviado em 29/01/2013 - 10:47h

Windows 7 Ultimate 6.1.7600

Ao acessar o caminho \\Servidor01\ ou \\192.168.1.10 (Ip do Servidor)
tenho acesso normalmente as 2 pastas compartilhadas pelo Samba.
Consigo acessar, gravar, criar, excluir.... tudo normal....

O problema é que o Servidor Samba não aparece no ambiente de Rede do Windows, quando consulto o grupo de trabalho Brasil, vejo somente:
Estacao01
Estacao02
Estacao03

e neste caso falta apenas aparecer Servidor01, já que ele esta ativo na rede, e consigo acessá-lo normalmente pelo nome ou IP.

Obs: O acesso via SSH tbm funciona normalmente.


4. Re: Servidor não aparece no ambiente de rede Windows

Pedro Martelotta
pmartelotta

(usa CentOS)

Enviado em 30/01/2013 - 11:07h

As workstations e servidores estão no mesmo grupo de trabalho?


5. Re: Servidor não aparece no ambiente de rede Windows

Anderson Diego Ribeiro
Anderson_Diego

(usa Ubuntu)

Enviado em 30/01/2013 - 12:04h

Sim amigo, as 3 estações (Windows 7) e o servidor linux (Ubutu 12.10) estão no mesmo grupo de trabalho (Brasil).


6. NMB

Jorge Nunes
jcvn

(usa Debian)

Enviado em 11/05/2013 - 23:25h

Amigo,

Verifica se o serviço NMB foi estartado.

At.

Jorge Nues


7. Re: Servidor não aparece no ambiente de rede Windows

marcelo
mgaletti

(usa Outra)

Enviado em 11/09/2013 - 13:38h

Estou com o mesmo problema..

- Instalei o Samba em um CentOS (máquina virtual - virtual box) c/ placa de rede em modo bridge. O Virtual box roda no meu Windows 7.

- Da estação fisica com Windows 7, consigo dar um ping na maquina virtual (C/ o samba), tranquilo.

- Pelo Windows Explorer da estação fisica, na opção REDE, consigo visualizar o nome NetBios que criei no smb.conf, porem ao clicar aparece a mensagem:

Erro de rede
O Windows não pode acessar \\SAMBA.
Verifique a ortografia do nome. Caso contrário, pode ocorrer um problema na rede. Para tentar identificar e resolver problemas de rede, clique em Diagnosticar.

- Se eu coloco via ip \\192.168.1.9\software .. ou \\192.168.1.9
Também não funciona.

- O serviço smb e nmb está rodando tudo certo. Abaixo o smb.conf
- A estação que acessa o servidor está no Grupo de trabalho: GRUPO

[global]
# Substituir xxxxxx pelo nome do domío desejado caso necessáo
workgroup = grupo
# Substituir xxxxxx pelo nome do servidor caso necessáo
netbios name = samba
server string = Servidor Samba
domain master = yes
preferred master = yes
local master = yes
domain logons = no
logon path = %systemroot%\%u

#logon script = todos.bat
security = share
encrypt passwords = yes
os level = 200

time server = yes
unix charset = iso8859-1
display charset = cp850

##Arquivo de log
log file = /var/log/samba/%m.log
max log size = 5000
debug level = 2

##Encrypta as senhas digitadas na rede, porem nao funciona em estacoes
## Windows 95 e Windows 3.11
smb passwd file = /etc/samba/smbpasswd
username map = /etc/samba/smbusers

##Garantir melhor desempenho do servidor
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

##Permite a utilizaç de impressoras compartilhas em estaçs Linux
load printers=yes
printing=lprng
printcap name = /etc/printcap


[software]
path = /home/software
guest ok = yes
browseable = no
public = yes
writable = yes
read only = no

[programacao]
path = /home/programacao
guest ok = no
browseable = yes
public = no
writable = yes
read only = no



8. NMB

GABRIEL DE CARVALHO MELLO
hedtec

(usa CentOS)

Enviado em 26/07/2017 - 09:48h

Deve iniciar o nmb como disse nosso amigo acima! Funcionará....


9. Re: Servidor não aparece no ambiente de rede Windows

Andre de Araujo
dedeboy2005

(usa Ubuntu)

Enviado em 26/07/2017 - 16:01h

Tenta instalar o serviço WINBIND no Servidor e vê se ele funciona.
#apt-get install winbind

Abraços.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts