Qual o problema com essa .conf

1. Qual o problema com essa .conf

Erik da Silva Castilho
escastilho

(usa Ubuntu)

Enviado em 24/02/2008 - 15:37h

Olá pessoal estou configurando o samba aqui e não esta dando certo, montei esse msm arquivo e coloquei em um desktop e rodou certinho mas quando o coloco no notebook não vai nem a pau, deêm uma olhadinha pra ver se tem algum erro.

[global]

workgroup = MATRIX
server string = Samba Server Version %v
hosts allow = 127. 192.168.1.
log file = /var/log/samba/log.%m
max log size = 50
log level = 2
name resolve order = host lmhosts bcast
security = user
passdb backend = tdbsam
# ****compartilhamento público****
username map = /etc/samba/smbusers
#passdb backend = tdbsam --->>> compartilhamento com autenticação
#security = guest --->>> compartilhamento sem autenticação
printing = cups
printcap name = cups
load printers = yes
wins support = yes
preferred master = yes
os level = 255

[Público]
comment = diretório público
path = /root/publico
browseable = yes

# ****Configuração do compartilhamento [homes]:****

[homes]
comment = Diretório Home
path = /root/Documentos
writable = yes
browseable = yes
valid users = %S
create mask = 0740
directory mask = 0750
security mask = 0740
directory security mask = 0750

# ****Configuração do Printers [cups]

[printers]
comment = Todas as impressoras
path = /var/spool/samba
printable = yes
writable = no

Depois eu restarto o serviço e vou no windows e tento encontrar o compartilhamento e nd.

Atenciosamente
Erik


  


2. mais detalhes...

Marcelo Corrêa
exercitobr

(usa Debian)

Enviado em 24/02/2008 - 19:53h

bom... o caminho do compartilhamento existe nas duas máquinas? exemplo: /root/compatilhar tá igualzinho nas duas máquinas?


3. Re: Qual o problema com essa .conf

André Franco Rezende Dantas
andrefrd

(usa Ubuntu)

Enviado em 24/02/2008 - 20:30h

tente o comando ps -aux | grep smb ele mostra se esta tudo ok e onde esta a falha


abraços


4. Re: Qual o problema com essa .conf

Thiago Fernandes de Melo
m4tri_x

(usa Ubuntu)

Enviado em 25/02/2008 - 09:19h

hosts allow = 127. 192.168.1.

inicialmente tenta mudar para:

hosts allow = 127.0.0.1/32 192.168.1.0/24


depois verifica se a faixa de ip do notebook é a mesma do outro desktop...


para o samba e roda denovo...

e veja se funciona...



[]´s



5. Re: Qual o problema com essa .conf

Marcos Miras
marcosmiras

(usa CentOS)

Enviado em 25/02/2008 - 09:51h

Boa...
Olhe se os compartilhamentos existem e se altere a rede como o matrix mencionou acima!
Olhe o log para ver se existe alguma entrada em erros.
Abraço!


6. Re: Qual o problema com essa .conf

Erik da Silva Castilho
escastilho

(usa Ubuntu)

Enviado em 25/02/2008 - 09:58h

exercitobr

Desculpe mas eu naum entendi o que quis dizer, na máquina win eu somente tento acessar o note. Tipo ele esta enxergando o Samba mas não acessa.


7. Usuario cadsatrado no samba?

Genesco Sousa
gesousa

(usa Ubuntu)

Enviado em 25/02/2008 - 10:32h

seu usuário esta cadastrado no samba?

# smbpasswd -a usuario
New SMB password:
Retype new SMB password:

Se nao tiver ele ainda:

# adduser user
# smbpasswd -a user

Seu usuario tem acesso completo ao conteúdo das pastas compartilhadas?

# chown -R user.user /root/arquivos

veja se não é isso: tem um tutorial bem simples aqui:
http://www.guiadohardware.net/artigos/servidor-rede-local/


8. Re: Qual o problema com essa .conf

Erik da Silva Castilho
escastilho

(usa Ubuntu)

Enviado em 26/02/2008 - 07:56h

A faixa de IP esta correta note (192.168.1.10) desktop (192.168.1.11), o samba creio eu esta configurado de forma correta e os usuários estão OK, mas quando vou no windows e digito //servidor100 ele não encontra nada. Muito estranho.


9. Entendi agora

Genesco Sousa
gesousa

(usa Ubuntu)

Enviado em 26/02/2008 - 09:28h


Não estava entendendo o que vc queria na parte global e so adicionar esta linha ->

netbios name = Nome_Servidor



10. Usuario maquina

Thiago Fernandes Gonzaga
thiagotj

(usa Suse)

Enviado em 28/02/2008 - 13:31h

Caro escastilho,
Você tem que adicionar o usuário maquina. Ex: nome_do_not$.
Pra isso tem que criar um grupo só para as maquinas. Ex:
"groupadd machine"
Depois adicionar as maquinas:
"useradd -g machine -s /bin/false not$"



11. Re: Qual o problema com essa .conf

Marcelo Corrêa
exercitobr

(usa Debian)

Enviado em 29/02/2008 - 12:16h

Resolveu?



12. Re: Qual o problema com essa .conf

Erik da Silva Castilho
escastilho

(usa Ubuntu)

Enviado em 01/03/2008 - 09:30h

Ainda não pessoal, deu um pau aqui no Fedora e estou tentando resolver primeiro, acho que vou ter reinstála-lo, vlw pela preocupação e interesse de todos em me ajudar, assim que eu configurar aqui de novo eu volto aqui e digo se deu certo.

Esse usuário máquina eu não tinha criado, mas como deu problema no SO não tive jeito de testar ainda.

Vlw!!!



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts