Instalação do SAMAB

1. Instalação do SAMAB

Rodolfo Luiz da Silva - Linux user #396657
rodolfols

(usa Ubuntu)

Enviado em 05/03/2010 - 14:44h

Olá,

Estou tentando resinstalar o samaba, mas recebo essa mensagem:

srvdjr:/var/cache/apt/archives# apt-get install -f samba-common
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
samba-common já é a versão mais nova.
samba-common configurado para instalar manualmente.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 1 não atualizados.
2 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0B adicionais de espaço em disco serão usados.
Configurando samba-common (2:3.2.5-4lenny9) ...
dpkg: erro processando samba-common (--configure):
sub-processo post-installation script retornou estado de saída de erro 10
dpkg: problemas de dependência impedem a configuração de samba:
samba depende de samba-common (= 2:3.2.5-4lenny9); porém:
Pacote samba-common não está configurado ainda.
dpkg: erro processando samba (--configure):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
samba-common
samba
E: Sub-process /usr/bin/dpkg returned an error code (1)

Como posso resolver esse erro?



  


2. SAMBA

Neto
netocba

(usa Debian)

Enviado em 05/03/2010 - 16:33h

Olá amigo

Primeira coisa vc tem que se certificar que a sua source.list está atualizada , pois se vc estiver tentando instalar com a source.list original de instalação do debian lenny 5.0 vc nunca vai conseguir , pois ela está incompleta de repositorios , vc tera que pesquisar aqui mesmo no VOL uma source.list quente do debian lenny certo.. apos vc fazer isso , tenho certeza que tú ira conseguir instalar os pacotes do samba...

boa sorte

t mais.


3. Tente

Rosberg M Bozzetto
bergcc

(usa Fedora)

Enviado em 05/03/2010 - 17:02h

Tente o comando abaixo para corrigir o problema.

#dpkg --configure -a

caso nõa de certo, sugiro que remova todos os pacotes do samba e instale-os novamente com os seguintes comandos:

#apt-get remove --purge samba smbclient samba-common
#apt-get install samba smbclient samba-common

:)


4. Re: Instalação do SAMAB

Jefferson Diego
Diede

(usa Debian)

Enviado em 05/03/2010 - 18:05h

Tente o "-f" sem argumentos:
apt-get install -f


5. Re: Instalação do SAMAB

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 05/03/2010 - 19:29h

como já foi dito acima, seu sources está correto?

qual a finalidade do samba, servidor ou cliente?

instalar para servidor [aptitude install samba]

instalar para cliente [aptitude install samba-client]

o próprio projeto está recomendo usar aptitude no lugar de apt-get, por fazer uma melhor administração.



6. retitando comentario

Laurentino Bispo
laurentino bispo

(usa Ubuntu)

Enviado em 07/03/2010 - 13:11h

i israel_miranda esta corretissimo. minhas mais sinceras desculpas.

laurentino bispo


7. Re: Instalação do SAMAB

Israel Miranda
israel_miranda

(usa FreeBSD)

Enviado em 09/03/2010 - 13:11h

Ia falar como prosseguir, mas os camaradas acima já deram todas as instruçoes necessárias!
O basico e tentar remover os pacotes com problemas e reinstalar
apt-get -f install
dpkg-reconfigure -ua

senao resolver
dpkg --force-all -r nomesdospacotescomproblema

e depois instalar denovo!
nessas horas q eu amo o debian!
dpkg+apt-get rox!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts