Erro na compilação do Samba4 no CentOS 8 [RESOLVIDO]

1. Erro na compilação do Samba4 no CentOS 8 [RESOLVIDO]

Thiago Silva Luz
tsilvaluz01

(usa CentOS)

Enviado em 06/05/2020 - 19:52h

Boa noite pessoal,

Estou tentando promover um servidor CentOS 8 para controlador de domínio, porém, após alguns passos, ocorre o erro que consta no print anexo, um erro após rodar o comando MAKE. Baixei tudo queera necessário para a instalação e mesmo assim o Make dá esse erro, já tentei com mais de uma versão do Samba 4, acontece o mesmo. Alguém sabe resolver?


  


2. MELHOR RESPOSTA

Mauricio Ferrari
mauricio123

(usa Slackware)

Enviado em 06/05/2020 - 20:06h

verifique se esses pacotes estão instalado.

libtirpc libtirpc-devel

Não tem errada.

___________________________________
Conhecimento não se Leva para o Túmulo.

3. Re: Erro na compilação do Samba4 no CentOS 8 [RESOLVIDO]

Mauricio Ferrari
mauricio123

(usa Slackware)

Enviado em 07/05/2020 - 12:49h

Funcionou?


___________________________________
Conhecimento não se Leva para o Túmulo.


4. Re: Erro na compilação do Samba4 no CentOS 8 [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 07/05/2020 - 15:06h


quais pacotes que tu instalou antes de compilar o samba ?


5. Re: Erro na compilação do Samba4 no CentOS 8 [RESOLVIDO]

Thiago Silva Luz
tsilvaluz01

(usa CentOS)

Enviado em 07/05/2020 - 15:52h

mauricio123 escreveu:

verifique se esses pacotes estão instalado.

libtirpc libtirpc-devel

Não tem errada.

___________________________________
Conhecimento não se Leva para o Túmulo.


Verifiquei, o libtirpc-devel não estava instalado, provavelmente foi o que gerou o erro, aparentemente agora deu certo, obrigado!


6. Re: Erro na compilação do Samba4 no CentOS 8 [RESOLVIDO]

Thiago Silva Luz
tsilvaluz01

(usa CentOS)

Enviado em 07/05/2020 - 15:53h

danniel-lara escreveu:


quais pacotes que tu instalou antes de compilar o samba ?


Peguei duas listas em canais diferentes, a primeira continha essas :
docbook-style-xsl gcc gdb gnutls-devel gpgme-devel jansson-devel \
keyutils-libs-devel krb5-workstation libacl-devel libaio-devel \
libarchive-devel libattr-devel libblkid-devel libtasn1 libtasn1-tools \
libxml2-devel libxslt lmdb-devel openldap-devel pam-devel perl \
perl-ExtUtils-MakeMaker perl-Parse-Yapp popt-devel python3-cryptography \
python3-dns python3-gpg python36-devel readline-devel rpcgen systemd-devel \
tar zlib-devel cups-devel
e a segunda essas:
openldap-devel pam-devel git gcc make wget libacl-devel libblkid-devel gnutls-devel \
readline-devel python-devel cups-devel libaio-devel quota-devel ctdb-devel krb5-devel \
krb5-workstation acl setroubleshoot-server setroubleshoot-plugins policycoreutils-python \
libsemanage-python setools-libs-python setools-libs popt-devel libpcap-devel libidn-devel \
libxml2-devel libacl-devel libsepol-devel libattr-devel keyutils-libs-devel cyrus-sasl-devel \
cups-devel bind-utils bind-sdb bind-devel bind-libs bind avahi-devel mingw32-iconv gamin libcap-devel\
rpc2-devel glusterfs-devel python-dns pkgconfig gdb e2fsprogs-devel zlib-devel sqlite-devel perl \
attr acl krb5-user ntp bind bind-sdb



7. Re: Erro na compilação do Samba4 no CentOS 8 [RESOLVIDO]

Mauricio Ferrari
mauricio123

(usa Slackware)

Enviado em 07/05/2020 - 20:39h


Marque a então como melhor resposta para completar.

___________________________________
Conhecimento não se Leva para o Túmulo.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts