Erro ao atualizar samba 4.13.7 para 4.14.3 [RESOLVIDO]

1. Erro ao atualizar samba 4.13.7 para 4.14.3 [RESOLVIDO]

willian firmino
willian.firmino

(usa Slackware)

Enviado em 23/04/2021 - 08:24h

Tenho o samba 4.13.7 compilado no RHEL 8, estou tentando atualizar o samba que tenho como controlador de dominio da versão 4.13.7 para a 4.14.3, tentei atualizar uma a uma (da 4.13.7 para a 4.14.0, 4.14.1, ...) após atualização quando tento iniciar o samba da o seguinte erro:
/usr/local/samba/sbin/samba: /usr/local/samba/lib/private/libreplace-samba4.so: version `SAMBA_4.13.7' not found (required by /usr/local/samba/lib/private/libtdb.so.1)


Alguém ja passou por esse problema? Olhei nas releases notes do samba e não encontrei nada.


  


2. Re: Erro ao atualizar samba 4.13.7 para 4.14.3 [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 23/04/2021 - 08:52h


verifica se tem o pacote instalado libtdb




3. Re: Erro ao atualizar samba 4.13.7 para 4.14.3 [RESOLVIDO]

willian firmino
willian.firmino

(usa Slackware)

Enviado em 23/04/2021 - 09:13h


danniel-lara escreveu:


verifica se tem o pacote instalado libtdb



Já estão instalados.

O pacote libtdb-1.4.3-1.el8.x86_64 já está instalado.
O pacote libtdb-devel-1.4.3-1.el8.x86_64 já está instalado.



4. Re: Erro ao atualizar samba 4.13.7 para 4.14.3 [RESOLVIDO]

willian firmino
willian.firmino

(usa Slackware)

Enviado em 26/04/2021 - 12:56h

Eu fiz o que a pessoa deste link fez e funcionou. Não deve ser a forma correta mas como ainda estamos homologando o serviço serviu.

https://serverfault.com/questions/1058398/compiled-samba-from-source-upgrade-version-mismatch?noredi...







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts