erros ao usar o emerge -av programa

1. erros ao usar o emerge -av programa

Perfil removido
removido

(usa Nenhuma)

Enviado em 20/07/2019 - 21:58h

instalei o sabayon para usar pela primeira vez mais quando eu fui usar o emerge aparece sempre o mesmo erro ou parecido dependendo do programa se alguem puder me dar uma simples solução porque sou novo nos gentoo-like
esse o erro :
emerge --sync
emerge -av x11-wm/i3-gaps

These are the packages that would be merged, in order:

Calculating dependencies
* IMPORTANT: 20 news items need reading for repository 'gentoo'.
* Use eselect news read to view new items.

.... ... done!
[ebuild N ] dev-util/gperf-3.1::gentoo 0 KiB
[ebuild N ] media-libs/libid3tag-0.15.1b-r4::gentoo USE="-debug -static-libs" ABI_X86="32 (64) (-x32)" 331 KiB
[ebuild N ] dev-perl/JSON-XS-3.40.0::gentoo USE="-examples -test" 0 KiB
[ebuild N ] dev-perl/AnyEvent-I3-0.170.0::gentoo 25 KiB
[ebuild N ] app-crypt/rhash-1.3.8::gentoo USE="nls ssl -debug -libressl -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild NS ] app-text/docbook-xml-dtd-4.2-r2:4.2::gentoo [4.5-r1:4.5::gentoo] 77 KiB
[ebuild N ] x11-libs/xcb-util-xrm-1.3::gentoo USE="-doc -static-libs -test" ABI_X86="32 (64) (-x32)" 320 KiB
[ebuild N ] dev-libs/libuv-1.30.1:0/1::gentoo USE="-static-libs" ABI_X86="32 (64) (-x32)" 1.200 KiB
[ebuild N ] dev-util/cmake-3.15.0::gentoo USE="ncurses -doc -emacs -qt5 -system-jsoncpp -test" 9.050 KiB
[ebuild N ] dev-libs/yajl-2.1.0-r2:0/2::gentoo USE="-static-libs" ABI_X86="32 (64) (-x32)" 83 KiB
[ebuild N ] media-libs/imlib2-1.5.1-r1::gentoo USE="X bzip2 gif jpeg mp3 nls png shm tiff zlib -doc -static-libs" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="sse2 (-mmx)" 997 KiB
[ebuild N ] www-client/w3m-0.5.3_p20190105::gentoo USE="X fbcon gpm imlib nls ssl unicode -gdk-pixbuf -libressl -lynxkeymap -nntp -xface" L10N="de ja" 2.133 KiB
[ebuild N ] virtual/w3m-0::gentoo 0 KiB
[ebuild N ] app-text/xmlto-0.0.28-r1::gentoo USE="text -latex" 125 KiB
[ebuild N ] x11-wm/i3-gaps-4.16.1-r1::gentoo USE="-doc" 3.891 KiB

Total: 15 packages (14 new, 1 in new slot), Size of downloads: 18.228 KiB

Would you like to merge these packages? [Yes/No]
>>> Verifying ebuild manifests

>>> Emerging (1 of 15) dev-util/gperf-3.1::gentoo
* Fetching files in the background.
* To view fetch progress, run in another terminal:
* tail -f /var/log/emerge-fetch.log
* gperf-3.1.tar.gz BLAKE2B SHA512 size ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking gperf-3.1.tar.gz to /var/tmp/portage/dev-util/gperf-3.1/work
>>> Source unpacked in /var/tmp/portage/dev-util/gperf-3.1/work
>>> Preparing source in /var/tmp/portage/dev-util/gperf-3.1/work/gperf-3.1 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-util/gperf-3.1/work/gperf-3.1 ...
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --docdir=/usr/share/doc/gperf-3.1 --htmldir=/usr/share/doc/gperf-3.1/html --libdir=/usr/lib64 --htmldir=$(datarootdir)/doc/gperf-3.1/html
checking whether make sets $(MAKE)... yes
configure: creating ./config.status
config.status: creating Makefile
=== configuring in lib (/var/tmp/portage/dev-util/gperf-3.1/work/gperf-3.1/lib)
configure: running /bin/sh ./configure --disable-option-checking '--prefix=/usr' '--build=x86_64-pc-linux-gnu' '--host=x86_64-pc-linux-gnu' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--datadir=/usr/share' '--sysconfdir=/etc' '--localstatedir=/var/lib' '--docdir=/usr/share/doc/gperf-3.1' '--htmldir=/usr/share/doc/gperf-3.1/html' '--libdir=/usr/lib64' '--htmldir=$(datarootdir)/doc/gperf-3.1/html' 'build_alias=x86_64-pc-linux-gnu' 'host_alias=x86_64-pc-linux-gnu' --cache-file=/dev/null --srcdir=.
checking whether make sets $(MAKE)... yes
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
checking whether the C compiler works... no
configure: error: in `/var/tmp/portage/dev-util/gperf-3.1/work/gperf-3.1/lib':
configure: error: C compiler cannot create executables
See `config.log' for more details
configure: error: ./configure failed for lib

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-util/gperf-3.1/work/gperf-3.1/config.log
* ERROR: dev-util/gperf-3.1::gentoo failed (configure phase):
* econf failed
*
* Call stack:
* ebuild.sh, line 124: Called src_configure
* environment, line 1009: Called econf '--htmldir=$(datarootdir)/doc/gperf-3.1/html'
* phase-helpers.sh, line 718: Called __helpers_die 'econf failed'
* isolated-functions.sh, line 121: Called die
* The specific snippet of code:
* die "$@"
*
* If you need support, post the output of `emerge --info '=dev-util/gperf-3.1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=dev-util/gperf-3.1::gentoo'`.
* The complete build log is located at '/var/tmp/portage/dev-util/gperf-3.1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-util/gperf-3.1/temp/environment'.
* Working directory: '/var/tmp/portage/dev-util/gperf-3.1/work/gperf-3.1'
* S: '/var/tmp/portage/dev-util/gperf-3.1/work/gperf-3.1'

>>> Failed to emerge dev-util/gperf-3.1, Log file:

>>> '/var/tmp/portage/dev-util/gperf-3.1/temp/build.log'
* Messages for package dev-util/gperf-3.1:
* ERROR: dev-util/gperf-3.1::gentoo failed (configure phase):
* econf failed
*
* Call stack:
* ebuild.sh, line 124: Called src_configure
* environment, line 1009: Called econf '--htmldir=$(datarootdir)/doc/gperf-3.1/html'
* phase-helpers.sh, line 718: Called __helpers_die 'econf failed'
* isolated-functions.sh, line 121: Called die
* The specific snippet of code:
* die "$@"
*
* If you need support, post the output of `emerge --info '=dev-util/gperf-3.1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=dev-util/gperf-3.1::gentoo'`.
* The complete build log is located at '/var/tmp/portage/dev-util/gperf-3.1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-util/gperf-3.1/temp/environment'.
* Working directory: '/var/tmp/portage/dev-util/gperf-3.1/work/gperf-3.1'
* S: '/var/tmp/portage/dev-util/gperf-3.1/work/gperf-3.1'




  


2. Re: erros ao usar o emerge -av programa

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 22/07/2019 - 18:32h

agora aparece como removido, mas só agora ví sua pergunta, que tem já dois dias....

em Sabayon, ao menos os iniciantes, é mais fácil usar o entropy, comando equo, ou o RIGO., invés de portage, emerge...

Se realmente quiser usar emerge no sabayon, primeira coisa..... atualiza o sabayon primeiro com entropy;;;;

***depois edite o arquivo /etc/entropy/client.conf e na linha escrito "ignore spm downgrades" troque "disable" por "enable"....

só então execute "emerge --sync"....

se não fizer assim, seu sabayon vai misturar os pacotes precompilados do entropy, com a compilação do portage e vc começará a ter "downgrades" invés de "upgrades".

sobre o erro que obteve.... é porque o sabayon não tem o compilador GCC ativo por padrão, apenas o "base-gcc",,,, precisa instalar o pacote GCC completo com entropy antes e colocar ativos os overlays do sabayon...

depois de editar o arquivo que falei, em ***

execute estes comandos, nessa ordem...


# equo up
# equo u
# equo i -av make cmake autoconf automake gcc gcc-config
$ gcc-config -l
# gcc-config NUM, onde NUM é o número do mais novo GCC (no meu sabayon é 8.2.0)
# layman -a sabayon
# layman -a sabayon-distro


só então execute "emerge --sync".... de preferência, não troque o portage (não execute "emerge -av --oneshot portage),

para instalar pacotes com emerge, veja primeiro se a versão entropy é mais antiga, para isso execute estes comandos


# emerge -s PACOTE
deve dar versão mais nova de pacote do que:
# equo s PACOTE


se der versão mais nova, vc pode SIMULAR instalar com:


# emerge -pv PACOTE


parece dar tudo certo? tente agora instalar:


# emerge -av PACOTE


não parece ter dado certo? dependências, colisões ou máscaras? cada caso é um caso (para pode solucionar), mas no geral, pode tentar assim:


# emerge -av --nodeps PACOTE


As dicas acima funcionam como guia; Na realidade, usar portage (emerge) em sabayon, não é fácil. Precisa prática.

¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts