Não consigo atualizar sabayon 18.05 [RESOLVIDO]

1. Não consigo atualizar sabayon 18.05 [RESOLVIDO]

Mac
Skylen

(usa Slackware)

Enviado em 16/12/2018 - 13:04h

Boa tarde,

Troquei de distribuição do Debian para o Sabayon, não sei muito sobre o sistema.
Após ter feito a instalação em português, comecei a atualizar o sistema, depois de uns duas horas apresenta um erro "Ocorreu um error. Ação abordada", isso no terminal, já no rigo também da erro é pede para verificar o blog de atualização.

É isso que observei, estou pelejando nessa atualização a três dias, kkkk.

Já li em alguns artigos do fórum, na wiki, reinstalei a ISO e nada

Estou rodando o sistema sabayon 18.05 xfce no virtual box.

Agradeço pela ajuda.


  


2. Re: Não consigo atualizar sabayon 18.05 [RESOLVIDO]

-
BiaMonteiro

(usa Arch Linux)

Enviado em 16/12/2018 - 13:26h

Pode ser que os seus repositórios não estejam configurados, por isso o Sabayon não faz atualização.
Além do mais, essa distribuição usa, além do portage do Gentoo como gerenciador de pacotes, o entropy, que é binário. Qual gerenciador de pacotes você usou para atualizar o sistema?

Vou deixar uns links, podem ser úteis:
https://wiki.gentoo.org/wiki/Portage
https://wiki.sabayon.org/index.php?title=En:Entropy



3. Re: Não consigo atualizar sabayon 18.05 [RESOLVIDO]

Mac
Skylen

(usa Slackware)

Enviado em 16/12/2018 - 13:48h

Nas primeiras tentativas usei o entropy, aprentava o erro, na última usei o emerge (portage) na sequência:

emerge --sync
emerge portage
layman -S

Em relação aos repositórios executei os comandos:

equo repo mirrorsort sabayon-weekly
equo conf update

Esse comando a velocidade de downloads dos espelhos.

Foi isso que fiz, além de tentar pelo rigo.


4. Re: Não consigo atualizar sabayon 18.05 [RESOLVIDO]

Matheus
pylm

(usa Gentoo)

Enviado em 16/12/2018 - 13:51h

Não se usa o portage pra atualizar o sabayon.
Não dá pra advinhar o que tá acontecendo com toda essa informação que você passou, mande as saídas completas e os comandos.


5. Re: Não consigo atualizar sabayon 18.05 [RESOLVIDO]

Mac
Skylen

(usa Slackware)

Enviado em 16/12/2018 - 13:59h

Vai demorar um pouco, estou rodando o comando novamente,

equo upgrade

Depois de executar os três comandos citados acima do portage

É como vc disse o portage não atualiza.


6. Re: Não consigo atualizar sabayon 18.05

Mac
Skylen

(usa Slackware)

Enviado em 16/12/2018 - 15:01h

Por algum milagre consegui atualiza kkkk, porém o terminal ficou em inglês e alguns programas. A sequência de comandos que usei foi:

emerge --sync
emerge portage
layman -S
configurei o locale-gen, que foi pedido

equo update && equo upgrade
reboot

Após o reinicio do sistema, foi acusado que o sistema estava atualizado, executei o seguinte comando para verificar

sabayon /home/mac # equo update && equo upgrade
invalid filesystem encoding ISO-8859-1, must be UTF-8.
Make sure to set LC_ALL, LANG, LANGUAGE to valid UTF-8 values.
Please execute:
LC_ALL=en_US.UTF-8 /usr/bin/equo update
Trying to force en_US.UTF-8.
â  @@ Repositories synchronization ...
â  # Sabayon Linux Official Repository
â  # Repository URL: http://pkg.sabayon.org/standard/sabayon-weekly/database/amd64/5 [bz2]
â  # Repository URL: http://pkg.repo.sabayon.org/standard/sabayon-weekly/database/amd64/5 [bz2]
â  # Repository local path: /var/lib/entropy/client/database/amd64/sabayon-weekly/standard/amd64/5
â  # Repository API: 3
â  # (1/2) Scanning URL: http://pkg.sabayon.org/standard/sabayon-weekly/database/amd64/â ; # Selected URL: http://pkg.sabayon.org/standard/sabayon-weekly/database/amd64/5 [bz2]
â  Attention: repository is already up to date.
â  @@ Notice board: sabayon-weekly
â  [0] [Fri, 16 Sep 2016 12:09:32 +0000] Title: Sabayon Community Repositories
â  [1] [Fri, 08 Jun 2018 10:29:14 +0000] Title: Support Sabayon on Patreon
â  [2] [Sat, 16 Jun 2018 15:16:00 +0000] Title: Support Sabayon on Liberapay
â  [3] [Thu, 29 Nov 2018 12:05:30 +0000] Title: Possible problems with services after recent systemd upgrade
invalid filesystem encoding ISO-8859-1, must be UTF-8.
Make sure to set LC_ALL, LANG, LANGUAGE to valid UTF-8 values.
Please execute:
LC_ALL=en_US.UTF-8 /usr/bin/equo upgrade
Trying to force en_US.UTF-8.
â  @@ Calculating System Updates:
â  @@ Nothing to update.
â  @@ On the system there are packages that are not available anymore in the online repositories.
â  @@ Even if they are usually harmless, it is suggested (after proper verification) to remove them.
â  @@ These are the packages that should be MANUALLY removed:
â  ## [sabayonlinux.org] sys-devel/binutils-2.29.1-r1 [35.8MB]
â  ## [sabayonlinux.org] media-libs/celt-0.11.1-r1 [282.5kB]
â  ## [sabayonlinux.org] x11-libs/gksu-2.0.2-r2 [75.8kB]
â  ## [sabayonlinux.org] sys-libs/libblockdev-0.13 [1.0MB]
â  ## [sabayonlinux.org] x11-libs/libXp-1.0.3 [159.9kB]
â  ## [sabayonlinux.org] net-misc/lldpad-0.9.45 [671.2kB]
â  @@ Nothing to remove.
â  Found update: /etc/._cfg0000_hosts
â  Found update: /etc/._cfg0000_locale.gen
â  Found update: /etc/._cfg0000_ethertypes
âHá arquivos de configuração 3 requerendo atualização
âPlease run: equo conf update
âHá 2 bibliotecas preservadas no Sistema
â  /usr/lib64/libgtop-2.0.so.10.0.0 [libgtop-2.0.so.10:2 -> gnome-base/libgtop-2.36.0]
â  /usr/lib64/libgtop-2.0.so.10 [libgtop-2.0.so.10:2 -> gnome-base/libgtop-2.36.0]
sabayon /home/mac #

Como pode ver aquele traço que tinha não existe mais foi substituído por "â", além de ficar em inglês e aparecer a mensagem:

"invalid filesystem encoding ISO-8859-1, must be UTF-8.
Make sure to set LC_ALL, LANG, LANGUAGE to valid UTF-8 values.
Please execute:
LC_ALL=en_US.UTF-8 /usr/bin/equo update"

Ficou a dúvidas:

1) Porque não conseguia atualizar?
2) Qual era o problema?
3) Os problemas que ficaram depois da atualização tem como arrumar?
4) Como devo configurar os arquivos citados?




7. Re: Não consigo atualizar sabayon 18.05 [RESOLVIDO]

Mac
Skylen

(usa Slackware)

Enviado em 18/12/2018 - 17:46h

Consegui atualizar o sistema sem problemas, resumindo a solução das pergundas:

1) Porque não conseguia atualizar?
Porque não estava com todos os repositorios sincronizados.

2) Qual era o problema?
Sincronização nos repositorios.

3) Os problemas que ficaram depois da atualização tem como arrumar?
Não sei, tinha refeito o processo, não tive problema, teve ter ocorrido por ter mexido em algum arquivo, tendo como conclusão os erros citados.

4) Como devo configurar os arquivos citados?
Depois que percebir que a forma que estava configundo estava errada, era só seguir a numeração.

Obrigado pela atenção e a ajuda.




8. Re: Não consigo atualizar sabayon 18.05 [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 18/12/2018 - 20:51h

Olha, só agora ví a mensagem....

vc pegou o Sabayon 18.05 , o oficial..... ele é DE MAIO, é antigo;
Sabayon é rolling release,,,,

sugiro que faça backup de seus arquivos e instale a ISO daily, é a mais atualizada.

mais fácil é pegar a ISO daily, são os mais novos com kernel 4.18:

http://sabayon.c3sl.ufpr.br/iso/daily/

em geral, em sabayon não precisa mexer nos repos, embora possa , se quiser.

outra coisa, ainda em inglês?

SOBRE PORTAGE:

Não se pode usar direto, é preciso modificar arquivos de configuração e portage não deve ser usado para atualizar... no Sabayon, as versões de Portage, o SLOT e o EAPI e mesmo a localização do make.conf.



¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts