Erro no comando "equo upgrade" [RESOLVIDO]

1. Erro no comando "equo upgrade" [RESOLVIDO]

Israel Eriston Filgueira de Araujo
israelfilgueira

(usa Sabayon)

Enviado em 21/08/2014 - 12:26h

Bom dia, pessoal venho recorrer ao conhecimento assíduo dos senhores, eu uso a ultima versão do sabayon e quando eu fui hoje atualizar o meu sabayon com o comando Equo Upgrade , apresenta o seguinte erro
sabayon israelfilgueira # equo upgrade
Traceback (most recent call last):
File "/usr/bin/equo", line 13, in <module>
from solo.main import main
File "/usr/lib/entropy/client/solo/main.py", line 28, in <module>
from solo.commands.descriptor import SoloCommandDescriptor
File "/usr/lib/entropy/client/solo/commands/__init__.py", line 28, in <module>
__import__(_mod)
File "/usr/lib/entropy/client/solo/commands/install.py", line 18, in <module>
from entropy.locks import UpdatesNotificationResourceLock
ImportError: cannot import name UpdatesNotificationResourceLock

ja tentei atualizar, rodar outros comandos... mais não dar certo...

gostaria de uma ajudinha de voces..


  


2. Re: Erro no comando "equo upgrade" [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 21/08/2014 - 13:54h

isso parece erro de python...

rodou quais outros comandos?

primeira coisa, saída do comando:

$ eselect python list

outra coisa, está com RIGO aberto, a interface gráfica, ou clicou para atualizar em 2o plano?


3. Re: Erro no comando "equo upgrade" [RESOLVIDO]

Israel Eriston Filgueira de Araujo
israelfilgueira

(usa Sabayon)

Enviado em 21/08/2014 - 14:09h

foi assim antes de ontem eu atualizei porque o rigo estava pedindo, atualizou em segundo plano
ontem tive que atualizar para rodar porque estava instalando alguns programas, tipo virtualbox
a saida do comando foi essa Albfneto
sabayon israelfilgueira # eselect python list
Available Python interpreters:
[1] python2.7 *
[2] python3.3
[3] python3.4

e realmente ele mudou a versão do python





4. Re: Erro no comando "equo upgrade" [RESOLVIDO]

Israel Eriston Filgueira de Araujo
israelfilgueira

(usa Sabayon)

Enviado em 21/08/2014 - 14:12h

não tem nada aberto... tudo fechado..referente ao rigo


5. Re: Erro no comando "equo upgrade" [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 21/08/2014 - 15:01h

o Python 2.7 é padrão em sabayon.Ele de ter atualizado o python 2.7

tente o seguinte, reatualize o python 2.7 e re-instale apenas os pacotes do entropy:

# equo i -av python-2.7.7 entropy equo rigo magneto

agora reseleciona o python

# eselect python set 1

atualiza as configurações:

# equo conf update

Tente agora, instalar algo ou um "equo upgrade" (ou "equo u")

se não funcionar ainda, corrija as bibliotecas:

# equo libtest && equo deptest

e atualize as variáveis de ambiente:

# env-update

$ source /etc/profile (OBSERVAÇÃO: este último comando, sempre como usuário comum, nunca como Root)






6. Re: Erro no comando "equo upgrade" [RESOLVIDO]

Israel Eriston Filgueira de Araujo
israelfilgueira

(usa Sabayon)

Enviado em 21/08/2014 - 15:15h

Obrigado pela ajuda, mais todos os comandos apresentaram como saída o mesmo erro

observe:

sabayon israelfilgueira # equo libtest && equo deptest
Traceback (most recent call last):
File "/usr/bin/equo", line 13, in <module>
from solo.main import main
File "/usr/lib/entropy/client/solo/main.py", line 28, in <module>
from solo.commands.descriptor import SoloCommandDescriptor
File "/usr/lib/entropy/client/solo/commands/__init__.py", line 28, in <module>
__import__(_mod)
File "/usr/lib/entropy/client/solo/commands/install.py", line 18, in <module>
from entropy.locks import UpdatesNotificationResourceLock
ImportError: cannot import name UpdatesNotificationResourceLock



7. Re: Erro no comando "equo upgrade" [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 21/08/2014 - 19:25h


ImportError: cannot import name UpdatesNotificationResourceLock


veja sua mensagem, seu entropy está locked, travado. parec ter outro processo de entropy rodando.

vc terminou, ou cancelou a atualização em segundo plano?

por favor poste a saída destes dois comandos:

$ equo s equo (como usuário comum)
E
$ top (e veja se tem processos de entropy rodando)

Veja no site do Fabio Erculiani, desenvolvedor do Sabayon, isso é uma Classe em Python, para parar temporáriamente o processo do entropy:

http://eapi.sabayon.org/entropy.locks.UpdatesNotificationResourceLock-class.html


8. Re: Erro no comando "equo upgrade" [RESOLVIDO]

Israel Eriston Filgueira de Araujo
israelfilgueira

(usa Sabayon)

Enviado em 22/08/2014 - 01:22h

Bom Dia

chegou a terminar a atualização Albfneto

olha a saida dos comandos

[email protected] ~ $ equo s equo
Traceback (most recent call last):
File "/usr/bin/equo", line 13, in <module>
from solo.main import main
File "/usr/lib/entropy/client/solo/main.py", line 28, in <module>
from solo.commands.descriptor import SoloCommandDescriptor
File "/usr/lib/entropy/client/solo/commands/__init__.py", line 28, in <module>
__import__(_mod)
File "/usr/lib/entropy/client/solo/commands/install.py", line 18, in <module>
from entropy.locks import UpdatesNotificationResourceLock
ImportError: cannot import name 'UpdatesNotificationResourceLock'
[email protected] ~ $


Saida do comando $ top, detalhe que eu nao cheguei a ver nenhum serviço do entropy rodando



top - 22:06:26 up 9 min, 2 users, load average: 0,40, 1,27, 0,85
Tasks: 175 total, 1 running, 174 sleeping, 0 stopped, 0 zombie
%Cpu(s): 2,9 us, 1,5 sy, 0,0 ni, 95,6 id, 0,0 wa, 0,0 hi, 0,0 si, 0,0 st
KiB Mem: 2844312 total, 2457144 used, 387168 free, 81548 buffers
KiB Swap: 1832956 total, 0 used, 1832956 free. 1176576 cached Mem

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
1757 root 20 0 133412 70716 31352 S 4,3 2,5 0:15.85 Xorg
2796 israelf+ 20 0 114996 58240 28304 S 3,3 2,0 0:02.41 gnome-terminal-
2112 israelf+ 20 0 621564 235876 69856 S 2,7 8,3 0:34.23 cinnamon
2719 israelf+ 20 0 308924 92412 40144 S 1,0 3,2 0:03.35 chrome
2770 israelf+ 20 0 353168 124128 66620 S 0,7 4,4 0:07.05 chrome
1787 root 20 0 57944 14524 7488 S 0,3 0,5 0:00.59 teamviewerd
2542 israelf+ 20 0 662440 160368 100192 S 0,3 5,6 0:18.67 chrome
2812 israelf+ 20 0 5492 2844 2404 R 0,3 0,1 0:00.33 top
1 root 20 0 5168 4224 3392 S 0,0 0,1 0:01.79 systemd
2 root 20 0 0 0 0 S 0,0 0,0 0:00.00 kthreadd
3 root 20 0 0 0 0 S 0,0 0,0 0:00.24 ksoftirqd/0
5 root 0 -20 0 0 0 S 0,0 0,0 0:00.00 kworker/0:0H
7 root 20 0 0 0 0 S 0,0 0,0 0:00.38 rcu_sched
8 root 20 0 0 0 0 S 0,0 0,0 0:00.00 rcu_bh
9 root rt 0 0 0 0 S 0,0 0,0 0:01.72 migration/0
10 root rt 0 0 0 0 S 0,0 0,0 0:00.43 migration/1
11 root 20 0 0 0 0 S 0,0 0,0 0:00.01 ksoftirqd/1
13 root 0 -20 0 0 0 S 0,0 0,0 0:00.00 kworker/1:0H
14 root 0 -20 0 0 0 S 0,0 0,0 0:00.00 khelper
15 root 20 0 0 0 0 S 0,0 0,0 0:00.00 kdevtmpfs
16 root 0 -20 0 0 0 S 0,0 0,0 0:00.00 netns
17 root 0 -20 0 0 0 S 0,0 0,0 0:00.00 writeback
18 root 25 5 0 0 0 S 0,0 0,0 0:00.00 ksmd
19 root 39 19 0 0 0 S 0,0 0,0 0:00.07 khugepaged
20 root 0 -20 0 0 0 S 0,0 0,0 0:00.00 kintegrityd
21 root 0 -20 0 0 0 S 0,0 0,0 0:00.00 bioset
22 root 0 -20 0 0 0 S 0,0 0,0 0:00.00 crypto
24 root 0 -20 0 0 0 S 0,0 0,0 0:00.00 kblockd
25 root 0 -20 0 0 0 S 0,0 0,0 0:00.00 ata_sff
26 root 20 0 0 0 0 S 0,0 0,0 0:00.00 khubd
27 root 0 -20 0 0 0 S 0,0 0,0 0:00.00 md




eu olhei o site do desenvolvedor rodei ate o cod dele e não funcionou


9. Re: Erro no comando "equo upgrade" [RESOLVIDO]

Israel Eriston Filgueira de Araujo
israelfilgueira

(usa Sabayon)

Enviado em 22/08/2014 - 02:31h

Alfbneto o meu professor da faculdade, rodou essa atualização no meu sistema e não deu certo...
ele também usa sabayon


segue o código
su root -c "clear ; equo rescue spmsync ; equo update --force ; equo repo mirrorsort sabayon-weekly ; equo install entropy rigo equo --relaxed ; equo conf update ; equo upgrade ; equo upgrade --ask ; equo install equo entropy ; equo conf update ; equo deptest ; equo libtest ; emerge --sync ; layman -S ; shutdown -h now"

a saida do comando foi o mesmo erro, detalhe que agora eu verifiquei e nao abre nem o sulfur e nem o rigo e nenhum comando do equo é carregado...


10. Re: Erro no comando "equo upgrade" [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 22/08/2014 - 13:41h

Nos meus Sabayons, as atualizações estão funcionando, tudo normal!


Está parecendo que seu python está corrompido. Todos os comandos que seu professor fez, também dão o mesmo erro?


O que poderia ser tentado, antes de re instalar tudo:



Uma coisa que está me intrigando vc disse que tem SULFUR? Se tem Sulfur seu Sabayon é muito antigo! Sulfur não existe mais, agora é Rigo... Vc não atualizou algum Sabayon muito velho?

quanto as outras observações suas, claro que o rigo não abrirá, ele é interface gráfica do entropy, do equo.



Faça backup de seus arquivos!

depois

Tente trocar o python por uma versão superior, e rodar de novo o comando de equo:

eselect python list
# eselect python set número do python 3 (não 2) mais novo
# equo i entropy equo rigo

Outro jeito ( só deve ser feito para consertar coisas e não tente sem backup):

reinstalar o entropy, o equo e o rigo, mas com portage.

Edite o arquivo /etc/entropy/client.conf e na linha escrito "ignore pseudodowgrades", troque "disable" por "enable".

agora faça:

# emerge --sync
# LINGUAS-pt_BR" emerge -av entropy equo rigo magneto


11. Re: Erro no comando "equo upgrade" [RESOLVIDO]

Israel Eriston Filgueira de Araujo
israelfilgueira

(usa Sabayon)

Enviado em 22/08/2014 - 15:52h

boa tarde, Alfbneto
tinha sim, para atualizar algumas coisas, e faz tempo q ele foi descontinuado, o meu sabayon é o mais novo

saida do comando de python

sabayon israelfilgueira # eselect python list
Available Python interpreters:
[1] python2.7
[2] python3.3
[3] python3.4 *
sabayon israelfilgueira # eselect python list set 3
!!! Error: Unrecognized argument 'set'
exiting
sabayon israelfilgueira #


a saida do outro comando

sabayon israelfilgueira # equo i python equo rigo
Traceback (most recent call last):
File "/usr/bin/equo", line 13, in <module>
from solo.main import main
File "/usr/lib/entropy/client/solo/main.py", line 28, in <module>
from solo.commands.descriptor import SoloCommandDescriptor
File "/usr/lib/entropy/client/solo/commands/__init__.py", line 28, in <module>
__import__(_mod)
File "/usr/lib/entropy/client/solo/commands/install.py", line 18, in <module>
from entropy.locks import UpdatesNotificationResourceLock
ImportError: cannot import name 'UpdatesNotificationResourceLock'
sabayon israelfilgueira #



outra saida do comando
LINGUAS="pt_BR" emerge -av entropy equo rigo magneto
!!! Found 2 make.conf files, using both '/etc/make.conf' and '/etc/portage/make.conf'
--- Invalid atom in /etc/portage/package.accept_keywords: eixt

* IMPORTANT: 10 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "magneto".

emerge: searching for similar names...
emerge: Maybe you meant any of these: kde-misc/magneto-kde, x11-misc/magneto-gtk, x11-misc/magneto-gtk3?


12. Re: Erro no comando "equo upgrade" [RESOLVIDO]

Israel Eriston Filgueira de Araujo
israelfilgueira

(usa Sabayon)

Enviado em 23/08/2014 - 01:32h


Albfneto, obrigado pela ajuda, consegui resolver...
segue a baixo a forma q eu consegui resolver...


estou grato pela ajuda, então sempre estarei postando algo sobre sabayon para ajudar

Instalando entropy via Portage pode ser concluída usando o procedimento abaixo. Abra um terminal (como o konsole) e digite os comandos:
1 Torne-se root (digite a senha de root quando solicitado):
$ su
2 Atualize as sobreposições Sabayon para as versões mais recentes:
# Layman --sync sabayon
# Layman --sync sabayon-distro
Se você receber uma mensagem de erro que as sobreposições não existem, então você precisa adicioná-los:
# Layman --add sabayon
# Layman --add sabayon-distro
3. Emerge Entropy, Equo e Rigo para instalar as versões mais recentes:
# Emerge entropia equo rigo
4 Para testar que está funcionando, execute:
# Equo --version
Se você receber um número de versão, tais como:
entropia: 285
equo: 285


fonte:https://wiki.sabayon.org/index.php?title=En:Entropy#Upgrading_Entropy_using_Equo



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts