"problema para atualizar" ou "meu synaptic não abre" ou "procuro um repositório que não existe"

1. "problema para atualizar" ou "meu synaptic não abre" ou "procuro um repositório que não existe"

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 01/03/2015 - 11:12h

Olá amigos, estou com problemas para atualizar meu Linux Mint Rebecca Mate 64bit, http://imgur.com/aRelxJp e http://imgur.com/fDnSkPm
busquei fóruns, tutoriais, tentei alguns procedimentos, dentre eles
sudo apt-get --fix-broken install 
e dá isso http://imgur.com/zFC4PQA, sempre "failed to fetch http://extra.linuxmint.com/dists/rebecca/Release";
enfim, a situação é essa:
$ lsb_release -a
$ cat /etc/apt/sources.list
$ ls /etc/apt/sources.list.d/

http://pastebin.com/aGU56nje
$ sudo apt-get update
$ sudo apt-get dist-upgrade -s

http://pastebin.com/nJpt3wbL
alguém saberia me dar uma luz quanto a isso?
(tenho dificuldades ainda para categorizar as perguntas, no geral me parece que é um problema de "banco de dados", e confesso que "chutei" a subcategoria, me desculpem se o chute foi muito distante)
Abraço





  


2. Re: "problema para atualizar" ou "meu synaptic não abre" ou "procuro um repositório que não existe"

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 01/03/2015 - 11:16h


sudo rm /var/lib/apt/lists/lock
sudo rm /var/lib/dpkg/lock
sudo apt-get update
sudo apt-get upgrade


3. Re: "problema para atualizar" ou "meu synaptic não abre" ou "procuro um repositório que não existe"

edps
edps

(usa Slackware)

Enviado em 01/03/2015 - 11:25h

woody143a escreveu:

Olá amigos, estou com problemas para atualizar meu Linux Mint Rebecca Mate 64bit, http://imgur.com/aRelxJp e http://imgur.com/fDnSkPm
busquei fóruns, tutoriais, tentei alguns procedimentos, dentre eles
sudo apt-get --fix-broken install 
e dá isso http://imgur.com/zFC4PQA, sempre "failed to fetch http://extra.linuxmint.com/dists/rebecca/Release";
enfim, a situação é essa:
$ lsb_release -a
$ cat /etc/apt/sources.list
$ ls /etc/apt/sources.list.d/

http://pastebin.com/aGU56nje
$ sudo apt-get update
$ sudo apt-get dist-upgrade -s

http://pastebin.com/nJpt3wbL
alguém saberia me dar uma luz quanto a isso?
(tenho dificuldades ainda para categorizar as perguntas, no geral me parece que é um problema de "banco de dados", e confesso que "chutei" a subcategoria, me desculpem se o chute foi muito distante)
Abraço




Pelo o que você postou, seu sources.list está zerado, só tem a referência (comentada) a um CD de instalação.

Peça ao @clodoaldops, que também está tentando lhe ajudar a lhe fornecer uma cópia dos repositórios default dessa versão do Linux Mint.

E cuidado com esse excesso de PPAs, é isso o que quebra sistemas!





4. Re: "problema para atualizar" ou "meu synaptic não abre" ou "procuro um repositório que não existe"

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 01/03/2015 - 11:30h


http://pastebin.com/htSNkZ7G


5. Re: "problema para atualizar" ou "meu synaptic não abre" ou "procuro um repositório que não existe"

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 01/03/2015 - 11:42h

Tente aí:
Menu >> Aplicativos >> Administração >> Fontes de Aplicativos >> Repositórios Oficiais >> Restaurar



6. Re: "problema para atualizar" ou "meu synaptic não abre" ou "procuro um repositório que não existe"

edps
edps

(usa Slackware)

Enviado em 01/03/2015 - 11:49h

woody143a escreveu:


http://pastebin.com/htSNkZ7G


NUNCA responda com "y" as perguntas do tipo (todas elas!):

Configuration file '/etc/issue'

==> Modified (by you or by a script) since installation.

==> Package distributor has shipped an updated version.

What would you like to do about it ? Your options are:

Y or I : install the package maintainer's version

N or O : keep your currently-installed version

D : show the differences between the versions

Z : start a shell to examine the situation

The default action is to keep your current version.

*** issue (Y/I/N/O/D/Z) [default=N] ? y

Installing new version of config file /etc/issue ...


Observe próximo ao final da pergunta o texto The default action is to keep your current version., ou seja a opção padrão é manter a versão corrente do arquivo, ou seja, ou vc tecla ENTER (somente) ou tecla N e ENTER.

* pelo que você fez, provavelmente a identificação de seu sistema passará a ser Ubuntu Trusty.

Reinicie e veja como vai ficar.

Outra coisa são os erros de locale, que parecem estar ocorrendo, talvez seja necessário rodar:

$ sudo dpkg-reconfigure locales 


E marcar apenas os locales:

[*] pt_BR ISO-8859-1
[*] pt_BR.UTF-8 UTF-8


E na tela seguinte marcar:

pt_BR.UTF-8

* para marcar use a barra de espaço e para alternar entre as opções use a tecla TAB e para confirmar ENTER




7. Re: "problema para atualizar" ou "meu synaptic não abre" ou "procuro um repositório que não existe"

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 01/03/2015 - 13:18h

puuuutz... reverto isso com os mesmos comandos? acho que não deu:


http://pastebin.com/3tW8L0J3


8. Re: "problema para atualizar" ou "meu synaptic não abre" ou "procuro um repositório que não existe"

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 01/03/2015 - 13:21h


mandei restaurar os repositórios originais agora


9. Re: "problema para atualizar" ou "meu synaptic não abre" ou "procuro um repositório que não existe"

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 01/03/2015 - 13:31h


não sei em que pé que a coisa anda. voltou pro inglês o sistema, perguntou se eu queria atualizar o nome das pastas para o novo idioma, e no "update manager" consta como "up to date"


10. Re: "problema para atualizar" ou "meu synaptic não abre" ou "procuro um repositório que não existe"

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 01/03/2015 - 18:20h


http://pastebin.com/64nDQNMU



11. Re: "problema para atualizar" ou "meu synaptic não abre" ou "procuro um repositório que não existe"

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 01/03/2015 - 18:26h

woody143a escreveu:

não sei em que pé que a coisa anda. voltou pro inglês o sistema, perguntou se eu queria atualizar o nome das pastas para o novo idioma, e no "update manager" consta como "up to date"


Atualize pelo atualizador de programas... Depois vá em language settings e selecione pt.br... Depois reinicie sessão e escolha idioma





12. Re: "problema para atualizar" ou "meu synaptic não abre" ou "procuro um repositório que não existe"

Mário Borba
woody143a

(usa Linux Mint)

Enviado em 01/03/2015 - 18:33h

eu já tinha ido no language settings, está todo estranho, não aparecem pacotes de linguagem:
http://imgur.com/r0P20Mt
http://i.imgur.com/YR4qTVh.png

com relação ao update manager, consta sempre que o sistema está atualizado (e tinha mais ou menos 1 gb de atualizações pra fazer), fiquei com receio que fosse por ter eventualmente trocado a identificação do sistema para ubuntu trusty, se isso tiver acontecido.



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts